Ubuntu 17.10 congela durante o boot [Resolvido]

Publicado por Xerxes Lins em 20/10/2017

[ Hits: 7.089 ]

Blog: https://voidlinux.org/

 


Ubuntu 17.10 congela durante o boot [Resolvido]



Dica testada no Ubuntu 17.10.

Durante o carregamento do sistema, o Ubuntu congela antes de abrir a tela de login.

Com a dica de hellnux, eu reiniciei o sistema e antes de congelar pressionei Esc. Assim as mensagens foram exibidas. O sistema congelava com o seguinte texto por último:

Started User Manager for UID 121
Como resolvi? Duas coisas: chroot para instalar gnome-session e depois descomentar uma linha num arquivo.

Procedimento

Dê boot pelo live-cd, abra terminal (Ctrl+Alt+t). Vamos supor que a raiz do seu sistema esteja em "/dev/sda1". Execute:

sudo mount /dev/sda1 /mnt
$ sudo cp -L /etc/resolv.conf /mnt/etc/resolv.conf
$ sudo mount --bind /dev /mnt/dev
$ sudo mount --bind /proc /mnt/proc
$ sudo mount --bind /sys /mnt/sys
$ sudo chroot /mnt
$ apt update
$ apt upgrade
$ apt install gnome-session
$ sudo nano /etc/gdm3/custom.conf


Descomente a linha:

WaylandEnable=false

Salve e feche. Reinicie.

Aqui funcionou.

Fonte: Bug #1723577 “No login screen (mutter silently goes headless) on...” : Bugs : gnome-shell package : Ubuntu

Outras dicas deste autor

Como usar seu Iphone como controle sem fio para jogar no Linux

Jogo AlterEgo do Desura não funciona [Resolvido]

NOVO: Sauerbraten - Justice Edition

Linux Mint 17.1 com Enlightenment

Abrir apps automaticamente em áreas de trabalho ao iniciar o i3wm

Leitura recomendada

Analisado logs do Samba

Samba + Clamav no Slackware 10.1

Auto-executar um aplicativo no momento do logon do Gnome

Personalização do XFCE

Como restaurar o logo da tela de boot no Ubuntu

  

Comentários
[1] Comentário enviado por clodoaldops em 21/10/2017 - 10:26h

-em qual hardware ocorre esse congelamento??
-aqui num ci3/4gb/intel-hd não correu nenhum vez

[2] Comentário enviado por xerxeslins em 23/10/2017 - 15:26h


[1] Comentário enviado por clodoaldops em 21/10/2017 - 10:26h

-em qual hardware ocorre esse congelamento??
-aqui num ci3/4gb/intel-hd não correu nenhum vez



Clodoaldo, segue configuração:

processador: 4x AMD Phenom(tm) II X4 B97
4GB RAM
Placa de vídeo onboard: Radeon HD 4200 de 512MB

[3] Comentário enviado por clodoaldops em 24/10/2017 - 20:07h

Eu desconfiava que amd/ati tinha algo haver com esse problema.
Por isso eu corro de pc com essas placas de video.
Obrigado pelo esclarecimento.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts