Ubuntu 12.04 - Resolvendo problema do Java 7

Publicado por Francisco Jeova em 14/05/2012

[ Hits: 27.663 ]

 


Ubuntu 12.04 - Resolvendo problema do Java 7



Instalando Java 7 no Ubuntu 12.04.

Resolvendo problema do Java 7 no Ubuntu 12.04

Algumas pessoas estão com dificuldades para instalar o Java neste novo Ubuntu.

Ao instalar a versão 6, estão acontecendo muitos erros, dependências que estão faltando, etc.

Então, aconselho que siga estes passos para resolver totalmente os erros de instalação do Java:

sudo add-apt-repository ppa:webupd8team/java && sudo apt-get update
$ sudo apt-get install oracle-jdk7-installer


* Lembrando que o Java, é a versão '1.7.0_04'.

Muito obrigado.

Outras dicas deste autor

Montar imagem ISO para abrir VLC

Leitura recomendada

Elastix - Ligações ocupadas entre os ramais (não respondem à queue)

Usando open source no SO comercial da Microsoft

Instalar o Gambas 3

Nagios Core 4.0.6 no CentOS 6.5

Blender ou KDEnlive?

  

Comentários
[1] Comentário enviado por removido em 15/05/2012 - 17:50h

Adorei a dica..

funcionou corretamente no meu!

[2] Comentário enviado por jeovapinheiro em 15/05/2012 - 22:21h

Certo meu amigo obrigado.

[3] Comentário enviado por carlindojs em 16/05/2012 - 21:15h

Gostaria de saber o seguinte:

1) Você fez a instalação no ubuntu 12.04 desktop 64bits? Ocorreu tudo bem ou teve que fazer algum ajuste/configuração adicional?
-Porque quando instalei, o banco do brasil acusava que eu não tinha o java instalado, reiniciei, reinstalei e nada. Solução: formatei e coloquei o ubuntu 12.04 32bits e aí sim funcionou mas gostaria de instalar no 64bits.

2) Qual o procedimento para desinstalar o java7 por completo no ubuntu 12.04 64 bits?
-usei o sudo apt-get purge oracle-jdk7-instalaller* e tive a impressão que não removeu a instalação por completo.

Desde já, agradeço a atenção e peço desculpas por tantas dúvidas, é que sou novo no linux.

obs: utilizo Firefox e Chrome.




[4] Comentário enviado por jeovapinheiro em 16/05/2012 - 22:15h

Cara essa instalacao java 7 funciona em qualquer plataforma ubnuntu 12.04 32bits, ou 64 bits, post o erro que aconteceu com o seu que eu posso ti ajudar mais um pouco.

[5] Comentário enviado por migueldefaria em 19/05/2012 - 14:02h

Valeu ! Graças a esta dica posso pagar minhas contas através do Firefox e Chrome. Uso o Itaú e a equipe do 0300 de lá não conseguiu me ajudar a instalar o próprio guardião. Agredecido mesmo.

[6] Comentário enviado por fpflug em 23/05/2012 - 20:28h

Perfeito no kubuntu 64 bits para resolver o problema do Guardiao30horas do Itaú.

[7] Comentário enviado por marcosbadu em 11/06/2012 - 19:06h

Muito bom, mandei instalar e funcionou perfeitamente, valeu cara brigado e fica com deus.

[8] Comentário enviado por henbran em 15/06/2012 - 16:32h

Boa Tarde ...
Estou em uma ambiente que é rede interna, com proxy com autenticação (dominio/usuario .... senha) para navegar.

apliquei o comando para add o repositório e ...


[email protected]:/usr/lib/jvm$ sudo add-apt-repository ppa:webupd8team/java && sudo apt-get update
Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 125, in <module>
ppa_info = get_ppa_info_from_lp(user, ppa_name)
File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 80, in get_ppa_info_from_lp
curl.perform()
pycurl.error: (56, 'Received HTTP code 407 from proxy after CONNECT')
[email protected]:/usr/lib/jvm$



teria alguma forma de contornar isso?

[9] Comentário enviado por jeovapinheiro em 15/06/2012 - 16:42h

Provavelmente o proxy esta bloqueando sua maquina para emcontrar esses repositorios, fala com quem administra a rede que talvez seja algum bloqueio.

[10] Comentário enviado por marcusampaio em 01/08/2012 - 22:04h

Caro carlindojs sou novo tb no mundo Linux e estou gostando muito!Mas vamos ao principal o seu problema o qual eu também tive.Tentei varias alternativas e nada só funcionar em 32 bits e então fiz o seguinte o mais fácil, fui a central de do Ubuntu 12.04 64bits e digitei na busca "java" (sem aspas) e instalei o aplicativo "Tempo de execução OpenJDK Java 7" (sem aspas) e pronto funcionou perfeitamente no Firefox 14.0.1 e Chrome Versão 21.0.1180.57 beta.

[11] Comentário enviado por f3rr3ll em 03/09/2012 - 15:56h

Antes eu instalava o java6 com o comando, "sudo apt-get install sun-java6-jdk sun-java6-jre", e funcionava de boa na versão Ubuntu 10.10, como eu migrei para o Ubuntu 12.04, num rolo, testei o comando do post a cima e realmente funcionou de boa para instalar o jdk e quanto ao jre ?

Passa awe o comando para instalar o pacote completo JRE7 + JDK7.

[12] Comentário enviado por alex_sinop em 17/09/2012 - 07:34h

Olá

Gostaria de uma ajuda de vocês, por favor. Sou novo no Linux, já tentei usar antes, mas foram tantas complicações que desisti. Agora, vou tentar novamente, e tenho problemas para acessar o site do banco do brasil via firefox e chrome também.

quando acesso o site, ele diz que é preciso instalar o pacote de segurança. quando vai para o site do java, lá diz que tenho a última versão instalada. daí não entendo o porque de o site do BB não reconhecer a minha instalação do java.

Por favor, gostaria de receber ajuda, qualquer coisa sobre a instalação, pode perguntar.

Muito obrigado.

[13] Comentário enviado por floyd2000 em 18/09/2012 - 00:10h

Para quem tiver problemas com o BB, é só instalar, "sudo apt-get install openjdk-7-jre", e o pacote de plugins,
"sudo apt-get install icedtea-7-plugin". Inclusive sistemas 64 bit.

[14] Comentário enviado por Fsnet em 21/09/2012 - 14:43h

Depois de mim instalar Oracle java 7 o meu eclipse parou de funcionar, o que faço?

[15] Comentário enviado por wesleir2006 em 22/03/2013 - 13:18h

Muito bom essa dica > além de resolver o problema ele atualizou para a versão mais nova do java.
Obrigado!



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts