Tela de boot feia no Ubuntu 14.04 após instalar drivers NVIDIA [Resolvido]

Publicado por Pedro Souza em 09/07/2015

[ Hits: 3.389 ]

 


Tela de boot feia no Ubuntu 14.04 após instalar drivers NVIDIA [Resolvido]



O Ubuntu 14.04 tem um pequeno bug que quando você instala os drivers proprietários da NVIDIA ou ATI: a tela de boot do Ubuntu fica grande e estraga a excelente arte feita no logotipo do sistema.
Linux: Tela de boot feia no Ubuntu 14.04 após instalar drivers NVIDIA [Resolvido]
É bem fácil de corrigir esse problema.

Abra o terminal (Ctrl + Alt + T) e digite os seguintes códigos (um de cada vez). A qualquer momento sua senha pode ser pedida. Nesse caso digite-a e confirme com um enter:

sudo apt-get install v86d
sudo gedit /etc/default/grub

No arquivo que deve ser aberto no editor de texto Gedit, busque por esse texto (linha 9):

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

E substitua por:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap"

Faça o mesmo para a (linha 18):

#GRUB_GFXMODE=640x480

Substitua por:

GRUB_GFXMODE=1280x1024

Salve as alterações e feche o editor de texto.

Voltando ao terminal, digite e dê um enter:

sudo gedit /etc/initramfs-tools/modules

No arquivo que se abrir, adicione a linha seguinte no final do texto e salve as alterações:

uvesafb mode_option=1280x1024-24 mtrr=3 scroll=ywrap

Para finalizar, entre com os três seguintes comandos no terminal (uma de cada vez):

echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
sudo update-grub
sudo update-initramfs -u

Pronto. Feche o terminal, reinicie o sistema e aprecie a tela de carregamento impecável do Ubuntu 14.04.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Erro: msgfmt [Resolvido]

Iniciar o Windows em um HD secundário através do GRUB

Configurar Apache e MySQL para não iniciar no boot no Linux Mint e Ubuntu

Criando atalhos (arquivos *.desktop) manualmente no KDE, Gnome e XFCE

LPRNG no Debian 7 - Erro:LPD doesn't listen on port 515 [Resolvido]

  

Comentários
[1] Comentário enviado por arielkollross em 08/09/2016 - 17:58h

Para mim funcionou ate certa parte, agora a tela esta iniciando normalmente, com o logo e tals, mas ápos alguns segundos, ocorre um erro com a seguinte mensagem:

2.441707 ata5: WARNING: synchronous SCSI scan failed without making any prress, switching to async

to usando o Lubuntu, com Nvidia 9600 GSO




Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts