Resolvendo problema ao subir DHCP no Debian Sarge

Publicado por Rey Junior em 28/02/2007

[ Hits: 7.492 ]

 


Resolvendo problema ao subir DHCP no Debian Sarge



Tive alguns problemas ao habilitar o servidor DHCP com o Debian Sarge, porém não sei se em todas versões do Sarge ocorrem esse problema.

Então vou dividir com vocês a solução que eu adotei... não sei se é a melhor, mas funcionou.

Caso ocorra este erro, quando vai subir o servidor DHCP:

No subnet declaration for eth0 (x.x.x.x). Please write a subnet declaration in your dhcpd.conf file for the network segment to which interface eth0 is attached.

Efetuar os procedimentos abaixo:

# vi /etc/init.d/dhcp

Alterar a linha:

INTERFACES="eth0"

para:

INTERFACES="eth1"

# /usr/sbin/dchpd eth1
# /etc/init.d/networking stop
# /etc/init.d/networking start
# /etc/init.d/dhcp start


Pode-se criar um script para rodar isso sempre no boot, para que carregue automaticamente ao ligar o servidor, incluindo apenas o comando:

# /usr/sbin/dhcpd eth1

Outras dicas deste autor

Resolvendo bug de trocar avatar e enviar arquivos do aMSN 0.97

Uma dica de firewall baseado em iptables

Compilar aMSN 0.96 com fontes antialiasing

Dica para instalar webcam no Fedora Core 6

Leitura recomendada

Corrigir hora dos gráficos do Zabbix Appliance

Fim dos "estalos" de som no Ubuntu 9.10 (Karmic Koala)

Restaurando o painel do KDE

Baixou o Ubuntu 14.10 Utopic [sem suporte] no Site Oficial? Relaxe, temos a solução pra você!

Instalando LXQt no CentOS 7

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário