Resolvendo os problemas com o pacote install-info

Publicado por Virtuanet em 20/04/2011

[ Hits: 33.543 ]

Blog: http://blog.virtuanet.com.br

 


Resolvendo os problemas com o pacote install-info



Olá amigos do VOL,

Recentemente tive dificuldades para instalar alguns pacotes e até mesmo atualizar o sistema (Ubuntu 10.10) em minha máquina devido a várias mensagens de erro que referenciavam o pacote INSTALL-INFO.

Segue um exemplo da mensagem de erro mostrada pelo sistema:

Configurando install-info (4.13a.dfsg.1-5ubuntu1) ...
/etc/environment: linha 4: Acquire: comando não encontrado
dpkg: erro processando install-info (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 127
Erros foram encontrados durante o processamento de:
install-info
E: Sub-process /usr/bin/dpkg returned an error code (1)


Bom, vamos ao que interessa.

Como o pacote install-info está truncado, e o mesmo se encontra no cache de repositório local da sua máquina, ele precisará ser removido desse repositório para resolver o problema. Execute os comandos descritos abaixo:

# cd /var/lib/dpkg/info/
# ls | grep "install-info"


Serão listados todos os pacotes relacionados ao "install-info" que precisarão serem removidos.

Então execute o seguinte:

# rm install-info*
# apt-get install -f
# dpkg --configure -a


O comando "apt-get install -f" corrige um sistema com dependências quebradas. E o comando "dpkg -- configure -a " reconfigura quaisquer pacote desempacotado que ainda não foi configurado.

Desta forma eliminamos os problemas do pacote "install-info" definitivamente.

Grande abraço a todos, e se lhe foi útil esta dica, não esqueça de colocá-la em seus favoritos...

Outras dicas deste autor

Ubuntu 6 com MySQL permitindo conexão remota

Instalando seu adaptador Wireless usando o drive do windows (Debian/Ubuntu /Derivados)

Instalando o BrOffice 3.0.1 no Debian ou Ubuntu Linux

Leitura recomendada

Configuração da montagem de disquetes no Slackware 10.1

Solus OS não inicializa após atualização [RESOLVIDO]

Disco de inicialização com o LILO

Problemas com dvd/cdrom (scd0) no Ubuntu

Acessar diretórios Windows pela rede

  

Comentários
[1] Comentário enviado por snowbg em 17/10/2012 - 13:22h

Cara! Muito obrigado!!

Sua dica me salvou a vida!!! Valeu mesmo!

[2] Comentário enviado por virtuanet em 18/10/2012 - 00:12h

Obrigado snowbg,

Fico feliz em ter ajudado.

Se quiser salvar em seus favoritos, facilitará a localização futura da dica.

Até mais!

[3] Comentário enviado por mateusaires3 em 26/03/2014 - 11:48h

Valew cara, me ajudou bastante !

[4] Comentário enviado por gpzim98 em 26/03/2014 - 20:31h

Haha... Simplesmente show de bola amigo, simples e funcionou perfeitamente.

[5] Comentário enviado por virtuanet em 26/03/2014 - 20:36h

Olá gpzim98,

Obrigado e que bom que lhe ajudou.

Até mais!

[6] Comentário enviado por virtuanet em 26/03/2014 - 20:37h

Que bom mateusaires3, abraço!

[7] Comentário enviado por crebs86 em 14/05/2017 - 09:23h

Valeuuu, salvando ainda em 2017.
Estava com problemas com "unattended-upgrades", mas a lógica é a mesma!

[8] Comentário enviado por DanielDDu em 05/07/2017 - 09:04h

Estou muito grato. Essa sua dica foi fantástica. Já tinha testado de tudo. Resolveu mesmo. No meu caso foram três de uma vez util-linux, systemd e openvpn. Linux Mint. Como disse o crebs86: "salvando ainda em 2017".



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts