Resolvendo o problema do Adobe Reader 7.0.9 no Fedora 7

Publicado por Bruno Bispo em 17/06/2007

[ Hits: 5.689 ]

 


Resolvendo o problema do Adobe Reader 7.0.9 no Fedora 7



Como muitos usuários do recente Fedora Core 7 podem ter percebido, o Adobe Reader versão 7.0.9, última versão até a data desta dica, apresenta um problema que impede o seu funcionamento.

Para solucionar este problema, abra o seguinte arquivo como super usuário:

# gedit /usr/local/Adobe/Acrobat7.0/bin/acroread

E faça as seguintes modificações:

1) Na linha 418, substitua:

echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'

por:

echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]*\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'

2) Na linha 643, substitua:

MIN_GTK_VERSION="240"

por:

MIN_GTK_VERSION="2040"

Salve o arquivo e pronto, seu Adobre Reader 7.0.9 já estará funcionando corretamente.

Outras dicas deste autor

Fazendo a inicialização do seu Fedora Core 2 mais rápida

Instalando o Cairo-Dock no Fedora Core 8

Leitura recomendada

Synaptic - Como é fácil instalar programas no Linux [Vídeo]

Liberando Java 7 no Firefox pelo PlayOnLinux/Wine

Um bom programa de CAD para LInux

Visualizando o tráfego de rede de forma organizada com Weathermap + MRTG

GIMP - Calculando áreas com Area plugin

  

Comentários
[1] Comentário enviado por HolyMurderer em 17/06/2007 - 10:09h

Isso é um problema não do Fedora, mas sim do Adobe Reader em geral. Isso acontece com muitas mais distros e é fácil de resolver, é só fazer isto:

1- Editar o ficheiro /usr/local/Adobe/Acrobat7.0/bin/acroread, com algum editor de texto. Tem que ser feito em modo root.
2- Achar a função get_gtk_file_ver() e, substituir o texto "echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'" (sem aspas) por "echo $mfile| sed 's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]*\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'", também sem aspas, mas com plicas (').
3- Salgar/Guardar o ficheiro.
4- Correr o Adobe Reader :)

O 2º passo que referiste é desnecessário.

[2] Comentário enviado por removido em 17/06/2007 - 21:24h

êta buguezinho ordinário da gota...

[3] Comentário enviado por coffnix em 18/06/2007 - 16:30h

use gentoo e compile seu software vc mesmo!!!! :D

[4] Comentário enviado por [email protected] em 26/08/2008 - 11:51h

quero resouver oproblema meu computador

[5] Comentário enviado por [email protected] em 26/08/2008 - 11:53h

quero resouver o pro blema do meu adobe



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts