Recuperando lilo depois de uma instalação do Windows

Publicado por Perfil removido em 31/08/2009

[ Hits: 6.875 ]

 


Recuperando lilo depois de uma instalação do Windows



Quando possuímos o Linux e instalamos o Windows, o "sistema proprietário" reescreve a MBR e deleta o lilo, impossibilitando a inicialização de outros sistemas instalados na máquina. Aqui mais um tutorial de fácil reinstalação.

Bom, como sou utilizador e admirador dessa ótima distribuição que é chamada de Slackware, explicarei por ela.

Logicamente você vai precisar de um DVD da distribuição, que pode ser encontrado aqui:
Depois de baixar você precisará queimar um DVD com a imagem. Depois disso continue nos passos seguintes.

Se quiser fazer isso com outra distribuição, também funciona. Ligue pelo live-cd da distribuição e siga os mesmos passos em um terminal. Não vai mudar nada.

Iniciando:
  • Vá para a BIOS e coloque seu computador para dar boot pelo CD/DVD;
  • Ligue o computador pelo DVD do Slackware.

Aparecerá uma tela pedindo algum comando. Só tecle enter e irá começar o carregamento.

Após terminar irá pedir o login, tecle enter.

Aparecerá uma janela para selecionar o tipo de teclado. Encontre o seu tipo (geralmente ABNT2), teste na janela que aparecer, se estiver tudo ok digite "1" e tecle enter.

Agora você está no prompt de comando.

Verifique onde está o seu sistema Linux instalado.

A minha saída foi essa:

# fdisk -l
Disk /dev/hda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xe053e053

   Device Boot   Start    End      Blocks   Id  System
/dev/hda1           1     2040    16386268+   5  Extended
/dev/hda2   *    2041     3587    12426277+   7  HPFS/NTFS
/dev/hda3        3588     4832    10000462+  83  Linux
/dev/hda4        4833     4865      265072+  82  Linux swap
/dev/hda5           1     2040    16386237   83  Linux

Meu sistema está instalado na partição /dev/hda3 (porque eu lembro que instalei ali, só verifiquei as partições como estavam).

Agora vamos montar a partição. No meu caso:

# mount /dev/hda3 /mnt

Bom, como você instalou o Windows depois do Linux, o lilo não possui as configurações para carregar o Windows, então vamos configurá-lo:

# pico /mnt/etc/lilo.conf

Adicione as linhas:

other = /dev/hda2
label = Windows
table = /dev/hda

Logicamente, mudando o /dev/hda2 pelo local onde você instalou o Windows, no meu caso foi /dev/hda2, mas pode ser /dev/hda4; /dev/sda1; /dev/sda5; e assim vai. Mude pelo local onde você instalou. Somente essas linhas bastam.

Salve o arquivo e saia do editor (CTRL+X / Y / "enter"). Agora está na hora de regravar o Lilo na MBR com o comando:

# lilo -C /mnt/etc/lilo.conf -v

Pronto, agora reinicie o computador e você estará com o lilo funcionando como era antes e com o Windows adicionado.

Nathan Scapini

Outras dicas deste autor

Internet discada com Discador Orolix

Assistir os trailers de filmes no site da Apple pelo Firefox

Sound Juicer: Ripando CDs de áudio para MP3

Configurando sua impressora de rede no KDE

Documentação nos pacotes do Projeto GNU

Leitura recomendada

OpenJDK7 64 bits e Banco do Brasil [RESOLVIDO]

Áudio no Gnome: nenhum módulo e/ou dispositivo do GStreamer de controle de volume foi encontrado

Ajustar o relógio no Debian Etch

Recuperando tela de login no Ubuntu

Firefox não está em pt-BR no Funtoo [Resolvido]

  

Comentários
[1] Comentário enviado por removido em 24/02/2014 - 17:44h

Muito bom,me ajudou muito aqui!



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts