Putty: VIM com acentuação

Publicado por Thiago Fernandes de Melo em 11/09/2008

[ Hits: 21.578 ]

Blog: http://www.hospedarfacil.com.br

 


Putty: VIM com acentuação



Olá pessoal, frequentemente utilizamos o putty para acessar através do SSH servidores Linux em outros lugares, e quando usamos o editor VIM e escrevemos alguma palavra com acentuação, o acento não aparece, ou aparece caracteres estranhos no lugar.

Com essa configuração podemos utilizar acentuação no VIM através do putty.

Vamos alterar de UTF-8 para ISO-8859-1, assim permitindo acentuação.

Adicionem no início do /etc/vimrc (servidor Linux):

set encoding=iso-8859-1
set fileencodings=iso-8859-1

Comentem todas as linhas antes dessa: set nocompatible

Essa não precisa comentar.

Salvem e fechem, em seguida editem um arquivo com o vim e tentem acentuar as palavras.

:D

Espero que seja útil a vocês assim como foi pra mim.

Outras dicas deste autor

Postfix bloqueando e-mails indesejados

Enviando dados em formulário através de variáveis ocultas

SSH: Somente usuários autorizados

Squid: Autenticando em /etc/shadow

LSOF: Quem está ouvindo aí no seu Linux?

Leitura recomendada

Vim editor - inserir e retirar numeração de linhas

Como rodar o Firefox3 em seu Debian Etch

Acesso SSH/FTP no Linux pelo Windows

Instalando o navegador Opera no Ubuntu 20.04 LTS

Pogo Audio Player no Arch Linux, Debian, Slackware e Ubuntu

  

Comentários
[1] Comentário enviado por voyeg3r em 25/09/2008 - 16:34h

Ao invés de alterar a configuração no servidor eu descobri um jeito mais simples.

O putty tem uma opção de salvar seção, assim como uma seção
window >> translation

Na qual podemos definir utf8, após definir isto salve a seção dando-lhe um nome e cada vez que for logar você carrega antes a seção previamente salva.

[2] Comentário enviado por voyeg3r em 15/01/2009 - 12:25h

Ao invés de modificar o vim podemos modifcar o putty em:

Window >> Translation

Assim quem muda é o putty, até porque tudo vai ser utf-8

Valeu!

[3] Comentário enviado por pogo em 07/08/2009 - 16:36h

Salvou minha vida! Funcionou direitinho aqui!

Valeu pela dica!

[4] Comentário enviado por edsoncsouza em 06/12/2009 - 21:16h

Funcionou para o nano....
mais para o mcedit não =/

[5] Comentário enviado por olympiocarvalho em 03/04/2010 - 21:34h

Alterei as configurações do PuTTY:
Translation: ISO-8859-1
Fonts: Courier 10
Funcionou bem com o mcedit.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts