Problemas apt-get update (GPG error)

Publicado por Luriel Santana em 17/08/2008

[ Hits: 14.664 ]

 


Problemas apt-get update (GPG error)



Ao tentar atualizar o banco de dados de pacotes com o comando "apt-get update" aparece o seguinte erro:

W: GPG error: http://ftp.debian.org/debian etch Release: Erro desconhecido executando gpgv
W: Você terá que executar apt-get update para corrigir esses arquivos faltosos

Possíveis problemas:

1) A data do sistema está errada, use o comando "date" para verificar a data atual do seu sistema, caso esteja errada utilize o próprio "date" para corrigir.

Exemplo do comando date:

# date MMDDhhmmAAAA

Onde:
  • MM - Mês
  • DD - Dia
  • hh - hora
  • mm - minuto
  • AAAA - Ano

2) Necessário instalar o pacote gpgv:

# apt-get install gpgv

Outras dicas deste autor

Instalando o Webmin no Debian Etch através do apt-get

Usando o Play with Docker

Checando ocupação de disco dos diretórios a partir da raiz

Instalando o Docker-CE no Ubuntu 18.04 LTS

Curiosidade sobre o Debian

Leitura recomendada

Removendo Sessão Convidado do Ubuntu-14.04-LTS

Substituindo ocorrências de palavras dentro de um arquivo

Ajustando horário no Slackware

Arping - Descobrindo se um host está no ar em uma rede local protegida por um gateway/firewall

Uso das chaves na linha de comando

  

Comentários
[1] Comentário enviado por edisonlcp em 08/10/2009 - 23:57h

Para solucionar esse problema usem os comandos.

gpg --keyserver pgpkeys.mit.edu --recv-key CHAVEDOERRO
gpg -a --export CHAVEDOERRO | apt-key add -

o sinal de menos depois do add tem que ser colocado.

Espero ajudar mais algumas pessoas ae.




Contribuir com comentário