Módulo de segurança do Banco do Brasil no Debian 9 sem frescuras

Publicado por Xerxes em 27/03/2018

[ Hits: 9.529 ]

 


Módulo de segurança do Banco do Brasil no Debian 9 sem frescuras



Dica testada no Debian 9.3 (Stretch) com Firefox 52.6.0 (ESR).

Para instalar o módulo de segurança do Banco do Brasil execute os comandos:

Passo 1: se tentou instalar o módulo usando o pacote do Banco do Brasil, remova-o com:

sudo apt purge diagbb

Passo 2: baixe as dependências e o warsaw:

sudo apt-get install libnss3-tools libcurl3
$ wget https://cloud.gastecnologia.com.br/bb/downloads/ws/warsaw_setup64.deb -O warsaw.deb


Ou, se seu sistema for 32-bits:

wget https://cloud.gastecnologia.com.br/bb/downloads/ws/warsaw_setup.deb -O warsaw.deb

Instale:

sudo dpkg -i warsaw.deb
$ sudo apt install -f


Reabra o navegador e faça o teste.
Linux: Módulo de segurança do BB no Debian 9 sem frescuras
Outras dicas deste autor

Tema GTK em aplicativos KDE no LXDE

Entenda o uso de profiles no Funtoo

Canal do YouTube sobre GNU/Linux

Jogando Brogue no Linux

Plugin Java no Banco do Brasil para Ubuntu 64 bits

Leitura recomendada

Personalizando o OpenSuSE Linux 11 com alguns cliques

Melhorando a resolução da placa de vídeo SiS no Ubuntu 9.10 64 bits

Uma maneira diferente de escrever o dhcpd.conf

Cadê o menu.lst? Aprenda a configurar o Grub2!

Relatório do SARG com o access.log do Dansguardian

  

Comentários
[1] Comentário enviado por netTask em 01/04/2018 - 10:50h

Bom dia... funcionou comigo. Mas seu tópico necessita de alguns ajustes:
1 - o aplicativo a ser removido é o diagbb e não diabgg.
2 - o nome do arquivo a ser baixado de 32 bits é o mesmo do arquivo de 64 bits.
No mais, o processo funciona normalmente.

[2] Comentário enviado por xerxeslins em 02/04/2018 - 09:25h


[1] Comentário enviado por netTask em 01/04/2018 - 10:50h

Bom dia... funcionou comigo. Mas seu tópico necessita de alguns ajustes:
1 - o aplicativo a ser removido é o diagbb e não diabgg.
2 - o nome do arquivo a ser baixado de 32 bits é o mesmo do arquivo de 64 bits.
No mais, o processo funciona normalmente.


Opa! Obrigado pelas observações. Corrigido!

[3] Comentário enviado por saviolimalopes em 22/04/2018 - 19:07h

Boa noite.

Não funciona aqui.

1. Não consigo remover as minhas tentativas de instalação do diagbb. Quando envio o comando "apt purge diagbb", (estou logado no su) o retorno é este:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote diagbb
O nome do arquivo que baixei e executei é: diagbb-1.0.64.run

Assim, tentando usar o purge com este nome: diagbb-1.0.64, o retorno é este:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote diagbb-1.0.64
E: Couldn't find any package by glob 'diagbb-1.0.64'
E: Não foi possível encontrar o pacote através da expressão regular 'diagbb-1.0.64'

Assim, não consigo nem remover as tentativas de instalação.

Estas dependências já estão satisfeitas: libnss3-tools libcurl3

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
libnss3-tools is already the newest version (2:3.26.2-1.1+deb9u1).
libcurl3 is already the newest version (7.52.1-5+deb9u5).
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 4 não atualizados.

Tudo certo baixando o arquivo: wget https://cloud.gastecnologia.com.br/bb/downloads/ws/warsaw_setup64.deb -O warsaw.deb

Aqui é que o problema acontece:

Quando dou este comando, dpkg -i warsaw.deb o retorno é este:

(Lendo banco de dados ... 196896 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar warsaw.deb ...
[ ok ] Stopping warsaw (via systemctl): warsaw.service.
rm: não foi possível remover '/tmp/wi*': Arquivo ou diretório não encontrado
rm: não foi possível remover '/var/run/shm/sem.wi*': Arquivo ou diretório não encontrado
A descompactar warsaw (1.12.3.11) sobre (1.12.3.11) ...
Configurando warsaw (1.12.3.11) ...
chmod: não foi possível acessar '/usr/local/bin/warsaw/uninstall_core': Arquivo ou diretório não encontrado
Verifying...
Ok!
[ ok ] Starting warsaw (via systemctl): warsaw.service.
-su: linha 0: export: `--nofork': não é um identificador válido
-su: linha 0: export: `--nopidfile': não é um identificador válido
-su: linha 0: export: `--systemd-activation': não é um identificador válido
Failed to open connection to "session" message bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
A processar 'triggers' para fontconfig (2.11.0-6.7+b1) ...
A processar 'triggers' para systemd (232-25+deb9u3) ...

Reabro Firefox,e o módulo de segurança não está instalado.

Estou utlizando o Debian 9, 64 bits e Firefox ESR 52.7.3.

Alguém pode me ajudar?

Obrigado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts