MEGAsync não abre no Deepin 20

Publicado por Carlos A. P. Cunha em 15/08/2020

[ Hits: 1.020 ]

 


MEGAsync não abre no Deepin 20



Para quem já esta usando o Deepin 20 (beta mas em RC) ou atualizou o Deepin do 15.11 para 20 (foi liberado essa atualização) e usa o MEGAsync (gerenciador de arquivo na nuvem do MEGA, antigo Megaupload), perceberá que o mesmo não está mais funcionando, ao tentar abrir ele via ícone, não acontece nada, ao tentar abrir via terminal terá um erro semelhante a isso:

Setting QT_SCREEN_SCALE_FACTORS= "LVDS1=1.33333"
Falha de segmentação (imagem do núcleo gravada) (Segfault)
Pelo que vi é um problema com alguma questão do Deepin 20 com QT (algo assim), e deve ser corrigido em breve, porém há um contorno bem fácil.

1. Atualize o pacote do MEGAsync (não sei é necessário mas eu fiz). Acesse:
Baixe a versão para Debian 10, faça o update:

dpkg -i XXXX.dpkg

2. Aqui vem o pulo do gato, vamos alterar o arquivo que chama o megasync. Aonde é:

"Exec=megasync"

Ficará:

"Exec=env QT_SCALE_FACTOR=1 megasync"

Você pode editar o arquivo manual ou executar os comandos abaixo:

sudo sed -i -r '/^TryExec/d;s|^(Exec=).*$|\1env QT_SCALE_FACTOR=1 megasync|g' /usr/share/applications/megasync.desktop
sudo cp /usr/share/applications/megasync.desktop ~/.config/autostart/

Pronto, ao tentar abrir o MEGAsync pelo ícone (não via terminal) ou quando iniciar a máquina já deve iniciar corretamente.

Fontes:
Outras dicas deste autor

Desativando/Ativando Interface Gráfica ou Modo Texto com SystemD

Configurando Firefox em Português do Brasil no Sabayon

Atualização do Kernel no Ubuntu Server 14.04 LTS

Alterando Software Padrão de Torrent (magnet) do Firefox/Google Chrome

Samba 4 - Desabilitando suporte a impressoras (CUPS)

Leitura recomendada

Instalando o ePSXe - Emulador de Playstation

Emulando jogos de Super Nitendo no Linux

Compilando aBiblia Software para Linux Fedora 9 e Zenwalk 5.2

Open Drive (Cliente Google Drive)

Ferramentas para manipular PDF

  

Comentários
[1] Comentário enviado por mauricio123 em 15/08/2020 - 14:40h


Excelente.

___________________________________
Conhecimento não se Leva para o Túmulo.

[2] Comentário enviado por Carlos_Cunha em 16/08/2020 - 16:01h

Uma pequena correção, aonde menciono "dpkg -i XXXX.dpkg " é mais preciso "dpkg -i XXXX.deb" , erro meu que acabou passando na minha revisão.

#-------------------------------------------------------------------------------------#
"Falar é fácil, me mostre o código." - Linus Torvalds
#-------------------------------------------------------------------------------------#



Contribuir com comentário