Linux em SSD não reconhecido no BIOS [Resolvido]

Publicado por Xerxes em 16/11/2020

[ Hits: 3.444 ]

 


Linux em SSD não reconhecido no BIOS [Resolvido]



Compartilhando minha experiência: herdei um notebook velho do meu pai e vi a oportunidade de colocar Linux nele. Mas como se trata de um T4300 (1M de cache, 2.10 GHz, FSB de 800 MHz, Dual Core) com apenas 2GB de RAM, eu resolvi melhorá-lo um pouco. Adicionei mais 2GB de RAM e coloquei um SSD.

Infelizmente, surgiu um novo problema, o SSD não foi reconhecido no BIOS. Curioso que, iniciando um live-USB, durante a instalação, o SSD estava lá. Instalei uma distribuição Linux, mas mesmo assim, após reiniciar o computador, o SSD não era reconhecido, por isso o Linux instalado não iniciava.

Obs.: não sei o motivo desse problema. Caso alguém saiba, por favor, deixe um comentário.

Resumindo o cenário... Após inserir um SSD no notebook, ele não foi reconhecido no BIOS. Ele apareceu no instalador das distribuições Linux, entretanto. Após a instalação o sistema não iniciava, pois, não encontrava o SSD.

Agora vem a solução que, na verdade, é uma gambiarra. Após iniciar um live-USB e antes de começar a instalar o sistema, coloquei um cartão de memória na parte frontal do notebook.

Formatei como EXT2 e, durante a instalação, defini o cartão de memória para ser a partição "/boot", inclusive o GRUB foi instalado lá. O restante do sistema foi instalado no SSD normalmente (/).

Como o BIOS reconhecia o cartão de memória, o sistema foi inicializado por ele. E assim o resto funcionou!

Fica a dica para quem está com o mesmo problema.

Outras dicas deste autor

Deixando o SeaMonkey em português

Checar seu IP externo no terminal

Funtoo - Grub não reconhece partições automaticamente [Resolvido]

Windows inicializando primeiro no GRUB

Como saber se está usando Wayland ou Xorg

Leitura recomendada

Problemas pós-instalação no Beryl

Placa Wireless - Configuração no Notebook LG R410

Como instalar webcam Microdia no Arch Linux

Raid na instalação do Slackware

Concedendo permissão de root a um usuário comum via sudo

  

Comentários
[1] Comentário enviado por R9-SCCP em 17/11/2020 - 20:00h

Boa essa resolução, achei válida!!! Um colega de trabalho pediu pra eu formatar a máquina dele, e comprou um SSD!!! Um positivo antigo, ele não t conheceu o noite, com Windows, testei com Linux, também não resolveu, mesmo como MBR! O Windows, nem instalava, instai em outra máquina, pus no notebook e nada! Só rodou com HD mesmo!

[2] Comentário enviado por maurixnovatrento em 18/11/2020 - 07:36h


Estranho. Mas não é de se surpreender, uma vez que é uma técnologia ainda considerada recente, pode haver sim incompatibilidade. No bom chute, pode ter relação com a marca do produto ou com a qualidade. Tem muita máquina que vem com o Windows de Fábrica no SSD e inicia, vai entender.

___________________________________________________________
[code]Conhecimento não se Leva para o Túmulo.
https://github.com/MauricioFerrari-NovaTrento [/code]



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts