LTSP + Sound Blaster + Som

Publicado por ssssssssss em 04/08/2007

[ Hits: 6.304 ]

 


LTSP + Sound Blaster + Som



Galera, pra quem tentou fazer o som nas estações ltsp funcionar e não conseguiu, aqui vai uma dica que deu certo aqui.

[ws001]
SOUND              = Y
SOUND_DAEMON       = esd  
VOLUME             = 80
MIC_VOLUME         = 80
CD_VOLUME          = 75  
SMODULE_01         = sound
SMODULE_02        = uart401
SMODULE_03 = sb io=0x220 irq=5 dma=1

Este é o esqueleto básico para habilitar o som nas estações. Estas configurações ficam no arquivo ltsp.conf (estou considerando que se você está com dúvida para habilitar o som e com certeza já conhece bem este arquivo e sua configuração mínima).

Pois bem, desta forma como está aí, pelo menos comigo, na hora do boot nas estações, quando ele iria carregar o módulo do som, apesar de aparentemente estar tudo certo (em um tutorial de onde peguei este conf estava exatamente assim para habilitar o módulo do sound blaster) retornava um erro de parser na linha:

SMODULE_03 = sb io=0x220 irq=5 dma=1

Troquei (sabe-se lá o que me passou na cabeça) por:

SMODULE_03 = "sb io=0x220 irq=5 dma=1"

apenas adicionando as aspas e pronto. Depois que reiniciei as estações lá estava a tela de boas vindas do Gnome com seu sonzinho característico esperando.

Depois foi só configurar as aplicações para trabalhar com esound e pronto. Até uns clipes em 320x240 rodam, se tivesse uma placa de vídeo melhor no servidor acho que ficava melhor.

Bom galera, foi isso que me salvou. Espero que ajude vocês também, pois é muito gratificante ver essas maquininhas antigas com usb, disquete, cd-rom e o som funcionando. :)

Na próxima vou testar com uma placa com aceleração 3d no servidor e uma melhorzinha nos clientes pra ver o que que dá. Quando fizer posto aqui o resultado. É isso..

Abraço a todos e em caso de dúvidas, postem nos comentários que até onde eu souber tento ajudar.

Outras dicas deste autor

Recuperando apt-get após "falha de segmentação"

Configurando impressora HP600 em modo econômico no Linux

Resolvendo dependências Xlibs para Cedega 5.0 no Ubuntu Dapper

Instalando fontes Truetype no Linux

Rotacionando vídeos com o Mencoder

Leitura recomendada

Habilitando X11 via SSH no Slackware

Kermit e comandos AT

Atualizando o Ubuntu com uma linha

Consertando o ^M em scripts shell

Instalar o Unity 3D Web Player no Linux

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts