Kernel 3.0 em qualquer Ubuntu ainda suportado

Publicado por Andre (pinduvoz) em 13/10/2011

[ Hits: 7.282 ]

Blog: http://casadopinduvoz.wordpress.com/

 


Kernel 3.0 em qualquer Ubuntu ainda suportado



Quer ou precisa de um Kernel atualizado no seu Ubuntu?

É fácil, até mesmo no mais antigo deles, que é o 10.04.3 LTS, pois basta usar o PPA do Kernel Team, assim:

sudo add-apt-repository ppa:kernel-ppa/ppa

O script se encarregará de incluir a nova fonte e buscar a chave de autenticação, restando atualizar o sistema:

sudo apt-get update && sudo apt-get dist-upgrade

Segue a imagem abaixo, onde o meu Ubuntu 10.04.3 LTS roda com Kernel PAE (tenho 4 GB de RAM, mas uso o Ubuntu 32 bits) na versão 3.0.0-8, do ainda não lançado Ubuntu 11.10.
Linux: 
Kernel 3.0 em qualquer Ubuntu ainda suportado
Até a próxima dica.

Outras dicas deste autor

Ubuntu remasterizado pelo Hamacker

DLNA no Linux

Personalizar o Painel do Gnome no Ubuntu Lucid Lynx

Instalando pacote local com o YUM

Whiskermenu-plugin no Xubuntu 12.04 ou superior

Leitura recomendada

Slackware com kernel 3.10 - Erro com driver NVidia [Resolvido]

Os "patches ck1" de Con Kolivas estão de volta

OpenMosix em 1 disquete

Compilar kernel no Linux

pf-Kernel 3.16 - Acelere o Ubuntu, Linux Mint e Debian em net/notebooks

  

Comentários
[1] Comentário enviado por kads em 14/10/2011 - 00:01h

Qual a real vantagem em ter o kernel 3.0 em cima de uma LTS 10.04 ?

[2] Comentário enviado por pinduvoz em 14/10/2011 - 01:34h

Reconhecimento de hardware é a maior vantagem.

[3] Comentário enviado por kads em 14/10/2011 - 15:19h

Realizei os procedimentos que você informou acima e não ocorreu nada segue abaixo:
http://paste.debian.net/136503/

[4] Comentário enviado por pinduvoz em 15/10/2011 - 03:29h

Estranho, pois aqui atualizou instalando o Kernel 3.0.

Tente, então, instalar pelo Synaptic, abrindo-o e procurando por "linux-image". Nos encontrados vão estar o do Maverick, o do Natty e o do Oneiric, que é o da série 3. Escolha e instale, ou instale todos para escolher o melhor deles depois.

[5] Comentário enviado por pinduvoz em 15/10/2011 - 03:43h

Fui verificar melhor e mudaram o PPA, removendo o Kernel 3.0 e mudando o nome dos pacotes, razão pela qual eles não instalam mais com "dist-upgrade".

Vc ainda pode instalar o Kernel 2.6.38 do Natty, o mais novo disponível, assim:

sudo apt-get install linux-image-generic-lts-backport-natty

E se vc, como eu, utiliza o Kernel PAE (para 4 GB de RAM ou +), faça:

sudo apt-get install linux-image-generic-pae-lts-backport-natty

Desculpe o erro na dica, mesmo que ele tenho por razão o fato de o PPA ter sido modificado após a dica ter sido escrita.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts