JRE não funciona no Debian Etch depois de instalado

Publicado por Nibu em 11/10/2007

[ Hits: 6.016 ]

 


JRE não funciona no Debian Etch depois de instalado



Olá pessoal, resolvi escrever esta dica pois ao instalar o JRE (pacote auto-extract jre-6u2-linux-i586.bin) e seguir todo os procedimentos descritos no how-to da página official de download, me deparei com o não funcionamento do mesmo (por exemplo, ao acessar a página de "login" do BB).

Foi aí que fazendo testes, inicializei o Iceweasel (Firefox) pelo terminal e descobri que o problema era a falta da libstdc++.so.5.

Dando uma procurada rápida em http://www.debian.org/distrib/packages descobri que deveria instalar o pacote libstdc++5. Logo, depois de (como root - #):

# apt-get install libstdc++5

(Irá instalar o libstdc++5 e o gcc-3.3-base)

O campo de senha do BB funcionou normalmente.

Espero que ajude alguém com a mesma dificuldade.

Anibal Aguiar.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Evitando os dois carregamentos de JSF (JavaServer Faces)

Instalando plugin 64bits Java6 da Sun no Debian Lenny

Linux - Onde está meu plugin Java?

Java 8 Oracle no novíssimo Mageia 5

Java JRE + Plugin no Firefox - Instalação manual

  

Comentários
[1] Comentário enviado por nibuAguiar em 11/10/2007 - 16:04h

Mais uma dica,
Tenha certeza de fazer o link para a <dir_JRE>/plugin/i386/ns7/libjavaplugin_oji.so dentro da pasta de plugins do iceweasel - por exemplo, /usr/lib/iceweasel/plugins/ .
Caso você use a libjavaplugin_oji.so que esta dentro de <dir_JRE>/plugin/i386/ns7-gcc29... o iceweasel fechará toda vez que aparecer uma requisição a lib java...

Abraços

Nibu (Baú).

[2] Comentário enviado por marcops em 15/10/2007 - 09:05h

de uma olhada nos alternatives
=)



Contribuir com comentário