Instale módulos Perl com facilidade

Publicado por Wagner Amaral em 12/01/2005

[ Hits: 17.676 ]

 


Instale módulos Perl com facilidade



Está faltando algum módulo Perl no seu sistema e está com preguiça de baixar o source e compilar? Sem problemas, há quem faça isso pra você.

Funciona mais ou menos como o próprio instalador de pacotes da sua distro e a sintaxe é a seguinte:

perl -MCPAN -e 'install MODULO'

Por exemplo, se deseja instalar o módulo "Term::ReadKey", o comando seria:

$ perl -MCPAN -e 'install Term::ReadKey'

Ele vai baixar, compilar e instalar o módulo, tudo automaticamente.

PS1: Deve ser executado como usuário root.

PS2: Se for a primeira vez que você está usando esse comando, no início do processo ele irá te fazer a seguinte pergunta:

"Are you ready for manual configuration? (yes/no)"

Simplesmente digite: "no" e aperte enter, o resto continuará normalmente. Essa "configuração" a que ele se refere é a configuração do instalador e não do seu módulo que será baixado a seguir, portanto responder "no" é confiável em 99% das vezes.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Criando um programa CGI com Perl

Otimizando o Firefox para conexões banda larga

Removendo e-mails gigantes da fila no Qmail

PrintScreen em modo texto

Software Data Cable - Transfira arquivos de aparelho Android para computador via Wireless

  

Comentários
[1] Comentário enviado por BornSlip em 21/03/2006 - 00:52h

Ae amigo, ate q enfim achei uma maneira de terminar com as dependencias que havia no CL10, estou tentando instalar o mysql dai ele apresentava erros de dependencia no perl ate ai td bem, executei o # perl -MCPAN -e 'install DBI' perguntou ai uma paradinha, disse no, e blz, fui novamente tentar instalar o mysql e ele resultou em outras dependencias do perl

perl(DBI) is needed by MySQL-server-4.1.18-0.glibc23
perl(Data::Dumper) is needed by MySQL-server-4.1.18-0.glibc23
perl(File::Basename) is needed by MySQL-server-4.1.18-0.glibc23
perl(File::Copy) is needed by MySQL-server-4.1.18-0.glibc23
perl(File::Path) is needed by MySQL-server-4.1.18-0.glibc23
perl(File::Temp) is needed by MySQL-server-4.1.18-0.glibc23
perl(Getopt::Long) is needed by MySQL-server-4.1.18-0.glibc23
perl(POSIX) is needed by MySQL-server-4.1.18-0.glibc23
perl(Sys::Hostname) is needed by MySQL-server-4.1.18-0.glibc23
perl(strict) is needed by MySQL-server-4.1.18-0.glibc23
perl(vars) is needed by MySQL-server-4.1.18-0.glibc23

tentei instalar esses pacotes manualmente como vc citou acima

perl -MCPAN -e 'install Term::ReadKey'

executando perl -MCPAN -e 'install Data::Dumper'

e a resposta foi:

Can't locate object method "install" via package "Data::Dumper" at -e line 1.

sera q estou digitando algo errado ? valeu ai pela dica, agora sei q estou no caminho certo.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts