Instalando suporte ao Silverlight no Firefox 5 ou superior

Publicado por Rodrigo Bonicenha Ferreira em 25/09/2011

[ Hits: 10.115 ]

 


Instalando suporte ao Silverlight no Firefox 5 ou superior



Bem amigos, essa dica é para aqueles que ao tentar baixar o plugin chamado Moonlight, que dá suporte a sites e animações construídas em SilverLight para o Firefox 5, se deparam com a mensagem que não foi possível instalar o plugin pois a versão do Firefox não é compatível.

1. Iremos primeiro acessar o link:
e baixar o plugin para a arquitetura de nosso sistema operacional (x86 ou x64), clicando com o botão direito do mouse e pedindo para salvar o plugin em um lugar conhecido de nosso sistema operacional (de preferência na área de trabalho).

2. Depois de baixar o plugin, vamos extrair todo o conteúdo para uma segunda pasta, eu criei uma pasta chamada Silverlight na minha área de trabalho e extraí todos os arquivos para dentro dessa pasta. Você pode usar o descompactador de sua preferência, no meu caso estou usando o próprio gerenciador de pacotes padrão do meu sistema operacional, a intenção aqui é que essa dica seja a mais fácil possível.

3. Agora que já extraímos todos os arquivos para a pasta que criamos, vamos abrir o arquivo chamado install.rdf, que contém algumas parametrizações para correta instalação do plugin. Para edição desse arquivo estou usando o próprio Gedit, use o seu editor de texto predileto.

4. Procure uma linha dentro desse arquivo chamada:

<em:maxVersion>4.0.*</em:maxVersion>

E edite para:

<em:maxVersion>5.0.*</em:maxVersion>

Após editar colocando a versão do Firefox que você está utilizando, salve o arquivo. No meu caso estou usando a versão 5 do Firefox.

5. Aproveite que todos os arquivos do plugin que será instalado no Firefox estão descompactados e delete a pasta META-INF.

6. Agora que já fizemos a alteração no arquivo install.rdf e também já deletamos a pasta META-INF, vamos compactar novamente os arquivos, selecione todos os arquivos de uma única vez, clique com o botão direito do seu mouse e selecione a opção COMPRIMIR, escolha a opção COMPRIMIR como .ZIP (pode ser qualquer outro tipo, porém eu escolhi .ZIP).

7. Depois que todos os arquivos estiverem compactados no formado .ZIP, clique com o botão direito nesse arquivo, peça para renomear e renomeie a extensão dele para .xpi novamente, fazendo com que ele se torne a extensão padrão do Firefox novamente.

8. Abra o Firefox e arraste o arquivo que foi renomeado para dentro do navegador, o Firefox irá pedir autorização para instalar o plugin, aceite e permita a instalação e depois reinicie o seu navegador. Pronto, você está com o plugin com suporte a tecnologia SilverLight instalado e pronto para usar. :-)

Eu espero que todos os passos tenham sido bem claro, peço desculpas aos menos impacientes iguais a mim, porém tentei detalhar ao máximo essa dica para que até o mais leigo consiga seguir essas instruções.

Fontes


Forte abraço para toda comunidade,
Rodrigo Bonicenha Ferreira.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Servidor não encontrado: o Firefox não conseguiu localizar....

Linux Mint e Ubuntu com Flash atualizado

Liberando acesso ao Conectividade Social

Gerenciador de download no Linux? D4X!

Doode sua nova rede Linux de amigos

  

Comentários
[1] Comentário enviado por pinduvoz em 25/09/2011 - 17:40h

Segui a dica e encontrei os seguintes problemas:

1) para descompactar o arquivo xpi tive que renomeá-lo para zip (arquivo.xpi > arquivo.zip), pois o formato xpi não era suportado; e para instalar após compactar fiz o caminho inverso (arquivo.zip > arquivo.xpi);

2) da primeira vez não mandei "recriar as pastas" ao descompactar e a extensão, apesar de instalada, não funcionou; refiz, recriando as pastas ao descompactar (importante) e apagando a pasta META-INF antes de recompactar, instalei e funcionou.

[2] Comentário enviado por pinduvoz em 25/09/2011 - 17:41h

Esqueci de mencionar que instalei no Firefox 7, Ubuntu 10.10.

[3] Comentário enviado por kernel_rj em 26/09/2011 - 10:54h

Legal, isso mesmo!

Provavelmente o seu sistema de compressão padrão não está conseguindo descompactar os arquivos .xpi, acredito que você deva estar se enganando em algum momento visto que as estensões servem somente para indicar o tipo de compressão que determinado dado está utilizando. Quanto a pasta META-INF, realmente deve ser excluída conforme indicado no itén 5, antes dos arquivos serem compactados novamente.

Fico feliz da dica ter sido útil, qualquer coisa estamos sempre por ai!

Abraço! :-)

[4] Comentário enviado por superpassos em 21/10/2011 - 17:21h

Prezado Rodrigo,

Muito obrigado pela sua explicação, bastante didática.

Estou usando o Ubunto e, o suporte ao Silverlight no Chrome, deixava o computador extremamente lento - travando com bastante frequência e testando minha paciência.

Precisava da sua dica há alguns meses... Agradeço pela ajuda!

Um abraço,

Rafael

[5] Comentário enviado por brunoabinfo em 01/11/2011 - 23:48h

Putz, simples...

Me salvou, obrigado!!!

[6] Comentário enviado por julio.ferraz em 21/03/2012 - 09:12h

Senhores,.

Bom dia.

Ótimo artigo.

Fiz isso com o firefox 10.0.3.

Mas no meu caso, estou tentando assistir aulas da ESTACIO(UNIVERSIDADE ESTACIO DE SA) e a página deles, toda vez que tento diz que precisa do desnecessário Silverlight.

Alguem têm alguma outra idéia, como posso fazer? Meu firefox é o 10.0.3. E informo que o mesmo foi instalado com sucesso.
Fiz um teste básico em http://www.shinedraw.com/mathematics/flash-vs-silverlight-fps-meter-stress-test/




Outra Opção interessante é usar o Rai Smooth Stream Player



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts