Instalando o aMule e suas dependências no Slackware 10

Publicado por Eduardo Takeshita em 25/05/2005

[ Hits: 16.454 ]

 


Instalando o aMule e suas dependências no Slackware 10



Bom galera, essa dica vai para aqueles que querem instalar o aMule, um cliente P2P muito conhecido. É um aplicativo parecido com o eMule do Windows. Então vamos lá!

Primeiramente vá até esse link e baixe o aplicativo:
Escolha um servidor de sua preferência.

Depois de baixá-lo, navegue até onde você salvou o download e execute o seguinte comando para a instalação (como root):

# installpkg aMule-1.2.8-i486-1pcx.tgz

O pacote será instalado sem problema nenhum, mas para que o aplicativo funcione corretamente no seu Slackware você irá precisar de uma dependência chamada "wxGTK", então vamos lá.

Entre nesse link:
e baixe o arquivo "wxGTK-2.4.2.tar.gz", depois navegue até o local onde você salvou o arquivo e execute os seguintes comandos no seu terminal preferido (como root):

# tar -zxvf wxGTK-2.4.2.tar.gz
# cd wxGTK-2.4.2
# ./configure --prefix/usr
# make
# make install


Demora um pouquinho para a instalação desse aplicativo, mas vale à pena! Depois de tudo instalado, basta dar o comando para iniciar o "aMule" (no terminal):

# amule

Com esse comando você carregará o "aMule" e poderá usá-lo sem problemas, mas antes deve-se informar os servidores que quer usar... aí fica por sua conta qual servidor te agrada mais!

Bom espero que gostem da dica.

t+
[]'s
beetle_juice.

Outras dicas deste autor

Configurando o som no XMMS

Assistindo DVD's no Slackware

Instalando o RealPlayer 10 Gold no seu Linux

Separadores no menu do Fluxbox

Instalando o MPlayer e suas dependências no Slackware 10

Leitura recomendada

Ubuntu 12.04 - VirtualBox parou de funcionar? [Resolvido]

Como criar um instalador no InstallJammer

Instalando o aMSN 0.98 no Ubuntu Linux (jaunty e intrepid)

AST - Criando slackbuilds no Slackware

Aprenda a instalar o Popcorn Time com apenas 3 códigos no terminal!

  

Comentários
[1] Comentário enviado por beetle_juice em 26/05/2005 - 11:47h

Galera só corrigindo um erro <<desculpas>>
No comando configure do pacote "wxGTK"
este é o comando correto...

#./configure --prefix=/usr
#make
#make install

Desculpe pelo erro.... =]
t+
[]'s
beetle_juice.

[2] Comentário enviado por gersonab em 08/06/2005 - 16:42h

efetuei todos estes comandos parém ao efetuar o make ......
make: *** Nenhum alvo indicado e nenhum arquivo make encontrado. Pare.
poderia m ajudar ....

[3] Comentário enviado por beetle_juice em 09/06/2005 - 12:16h

Não sei porque aqui em casa eu instalei ele de novo depois que fiz o seu comentário e funcionaou perfeitamente!
Tente de novo quem sabe desda vez vai...
t+

[4] Comentário enviado por gersonab em 09/06/2005 - 14:05h

Companheiro ....
este comentario serve para instalar o amule no kurumin 5.0 ?
caso não , favor informar qual seria o procedimento correto ....

[5] Comentário enviado por beetle_juice em 09/06/2005 - 17:54h

Cara nunca usei o Kurumin, então não posso te dizer nada! A dica ensina a instalar no Slackware aqui em casa funcionou perfeitamente... Me desculpe mas, não sei se é o mesmo procedimento com o Kurumin ok?!
Espero ter ajudado qq coisa posta aí de novo!
t+
beetle_juice.

[6] Comentário enviado por gersonab em 12/06/2005 - 08:18h

Consegui .....
Depois de muito esforço consegui instalar , segue abaixo o link para maiores informações :
http://debian.nctu.edu.tw/debian/pool/main/w/wxwidgets2.5/

[7] Comentário enviado por beetle_juice em 12/06/2005 - 08:21h

blz pinguim... valeu pelo comentários e pela dica tbm!
t+
[]'s
beetle_juice.

[8] Comentário enviado por baleya em 09/11/2005 - 08:26h

muito boa a dica consegui instalar aki depois de muito tempo , vlw

[9] Comentário enviado por wr.silva em 16/11/2005 - 21:37h

root@manczak:/home/wxgtk/wxGTK-2.6.1# make
./bk-deps g++ -c -o basedll_appbase.o -D__WXGTK__ -DwxUSE_GUI=0 -DWXMAKINGDLL_BASE -DwxUSE_BASE=1 -fPIC -DPIC -DGTK_NO_CHECK_CASTS -Ilib/wx/include/gtk2-ansi-release-2.6 -I./include -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -O2 -pthread -Wall -Wno-ctor-dtor-privacy ./src/common/appbase.cpp
./bk-deps g++ -c -o basedll_archive.o -D__WXGTK__ -DwxUSE_GUI=0 -DWXMAKINGDLL_BASE -DwxUSE_BASE=1 -fPIC -DPIC -DGTK_NO_CHECK_CASTS -Ilib/wx/include/gtk2-ansi-release-2.6 -I./include -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -O2 -pthread -Wall -Wno-ctor-dtor-privacy ./src/common/archive.cpp
In file included from include/wx/stream.h:24,
from include/wx/archive.h:21,
from src/common/archive.cpp:27:
include/wx/object.h: In member function `const wxChar*
wxClassInfo::GetClassName() const':
include/wx/object.h:83: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
make: *** [basedll_archive.o] Error 1

[10] Comentário enviado por coffnix em 07/01/2006 - 07:33h

esse é um erro do wx widgets.....

vou postar um tutorial no vol logo logo!

e vai se chamar..... (instalação do amule, tutorial completo)

[11] Comentário enviado por cleytonasa em 31/10/2006 - 14:27h

bom no slack 11
aMule
http://ftp.naist.jp/pub/Linux/linuxpackages/Slackware-11.0/X11/aMule/aMule-2.1.3-i486-1asz.tgz
wxGTK-2.6.3
http://ftp.naist.jp/pub/Linux/linuxpackages/Slackware-11.0/Library/wxGTK/wxGTK-2.6.3-i486-1asz.tgz

# installpkg aMule-2.1.3-i486-1asz.tgz
# installpkg wxGTK-2.6.3-i486-1asz.tgz
# amule
prontinho!

[12] Comentário enviado por Qu!r!n0 em 04/12/2006 - 21:15h

Fiz tudo , mas na hora de abrir o amule ele carrega na barra mas naum abre!!!! oq pode ter acontecido?

[13] Comentário enviado por Qu!r!n0 em 04/12/2006 - 21:44h

ja instalei tudo, mas ta dando esse erro

amule: error while loading shared libraries: libwx_gtk-2.4.so: cannot open shared object file: No such file or directory


oq pode ser ?

[14] Comentário enviado por anacarol em 10/12/2007 - 17:14h

ta...pelos comentários parece que vc explicou direitinho, mas eu não entendo nada de computador e queria saber aonde eu preciso digitar esse
# installpkg aMule-1.2.8-i486-1pcx.tgz ? o que seria como root??

depois que eu baixo o arquivo no site ele abre 3 pastas:install, opt e usr...
o que faço depois??
bjos



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts