Instalando o aMSN 0.93 com traydoc no KDE 3.1

Publicado por Perfil removido em 10/09/2004

[ Hits: 16.181 ]

 


Instalando o aMSN 0.93 com traydoc no KDE 3.1



Instalando


Download:
http://prdownloads.sourceforge.net/.../amsn-0.93-linux-installer.bin

# cp amsn-0.93-linux-installer.bin /usr/local/
# cd /usr/local/
# mkdir amsn
# mv amsn-0.93-linux-installer.bin amsn
# cd amsn/
# chmod 755 amsn-0.93-linux-installer.bin
# ./amsn-0.93-linux-installer.bin


Depois dê um "forward". Na parte de "Acordo de licença" dê uma lida, clique em Yes e dê um forward.

Escolha o diretório de instalação, no nosso caso /usr/local/amsn, depois que ele instalar dê um "Finalizar".

Traydoc no KDE


# cd /usr/local/amsn/plugins/traydock
# ./configure && make
# cd /usr/local/bin/
# ln -s /usr/local/amsn/amsn


Depois de aberto o amsn, vá em "Ferramentas" => "Ícone na bandeja (Systray)" => "FreeDesktop (KDE3/GNOME2)".

Se você estiver no KDE, automaticamente na bandeja dele irá aparecer o ícone do amsn.

No Gnome não testei, mas creio eu que é só executar o amsn que automaticamente ele irá para a bandeja do sistema.

Finalizando


Um problema que muitos iniciantes apanham é nessa parte quando executa um "$ amsn" acontece o seguinte erro:
Error in startup script: couldn't open "lang/langbr": 
no such file or directory  while executing
"open "[file join lang lang$langcode]" r"
    (procedure "load_lang" line 4)
    invoked from within
"load_lang [::config::getGlobalKey language]"
    invoked from within
"if { $initialize_amsn == 1 } {
        create_dir $HOME
        create_dir $HOME/plugins
        create_di..."
    (file "config.tcl" line 1357)
    invoked from within
"source config.tcl"
    (procedure "reload_files" line 20)
    invoked from within
"reload_files"
    (file "/usr/local/bin/amsn" line 215)
A solução é bem simples:

# cd /usr/local/amsn/lang
# mv langpt_BR langbr
# amsn


Abraços...
Guilherme L. Stolfo
guinet(NOTSPAM)gmail.com

Outras dicas deste autor

Vídeo aula: Como colocar wallpaper comum a todos os usuários

Baixou o Ubuntu 14.10 Utopic [sem suporte] no Site Oficial? Relaxe, temos a solução pra você!

Solitarie Studio: jogo de paciência

Algumas dicas para novatos

Flash com som nos Ubuntu e Debian-like

Leitura recomendada

Boot de uma imagem ISO no HD

Mixando logs do Asterisk (ou quaisquer arquivos de áudio)

Fechar, minimizar e maximizar invertidos no Metacity

Corrigindo as fontes feias no Chromium (Chrome) no Debian XFCE

Skin do Brasil para aMSN (Copa do Mundo)

  

Comentários
[1] Comentário enviado por bluedog em 10/09/2004 - 20:30h

so uma obserçao para kem usa gnome antes de abrir o amsn para setar a opçao de systray vc deve ir na barra de ferramentas onde ficam os labels dizendo q aplicativos estao rodando clicar com o botao direito ir eh adicionar ao painel -> Utility -> Area de notificaçao
senao nao ira funcionar
flw ! "may the source be with you"

[2] Comentário enviado por removido em 10/09/2004 - 22:10h

Poww valeu mano pela dica, agora sim ficou 100%

Guilherme L. Stolfo

[3] Comentário enviado por kog em 14/09/2004 - 02:06h

Por favor eu segui passo a passo tudo que o Guilherme colocou mais ainda aparece a menssagem de erro meu SO é o conectiva 8:

Error in startup script: couldn't open "lang/langpt_br": no such file or directory
while executing
"open "[file join lang lang$langcode]" r"
(procedure "load_lang" line 4)
invoked from within
"load_lang [::config::getGlobalKey language]"
invoked from within
"if { $initialize_amsn == 1 } {
###############################################################
create_dir $HOME
create_dir $HOME/plugins
create_di..."
(file "config.tcl" line 1357)
invoked from within
"source config.tcl"
(procedure "reload_files" line 20)
invoked from within
"reload_files"
(file "/usr/local/bin/amsn" line 215)

Por favor toda a ajuda será ultil

[4] Comentário enviado por removido em 14/09/2004 - 08:49h

Powww brincaderia =(((((((((( mano vou postar aqui oque foi dito na dica e ainda por cima vc me falou que fez passo a passo Arghhhhhhhhhh!



Error in startup script: couldn't open "lang/langbr":
no such file or directory while executing
"open "[file join lang lang$langcode]" r"
(procedure "load_lang" line 4)
invoked from within
"load_lang [::config::getGlobalKey language]"
invoked from within
"if { $initialize_amsn == 1 } {
create_dir $HOME
create_dir $HOME/plugins
create_di..."
(file "config.tcl" line 1357)
invoked from within
"source config.tcl"
(procedure "reload_files" line 20)
invoked from within
"reload_files"
(file "/usr/local/bin/amsn" line 215)

A solução é bem simples:

# cd /usr/local/amsn/lang
# mv langpt_BR langbr
# amsn




poww se poderia ter deixado essa passado em branco ein?, mais acontece heheh

[5] Comentário enviado por kog em 30/09/2004 - 03:10h

Guilherme por favor o que significa esse erro ao tentar compilar o traydock?

/usr/bin/ld: cannot find -lieee
collect2: ld returned 1 exit status
make: ** [libtray.so] Erro 1

[6] Comentário enviado por removido em 30/09/2004 - 08:45h

POww me especifica ae a dist que vc usa... qual amsn estas usando....
ahh faça isso aqui:

# updatedb
espere terminar, ai depois
# locate libtray.so

e me coloque o resultado ...

vlw...

[7] Comentário enviado por maxopala em 03/10/2004 - 21:25h

Guilerme, uso o Conectiva 10 com o KDE 3.2.3. Faço passo-a-passo cada uma de suas instruções e ocorre o seguinte erro após a tentativa de executar o configure do diretório traydock:

checking for Tcl configuration... configure: WARNING: Can't find Tcl configuration definitions
bash: make: command not found

Isso ocorre por causa da distribuição ou por causa da versão do KDE? Por favor, pode me ajudar a resolver esse problema?

Obrigado!

Max

[8] Comentário enviado por removido em 04/10/2004 - 08:34h

Olá, então ele não está encontrando o Tcl que se não me engano é a linguagem da qual o amsn é feito. E tambêm provavelmente não encontrará o Tk .

tente isso aqui:

echo $PATH

se não estiver procure onde esta e depois faça assim:

./configure --with-tcl=/usr/lib/tcl8.4/ --with-tk=/usr/lib/tk8.4

mais lembra-se isso ai estou chutando.. verifica direitinho onde se encontra o diretório das duas linguagens.


[9] Comentário enviado por maxopala em 06/10/2004 - 16:07h

Muito obrigado Guilerme! Daqui pra frente me viro! Valeu pela dica!

[10] Comentário enviado por rpavoni em 12/10/2004 - 02:30h

Eu uso Slackware 10 e segui todas as recomendações do howto e o amsn apresentou esse erro:

Error in startup script: couldn't open "lang/langpt_br": no such file or directory
while executing
"open "[file join lang lang$langcode]" r"
(procedure "load_lang" line 4)
invoked from within
"load_lang [::config::getGlobalKey language]"
invoked from within
"if { $initialize_amsn == 1 } {
###############################################################
create_dir $HOME
create_dir $HOME/plugins
create_di..."
(file "config.tcl" line 1357)
invoked from within
"source config.tcl"
(procedure "reload_files" line 20)
invoked from within
"reload_files"
(file "/usr/local/bin/amsn" line 215)
[email protected]:/usr/local/amsn/lang# amsn
Error in startup script: couldn't open "lang/langpt_br": no such file or directory
while executing
"open "[file join lang lang$langcode]" r"
(procedure "load_lang" line 4)
invoked from within
"load_lang [::config::getGlobalKey language]"
invoked from within
"if { $initialize_amsn == 1 } {
###############################################################
create_dir $HOME
create_dir $HOME/plugins
create_di..."
(file "config.tcl" line 1357)
invoked from within
"source config.tcl"
(procedure "reload_files" line 20)
invoked from within
"reload_files"
(file "/usr/local/bin/amsn" line 215)

Quando segui o seguinte passo:
# cd /usr/local/amsn/lang
# mv langpt_BR langbr
# amsn
O sistema disse que não encontrou o arquivo langpt_BR, eu acessei o diretório /usr/local/amsn/lang e mudei o nome do arquivo langbr para langpt_br (minusculo mesmo) e funcionou.

Alguma explicação para isso?

[11] Comentário enviado por removido em 12/10/2004 - 16:12h

Eae velho...

Poww estranho ein?, em suas confs veio tudo minusculo... estranho..

bom mais se funcionou magavilha... flw!


[12] Comentário enviado por frattari em 27/11/2004 - 10:59h

Guilherme, estou tentando usar o systray do Amsn no KDE, mas não estou conseguindo. Uso o Conectiva 10 e o KDE 3.2. Os primeiros problemas como os relatados nesta pagina por outras pessoas consegui resolver, mas quando executo o ./configure aparece o seguinte:

./configure
checking for Tcl configuration... found /usr/lib/tclConfig.sh
checking for Tk configuration... found /usr/lib/tkConfig.sh
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
configure: error: Tcl and Tk must be configured with the --enable-shared flag

ja tentei todos os arquivos de configuração, mas nao consigo resolver. Você sabe o que pode ser?

[13] Comentário enviado por removido em 27/11/2004 - 13:26h

Amigo tenta dar

./configure --enable-shared

mais seria legal antes vc começar de novo, ou seja descpmpactar novamente qual vc baixou e dar o:
./configure --enable-shared && make && make install

[14] Comentário enviado por removido em 27/11/2004 - 13:26h

Amigo tenta dar

./configure --enable-shared

mais seria legal antes vc começar de novo, ou seja descpmpactar novamente qual vc baixou e dar o:
./configure --enable-shared && make && make install

espero que de certo manoo qualquer coisa liga eu ai =D

[15] Comentário enviado por removido em 06/03/2005 - 09:03h

Olá , eu uso o Slackware 10, e fiz tudo certo , só que quando incio o Amsn, ele fica demorando (mostrando a ampulheta de tempo) e acaba sendo fechado. O que seria isso ? Valeu mesmo.

[16] Comentário enviado por diego.bar em 26/03/2005 - 18:11h

segui o procedimento descrito, mas quando executei o comando "./configure && make" obtive como respostas:

WARNING: Can't find Tk confoguration definitions
make: *** Nenhum alvo indicado e nenhum arquivo make encontrado. Pare.

Soh pra informar, o sistema que uso é o Fedora Core 2.

[17] Comentário enviado por mex0729 em 29/03/2005 - 00:32h

ola!!! gui!!!!!! tb to com o mesmo problema do egresso !!! ah!!! e tb usa as mesmas configuraçao!!!! se alguem puder me ajufdar..!!!!
agradeço a gente lesa!!!

[18] Comentário enviado por removido em 29/03/2005 - 09:00h

OPa!,

Fala ae mex0729 ,

Meu de veiz de vc clicar num icone do amsn ou chamar via "ALT + F2"

vai no terminal de comando e digita:

$ amsn <ENTER>


E me cola aqui exatamente a tela de erro firmeza?

--
Abs,
guinet gmail com

[19] Comentário enviado por mex0729 em 29/03/2005 - 12:26h

ola!! gui!

ta ai !!! v o q vc pode fazer por min ai!!!
eu num so bom nisso naum pois estou mudado de SO...

desde ja obrigado pela sua atençao!

[email protected]:/usr/local/amsn# amsn
Error in startup script: couldn't open "lang/langpt_br": no such file or directory
while executing
"open "[file join lang lang$langcode]" r"
(procedure "load_lang" line 4)
invoked from within
"load_lang [::config::getGlobalKey language]"
invoked from within
"if { $initialize_amsn == 1 } {
###############################################################
create_dir $HOME
create_dir $HOME/plugins
create_di..."
(file "config.tcl" line 1357)
invoked from within
"source config.tcl"
(procedure "reload_files" line 20)
invoked from within
"reload_files"
(file "/usr/local/bin/amsn" line 215)

[20] Comentário enviado por removido em 29/03/2005 - 13:06h

OPa!,

amigo da uma lidinha direiro =D ta explicado no artigo como resolver esse problema rs.

basta mudar o diretorio da linguagem para qual ele ta pedindo:

lang/langpt_br

Por exemplo o meu está em:

# cd /usr/local/amsn-0.94/lang

ai é só da um "ls"

# ls -la

para renomear o diretório basta:

# mv nomeatual langpt_br

beleza?

--
Abs,
guinet gmail com

[21] Comentário enviado por mex0729 em 30/03/2005 - 01:37h

vlw !!!!
pela dica seu materia ta muito bom!!
mas uma vez obrigado

[22] Comentário enviado por gledsonfr em 07/11/2005 - 22:11h

já no meu caso eu sé renomeei os arquivo langpt_BR para langpt_br e funcionou ...
mas o meu amsn naum criou nenhum icone UAHUHAUhauh dai todas as veze que tenho que rodar estro no diretorio que instalei e ./amsn se alguem poder me ajudar ficarei muito grato UHAuUAhuahuh

[23] Comentário enviado por thornstriff em 18/11/2005 - 19:39h

Uso Mandrake 10.0 oficial.
Quando digito o primeiro conjunto de comandos aparece:

[[email protected] local]$ cp amsn-0.93-linux-installer.bin /usr/local/
cp: impossível fazer stat em `amsn-0.93-linux-installer.bin': No such file or directory
[[email protected] local]$ cd /usr/local/
[[email protected] local]$ mkdir amsn
mkdir: não é possível criar o diretório `amsn': Permission denied
[[email protected] local]$ mv amsn-0.93-linux-installer.bin amsn
mv: impossível fazer stat em `amsn-0.93-linux-installer.bin': No such file or directory
[[email protected] local]$ cd amsn/
bash: cd: amsn/: No such file or directory
[[email protected] local]$ chmod 755 amsn-0.93-linux-installer.bin
chmod: impossível acessar `amsn-0.93-linux-installer.bin': No such file or directory
[[email protected] local]$ ./amsn-0.93-linux-installer.bin
bash: ./amsn-0.93-linux-installer.bin: No such file or directory

[24] Comentário enviado por removido em 09/02/2006 - 14:34h

PESSOAL TO COM UMPROBLEMA NA INSTALAÇÃO DO AMSN 0.95, ELE DIZ QUE FALTA DOIS ARQUIVO PRA PODER DESCOMPACTAR.
OS ARQUIVOS SÃO tcl8.4.so e tk8.4.so

EU JA BAIXEI ESSES ARQUIVOS COPIEI PRA PASTA USR/LIB, MAS NUM DEU CERTO, ALGUÉM JA RESOLVEU UM PROBLEMA DESSE E PODE COMPARTILHAR COM A SOLUÇÃO???

FICO GRATO!!!

ALEXANDRE ROCHA

[25] Comentário enviado por nickmarinho em 21/05/2006 - 18:49h

Nas vezes que instalei o Linux na maquina peguei o Amsn por apt-get mesmo. Nunca tive que instalar assim!
Só para comentar mesmo.

www.lucianomarinho.com.br

[26] Comentário enviado por helinton em 07/06/2006 - 23:50h

E ai pessoal o meu problema é o seguinte... a instalação deu tudo certo só agora eu clico no icone da a seguinte mensagem>>> KDEInit não pôde lançar '/usr/local/amsn-0.93/amsn'
se eu digito o cod pelo pront da o seguinte erro>>> bash: ./amsn: /usr/bin/env: bad interpreter: Arquivo ou diretório não encontrado se alguem puder me ajudar Obrigado

[27] Comentário enviado por genivaldoinfo em 22/06/2006 - 12:09h

Instal o amsn no meu computador mas não deu certo da o seguinte erro a distribuição q estou usando é o rad hat 9.
Error in startup script: couldn't open "lang/langpt_br": no such file or directory
while executing
"open "[file join lang lang$langcode]" r"
(procedure "load_lang" line 4)
invoked from within
"load_lang [::config::getGlobalKey language]"
invoked from within
"if { $initialize_amsn == 1 } {
###############################################################
create_dir $HOME
create_dir $HOME/plugins
create_di..."
(file "config.tcl" line 1357)
invoked from within
"source config.tcl"
(procedure "reload_files" line 20)
invoked from within
"reload_files"
(file "./amsn" line 215)
fiz todos os passo.

[28] Comentário enviado por claudiovaz em 07/07/2006 - 17:04h

caro amigo estou tendo problemas para instalar o amsn 0.93 no conectiva 10 Uso o Conectiva 10 e o KDE 3.2. Os primeiros problemas como os relatados nesta pagina por outras pessoas consegui resolver, mas quando executo o ./configure aparece o seguinte:

./configure
checking for Tcl configuration... found /usr/lib/tclConfig.sh
checking for Tk configuration... found /usr/lib/tkConfig.sh
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
configure: error: Tcl and Tk must be configured with the --enable-shared flag
já fiz este procedimento e continua me dando o mesmo erro o que pode ser.
/configure --enable-shared

./configure --enable-shared && make && make install.
desde já agradeço.
claudio vaz



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts