Instalando o X-lite

Publicado por Eliab Coelho Venancio em 02/02/2010

[ Hits: 35.937 ]

Blog: http://www.eliabvenancio.blogspot.com/

 


Instalando o X-lite



Esta dica vem mostrar como instalar por completo o x-lite e como resolver o erro libstdc++5, que por muitas vezes compromete o processo.

Com o grande avanço da tecnologia, muitas pessoas estão incluindo em seu cotidiano o Voip, telefone por ip. É uma tecnologia que ainda está em crescimento, mas é muito eficiente e de baixo custo.

Lembrando que para funcionar é preciso ter um cadastro, que te informará uma senha e um login que serão usados para configurar o serviço/programa. Enfim, para você que se interessou pela dica, vamos ao trabalho.

Primeiro vamos instalar um programa que é compatível com seu sistema operacional, como exemplo vamos instalar o x-lite no Ubuntu.

Faça o download do arquivo no seguinte link:
Salve-o na pasta Downloads. Em seguida entre no terminal e vá até esta pasta.

cd Downloads

Agora vamos descompactar o arquivo.

tar -vzxf nomedoarquivo.tar.gz

No nosso caso digitamos:

tar -vzxf X-Lite_Install.tar.gz

Entre na pasta xten-xlite.

cd xten-xlite/

Digite:

./xtensoftphon

Após dar enter ele vai executar o x-lite.

Se não executar é porque falta o pacote libstdc++5_3.3.6-15ubuntu6_i386.deb. Vamos baixar a libstdc++.so.5 dos repositórios do Ubuntu, é mais confiável.

wget http://br.archive.ubuntu.com/ubuntu/pool/universe/g/gcc-3.3/libstdc++5_3.3.6-15ubuntu6_i386.deb

Vamos extrair o pacote:

dpkg -X libstdc++5_3.3.6-15ubuntu6_i386.deb ~

Vamos copiar a lib para o diretório padrão dela:

sudo cp usr/lib/libstdc++.so.5 /usr/lib

Pronto! Agora volte e digite novamente:

./xtensoftphon

Agora sim, irá executar o programa sem nenhum problema.

Outras dicas deste autor

Instalando codecs e players não-livres no Debian GNU/Linux

Aprenda mais sobre o GNU/Linux

Removendo o OpenOffice.org e instalando o BrOffice.org

Instalando o LXDE

Leitura recomendada

Como instalar o TeamSpeak 3 no Ubuntu Linux

Instalando o ATi Stream SDK no GNU/Linux

Trabalhando com PV, VG e LV

Use Zenwalk

Migrar Samba 4 entre servidores CentOS 7

  

Comentários
[1] Comentário enviado por cleysinhonv em 02/02/2010 - 16:08h

Olá meu caro,

Ótima dica, configurar softwares para dar suporte a voip, essa dica será muito importante para as pessoas que usam Linux aqui na Universidade. Parabéns, continue assim.

[2] Comentário enviado por Eliab venancio em 02/02/2010 - 16:25h

Obrigado Claysinho é um enorme prazer poder ajudar alguém espero que isso possa ser útil a muitos iniciantes do linux que muitas vezes desistem por falta de informação!


[3] Comentário enviado por luanyata em 30/03/2010 - 10:42h

POw vlw cara ... tava procurando isso ...

Uma dica para as pessoas q usam Debian se pedir o libstdc++.so.5 basta instalar o libstdc++5

apt-get install libstdc++5

flw... ;)

[4] Comentário enviado por Eliab venancio em 31/03/2010 - 08:18h

vlw pela dica...



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts