Instalando o BrOffice 3 no Debian Lenny Linux

Publicado por Valério Dias em 04/03/2009

[ Hits: 14.415 ]

 


Instalando o BrOffice 3 no Debian Lenny Linux



Fala, galera!

Esta é outra dica de minha autoria postada no FGdH e que trago para cá.

Com o lançamento do Debian Lenny, muitos pacotes foram atualizados em relação ao Etch. O Firefox veio na sua última versão (3.0.6), entretanto o OpenOffice sofreu um "incrível" salto de atualização, passado da versão 2.0 (Etch) para a... 2.4.1 (Lenny). E a tradição do Debian é estabilidade e segurança sempre. Isso é bom, em contrapartida os pacotes ficam meio fora de moda com o tempo e a velocidade de desenvolvimento dos programas SL.

Bem, se você prima pela estabilidade e segurança pode ficar com a suíte 2.4.1 do OpenOffice que acompanha o Lenny. Ela receberá correções de segurança mas não deixará de ser a 2.4.1. Mas você pode, se quiser, instalar a versão mais nova do pacote, a 3.0.1. Pode inclusive manter as duas versões instaladas.

Então vamos lá: baixe o pacote para o Debian em:

ftp://ftp.unicamp.br/pub/broffice/stable/3.0.1/BrOo_3.0.1_LinuxIntel_install_pt-BR_deb.tar.gz

Feito o download, descompacte o arquivo .tar.gz que contém os pacotes .DEB, depois entre na pasta OOO300_m15_native_packed-1_pt-BR.9379 e execute o comando para instalar todos os pacotes .DEB. Resumindo:

# tar -zxvf BrOo_3.0.1_LinuxIntel_install_pt-BR_deb.tar.gz
# cd OOO300_m15_native_packed-1_pt-BR.9379
# dpkg -i *deb


Pronto! O BrOffice 3 está instalado na pasta /opt. Para criar os ícones de menu entre na pasta DEBS/desktop-integration (que está dentro da cd OOO300_m15_native_packed-1_pt-BR.9379) e instale o .DEB contido na pasta:

# dpkg -i *deb

Agora você tem as duas versões da suíte. Se preferir manter somente o BrOffice 3 instalado, recomendo antes remover o OpenOffice original. Para isso antes de instalar o BrOffice 3 vamos remover o OpenOffice pelo Synaptic. Não use o Adicionar/Remover aplicações para a tarefa, pois ele trabalha com um banco de dados de dependências, de forma que se você tentar remover um dos pacotes da suíte (mesmo se marcar todos os pacotes) ele irá abortar alertando que outro pacote da suíte necessita do pacote que está tentando desinstalar.

# synaptic

Clique em "Procurar" e jogue a expressão "openoffice". Na listagem obtida clique com o botão direito em todos os pacotes com o nome openoffice instalados (quadradinho verde) e escolha "Remoção completa". Assim, além dos pacotes da suíte o Synaptic excluirá também os arquivos de configuração. Feito isso clique em "Aplicar". Aguarde a conclusão do processo. Ao seu final deverá ter apenas a entrada Correio e Agenda do Evolution no menu Aplicações > Escritório. Feche o Synaptic.

Agora sim instale o BrOffice 3:

# tar -zxvf BrOo_3.0.1_LinuxIntel_install_pt-BR_deb.tar.gz
# cd OOO300_m15_native_packed-1_pt-BR.9379
# dpkg -i *deb
# cd DEBS/desktop-integration
# dpkg -i *deb


Veja na imagem como fica o menu Aplicações > Escritório com a suíte instalada.
Linux: Dica: instalando o BrOffice 3 no Debian Lenny
Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Vero (verificador ortográfico)

OpenOffice.org e navegador Chomium em português do Brasil no Ubuntu (ou Debian)

Instalando o OpenOffice 3 no Slackware Linux

BRoffice 3 no Slackware Linux 12.1: Solução para teclas que não funcionam

Salvando arquivos OpenOffice em outro formato como padrão

  

Comentários
[1] Comentário enviado por thibaba em 17/04/2009 - 18:05h

Ola Aki no meu debian na hora de executa o comando *deb esta aparecendo esta mensagem:
dpkg: erro processando *deb (--install):
impossível acessar arquivo: Arquivo ou diretório não encontrado
Erros foram encontrados durante o processamento de:
*deb
Oq sera que aconteceu?

[2] Comentário enviado por milk2can em 18/04/2009 - 01:49h

[email protected]!

Bem, é estranho ter ocorrido este erro. Veja se você procedeu exatamente da forma abaixo:

# tar -zxvf BrOo_3.0.1_LinuxIntel_install_pt-BR_deb.tar.gz (descompactar o pacote .tar.gz baixado)

# cd OOO300_m15_native_packed-1_pt-BR.9379 (entrar na pasta criada com o comando acima)

# dpkg -i *deb (instalar os pacotes .DEB)

Isso instala o pacote completo do BrOffice 3.0.1. Agora basta proceder conforme abaixo para instalar os menus de acesso aos programas da suíte.

# cd DEBS/desktop-integration (você roda este comando de dentro da pasta criada na descompactação do pacote .tar.gz)

# dpkg -i *deb

Caso ainda não funcione experimente usar "*.deb" ao invés de "*deb".

[3] Comentário enviado por thibaba em 18/04/2009 - 18:46h

E ainda não deu certo hein amigo veja como esta aki no meu debian 5.
ThiGlobal:/home/thibaba/OOO300_m15_native_packed-1_pt-BR.9379# ls
DEBS licenses readmes update
ThiGlobal:/home/thibaba/OOO300_m15_native_packed-1_pt-BR.9379# dpkg -i *.deb
dpkg: erro processando *.deb (--install):
impossível acessar arquivo: Arquivo ou diretório não encontrado
Erros foram encontrados durante o processamento de:
*.deb
tudo com vc passou.
ok sera que esta errado?

[4] Comentário enviado por thibaba em 18/04/2009 - 19:11h

Não sei se tem alguma coisa a ver mas no icone da pasta descompactada tem um cadeado sera q tem alguma coisa a ver?

[5] Comentário enviado por milk2can em 20/04/2009 - 17:31h

Cara, eu acho que achei o erro na sua mensagem, porém de minha parte. Dentro da pasta OOO300_m15_native_packed-1_pt-BR.9379 tem a pasta DEBS. Entre nesta pasta, aí sim execute o comando dpkg -i *.deb.

O erro foi meu. Tem a pasta DEBS dentro da pasta OOO300_m15_native_packed-1_pt-BR.9379. Agora deve funcionar. Pena que não tem como editar o texto. O erro foi meu. Sorry!

[6] Comentário enviado por wellingto em 25/04/2009 - 19:35h

Olá amigo, fico grato, pela Dica graças ao seu topico eu consegui instalar o BrOffice 3.0.1, no meu linux, brlix no começo eu achei dificil mas depois que eu dei uma lida por completo, foi que entendi, ai eu só segui os passos.
vlw.....[:D

[7] Comentário enviado por wellingto em 25/04/2009 - 19:37h

se alguem tiver alguma Duvida, sobre a distro pode até ver no site.
http://brlix.com/site/

[8] Comentário enviado por djonatanb em 17/03/2010 - 10:44h

CORREÇÃO DO POST.

# tar -zxvf BrOo_3.0.1_LinuxIntel_install_pt-BR_deb.tar.gz
# cd OOO300_m15_native_packed-1_pt-BR.9379
# cd DEBS
# dpkg -i *deb
# cd DEBS/desktop-integration
# dpkg -i *deb

Não existem arquivos .deb dentro da pasta OOO300_m15_native_packed-1_pt-BR.9379.
Isso me consumiu um tempo até entender... como sou usuário noobie no linux tive que futricar pra entender o erro.
Espero que funcione para todos

[9] Comentário enviado por zeta em 16/04/2011 - 22:05h

Eu tb consegui instalaro o OpenOffice 3.3 no Debian Lenny 5.0.7. Bem, pelo q eu vi vc o instalou duas vezes. Vou descrever como eu fiz:

# aptitude remove openoffice.org-common << isso remove a versão antiga e todos os pacotes necessários para rodar o OpenOffice.

Porém isso remove tb o JRE necessário para instalar o Openoffice, então eu os reinstalei:

#aptitude install java-common default-jre

aí sim, instalei o OpenOffice 3

# tar -zxvf BrOo_3.0.1_LinuxIntel_install_pt-BR_deb.tar.gz
# cd DEBS/desktop-integration
# dpkg -i *deb
# cd OOO300_m15_native_packed-1_pt-BR.9379
# dpkg -i *deb

Bem, comigo foi assim, e funcionou



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts