Instalando Firefox 8 no Fedora 14

Publicado por Marcos Rocha de Oliveira em 12/12/2011

[ Hits: 7.298 ]

 


Instalando Firefox 8 no Fedora 14



1- Abra um Terminal e torne-se 'root' (su ou sudo -i).

2- Instale o repositório RPM-Fusion com os seguintes comandos:

# rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
# rpm -Uvh http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm

3- Instale o seguinte repositório:

# rpm -Uvh http://rpms.famillecollet.com/remi-release-14.rpm

4- Execute o comando para ativar o repositório Remi-Release e atualizar o Firefox (responda sim para a mensagem de atualização):

# yum --enablerepo=remi update firefox

Ou:

# yum --enablerepo=remi install firefox

Pronto! O Firefox já estará atualizado para versão 8.0.

Outras dicas deste autor

SQL Developer no Fedora

Leitura recomendada

Slackware e BIND - Corrigindo erro em chroot após upgrade

Mozilla Firefox Nightly - Instalação fácil no Ubuntu

Instalando aMSN no Slackware 12 e 12.2 da forma mais simples possível

IP Fixo no Sabayon Linux - Um jeito fácil

Extensões do Firefox úteis

  

Comentários
[1] Comentário enviado por adilson.pacheco em 17/01/2012 - 21:26h

Marcos ao tentar a atualização conforme sua DICA ,obtive a informação conforme abaixo descrito, como sou usuario inexperiente no Fedora, gostaria de ajuada de como devo proceder,
[Adilson@PachecoPC ~]$ SU
bash: SU: command not found...
[Adilson@PachecoPC ~]$ su
Senha:
[root@PachecoPC Adilson]# rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
Obtendo http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
Preparando... ########################################### [100%]
o pacote rpmfusion-free-release-14-2.noarch já está instalado
[root@PachecoPC Adilson]# rpm -Uvh http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
Obtendo http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm
Preparando... ########################################### [100%]
o pacote rpmfusion-nonfree-release-14-2.noarch já está instalado
[root@PachecoPC Adilson]# rpm -Uvh http://rpms.famillecollet.com/remi-release-14.rpm
Obtendo http://rpms.famillecollet.com/remi-release-14.rpm
Preparando... ########################################### [100%]
o pacote remi-release-14-6.fc14.remi.noarch já está instalado
[root@PachecoPC Adilson]# yum --enablerepo=remi update firefox
Plugins carregados: fastestmirror, langpacks, presto, refresh-packagekit
Adding pt_BR to language list
Loading mirror speeds from cached hostfile
updates/metalink | 49 kB 00:01
* fedora: fedora.c3sl.ufpr.br
* remi: rpms.famillecollet.com
* rpmfusion-free: mirror.us.leaseweb.net
* rpmfusion-free-source: mirror.us.leaseweb.net
* rpmfusion-free-updates: mirror.us.leaseweb.net
* rpmfusion-free-updates-source: mirror.us.leaseweb.net
* rpmfusion-nonfree: mirror.us.leaseweb.net
* rpmfusion-nonfree-source: mirror.us.leaseweb.net
* rpmfusion-nonfree-updates: mirror.us.leaseweb.net
* updates: fedora.c3sl.ufpr.br
epel-firefox5 | 1.3 kB 00:00
epel-firefox6 | 2.9 kB 00:00
remi | 2.9 kB 00:00
rpmfusion-free-updates | 3.3 kB 00:00
rpmfusion-free-updates-source | 2.7 kB 00:00
rpmfusion-nonfree-updates | 3.3 kB 00:00
Configurando o processo de atualização
Resolvendo dependências
--> Executando verificação da transação
---> Pacote firefox.i686 0:9.0.1-1.fc14.remi definido para ser atualizado
--> Processando dependência: gecko-libs(x86-32) = 9.0.1-1 para o pacote: firefox-9.0.1-1.fc14.remi.i686
--> Processando dependência: xulrunner9(x86-32) = 9.0.1 para o pacote: firefox-9.0.1-1.fc14.remi.i686
--> Executando verificação da transação
--> Processando dependência: gecko-libs(x86-32) = 5.0.1-1 para o pacote: firefox5-5.0.1-1.el6.leigh123linux.i686
---> Pacote xulrunner9.i686 0:9.0.1-1.fc14.remi definido para ser instalado
--> Resolução de dependências finalizada
Error: Pacote: firefox5-5.0.1-1.el6.leigh123linux.i686 (@epel-firefox5)
Requer: gecko-libs(x86-32) = 5.0.1-1
Removendo: xulrunner5-5.0.1-1.el6.leigh123linux.i686 (@epel-firefox5)
gecko-libs(x86-32) = 5.0.1-1
Obsoleted By: xulrunner9-9.0.1-1.fc14.remi.i686 (remi)
gecko-libs(x86-32) = 9.0.1
Removendo: xulrunner6-6.0.2-1.fc14.remi.i686 (@remi)
gecko-libs(x86-32) = 6.0.2-1
Obsoleted By: xulrunner9-9.0.1-1.fc14.remi.i686 (remi)
gecko-libs(x86-32) = 9.0.1
Disponível: xulrunner6-6.0-1.el6.leigh123linux.i686 (epel-firefox6)
gecko-libs(x86-32) = 6.0-1
Disponível: xulrunner8-8.0-1.fc14.remi.i686 (remi)
gecko-libs(x86-32) = 8.0
Você pode tentar usar o parâmetro --skip-broken para contornar o problema
Você pode tentar executar: rpm -Va --nofiles --nodigest
[root@PachecoPC Adilson]# rpm -Va --nofiles --nodigest
[root@PachecoPC Adilson]# yum --enablerepo=remi install firefox
Plugins carregados: fastestmirror, langpacks, presto, refresh-packagekit
Adding pt_BR to language list
Loading mirror speeds from cached hostfile
* fedora: fedora.c3sl.ufpr.br
* remi: remirpm.mirror.gymkl.ch
* rpmfusion-free: mirror.us.leaseweb.net
* rpmfusion-free-source: mirror.us.leaseweb.net
* rpmfusion-free-updates: mirror.us.leaseweb.net
* rpmfusion-free-updates-source: mirror.us.leaseweb.net
* rpmfusion-nonfree: mirror.us.leaseweb.net
* rpmfusion-nonfree-source: mirror.us.leaseweb.net
* rpmfusion-nonfree-updates: mirror.us.leaseweb.net
* updates: fedora.c3sl.ufpr.br
Configurando o processo de instalação
Resolvendo dependências
--> Executando verificação da transação
---> Pacote firefox.i686 0:9.0.1-1.fc14.remi definido para ser atualizado
--> Processando dependência: gecko-libs(x86-32) = 9.0.1-1 para o pacote: firefox-9.0.1-1.fc14.remi.i686
--> Processando dependência: xulrunner9(x86-32) = 9.0.1 para o pacote: firefox-9.0.1-1.fc14.remi.i686
--> Executando verificação da transação
--> Processando dependência: gecko-libs(x86-32) = 5.0.1-1 para o pacote: firefox5-5.0.1-1.el6.leigh123linux.i686
---> Pacote xulrunner9.i686 0:9.0.1-1.fc14.remi definido para ser instalado
--> Resolução de dependências finalizada
Error: Pacote: firefox5-5.0.1-1.el6.leigh123linux.i686 (@epel-firefox5)
Requer: gecko-libs(x86-32) = 5.0.1-1
Removendo: xulrunner5-5.0.1-1.el6.leigh123linux.i686 (@epel-firefox5)
gecko-libs(x86-32) = 5.0.1-1
Obsoleted By: xulrunner9-9.0.1-1.fc14.remi.i686 (remi)
gecko-libs(x86-32) = 9.0.1
Removendo: xulrunner6-6.0.2-1.fc14.remi.i686 (@remi)
gecko-libs(x86-32) = 6.0.2-1
Obsoleted By: xulrunner9-9.0.1-1.fc14.remi.i686 (remi)
gecko-libs(x86-32) = 9.0.1
Disponível: xulrunner6-6.0-1.el6.leigh123linux.i686 (epel-firefox6)
gecko-libs(x86-32) = 6.0-1
Disponível: xulrunner8-8.0-1.fc14.remi.i686 (remi)
gecko-libs(x86-32) = 8.0
Você pode tentar usar o parâmetro --skip-broken para contornar o problema
Você pode tentar executar: rpm -Va --nofiles --nodigest
[root@PachecoPC Adilson]# --skip-broken
bash: --skip-broken: command not found...
[root@PachecoPC Adilson]# exit
exit
[Adilson@PachecoPC ~]$
Desde já agradeço a colaboração

[2] Comentário enviado por mro em 07/02/2012 - 01:12h

desinstala o firefox 5: #yum erase firefox5-5.0.1-1.el6.leigh123linux.i686 e tenta novamente.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
{BANNER_MODEL3}

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts