Instalando Broadcom BCM43 no LinuxMint

Publicado por Clodoaldo Santos em 22/05/2013

[ Hits: 56.761 ]

 


Instalando Broadcom BCM43 no LinuxMint



Nesta Dica, veremos como ativar a Placa Wireless Broadcom-BCM43 no LinuxMint-13/14.

Passos

Passo 1: Remover o pacote bcmwl-kernel-source.

Para isto, abra o Terminal e digite o comando abaixo. Caso o pacote não esteja instalado, ignore esta Etapa.

sudo apt-get remove bcmwl-kernel-source

Passo 2: Atualizar os repositorios:

sudo apt-get update

Passo 3: Instalar o Driver B43:

sudo apt-get install b43-fwcutter firmware-b43-installer

Terminada a instalação.

Reinicie sua máquina e verifique se sua placa foi ativada!

Outras dicas deste autor

Instalando FrostWire no Debian 8

Instalando Google Chrome no openSUSE Leap 15

Instalando Skype para Linux Beta no Linux Mint 18

Gravando Mageia 3 no pendrive

GUFW não abre no Ubuntu 16.04 LTS [RESOLVIDO]

Leitura recomendada

Driver Radeon no Debian 7.1 Wheezy

Instalando impressora Epson Stylus T24 no Linux

Instalando Encore ENL832-TX-ICNT no Slackware

Impressora HP Color LaserJet 2600n USB (e similares) no GNU/Linux

Multifuncional Samsung SCX-3200

  

Comentários
[1] Comentário enviado por gpvariquemes em 07/11/2013 - 22:27h

P Q P .... TENS NOCAO D QTO TEMPO JA PERDI TENTANDO FAZER FUNCIONAR ESSA REDE ... DESDE 2008... DISTRO APOS DISTRO, E SEMPRE ACABAVA VOLTANDO PRA "M" DO WINDOWS SO PQ NAO CONSEGUIA FAZER FUNCIONAR O WI-FI ... SO DE ONTEONTEM PRA K JA INSTALEI E REINSTALEI DE DISTRO A PCTES DE ESTRUTURACAO DE DRIVES E NADA ... E AGORA "ISSO" ... iSSO ACABOU!!!!!!! ,,, TO OPERANDO DO WI-FI COM UM LINUX ... VALEU "CLODOALDO" !!! ... KKKKKKKKKKKKKKKKKKK ... VALEU !!!

[2] Comentário enviado por clodoaldops em 07/11/2013 - 22:31h

gpvariquemes, eu tinha um dell-1525 c/ essa wifi e penei com ele tbém. Ainda bem que tá resolvido! E que vc não desistiu!

[3] Comentário enviado por lilianalcantara em 10/02/2015 - 01:52h

É preciso baixar 3.960 B/30,4 kB de arquivos.
Depois desta operação, 154 kB adicionais de espaço em disco serão usados.
Troca de mídia: por favor, insira o disco nomeado
'Xubuntu 14.04.1 LTS _Trusty Tahr_ - Release amd64 (20140723)'
na unidade '/media/cdrom/' e pressione enter


como instalei por pen drive nem tenho como inserir o disco pelo cd... ai travo nessa parte e passo raiva toda vez, como prosseguir?

[4] Comentário enviado por lilianalcantara em 10/02/2015 - 11:56h

continuo sem instalar... to tentando também lá pelos "drives adicionais" mas fica mais de horas sem mover a barrinha de processo e nunca termina...

[5] Comentário enviado por aateixeira em 18/06/2015 - 22:09h


Muiiiiito Obrigado, funcionou super! super simples de fazer e funcionou 100%. Viva o Linux

[6] Comentário enviado por jluizg em 08/11/2015 - 22:29h

Tentei e não consegui.

Esta é a segunda tentativa, depois de reiniciar o computador.

jl@JL-NB:~$ sudo apt-get remove bcmw1-kernel-source
[sudo] password for jl:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote bcmw1-kernel-source

jl@JL-NB:~$ sudo apt-get install b43-fwcutter firmware-b43-installer
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
b43-fwcutter já é a versão mais nova.
firmware-b43-installer já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

Ainda sem wifi!

[7] Comentário enviado por clodoaldops em 08/11/2015 - 22:53h

jluizg :
-poste saida do comando: rfkill list all
-veja saida hard blocked yes/no
-tem que estar no

[8] Comentário enviado por murderb13 em 29/01/2016 - 10:01h

Parabéns!!!!

[9] Comentário enviado por stahlschmidt em 13/03/2016 - 19:26h

Parabéns, pelo artigo! Tenho um Dell Latitude 131L e ao instalar a distribuição Lubuntu (e Ubuntu 14.04) só a rede com cabo era reconhecida. Através dos comandos elencados no artigo, a rede sem fio passou a funcionar.

[10] Comentário enviado por clodoaldops em 22/08/2016 - 23:44h

Dica funcionou para ativar Broadcom BCM43 no Ubuntu, xubuntu, lubuntu e kubuntu

[11] Comentário enviado por mvzereks em 17/10/2016 - 17:30h

Parabéns clodoaldops pelo post. Valeu!

[12] Comentário enviado por lieechan em 06/03/2017 - 14:05h

Caraca, quando tava quase desistindo do linux e voltando pro windows tu apareceu !
Valeu pela ajuda e parabéns pelo post !

[13] Comentário enviado por CarlosARP em 19/07/2017 - 01:52h

Obrigado por esta dica! Estava ralando há três dias para ativar minha rede wifi. Tinha ativado um tópico aqui na comunidade e um outro membro estava me ajudando, mas ainda pesquisava por outras alternativas até achar esta dica.

[14] Comentário enviado por clodoaldops em 19/07/2017 - 09:19h

Uma alternativa "mais simples" seria usar o gerenciador de drivers do linux-mint para ativar o wifi broadcom

[15] Comentário enviado por elysio em 14/11/2018 - 11:41h

Cara, tenho que agradecer DEMAIS pela dica!!! Fiquei dias me debatendo em diversos fóruns. Primeiro a placa nem era reconhecida, até atualizar o Linux com uma conexão cabeada. Aí as redes eram vistas, mas o computador não se conectava por nada (nem dava erro). Segui as dicas de outro fórum e perdi as redes (embora a placa estivesse reconhecida lá). Com a dica acima, deu tudo certo! Segui os passos com meu MacBook A1181 (início de 2008), com 2Gb de SDRAM e SSD de 480Gb e Ubuntu 18.04. Valeu demais!!!

[16] Comentário enviado por clodoaldops em 14/11/2018 - 12:09h

elysio , dica antiga mas é bom saber que ainda funciona e bem vindo ao Linux!

[17] Comentário enviado por claucio23 em 26/11/2018 - 13:20h

Respondendo ao seu comentário no meu tópico:
https://www.vivaolinux.com.br/topico/Modems/Wifi-Desligado-No-Dell-Inspiron-1525-Linux-Mint-171/?pag...

Primeiramente, obrigado!

Por vias tortas, mas o Wifi voltou.

Achei estranho, mas veja só:

Fiz os passos deste link acima. Reiniciei, e nada de Wifi.

Fui no Gerenciador de Drivers e estava ativada na 3ª opção da minha lista que eu publiquei no tópico, a ([b]firmware-b43legacy-installer[/b]).

Aí eu ativei mudanças novamente [i]para a versão que estava antes[/i] ([b]bcmwl-kernel-source (recomendado) versão 6.30.22.248+bdcom-ubunto0.2[/b])

e... funcionou!

Vou colocar o tópico como resolvido, mas vc tem ideia do que pode ter sido?

[18] Comentário enviado por reginaldohd em 12/06/2019 - 15:00h

No Dell Vostro 1000, rodando Lubuntu 18, funcionou certinho. Muito obrigado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts