Instalação Multifuncional Lexmark x1270

Publicado por Weidllan Djeizo Dos Santos em 02/01/2009

[ Hits: 15.889 ]

Blog: http://www.ubuntu-br.org

 


Instalação Multifuncional Lexmark x1270



É necessário ter acesso a internet para fazer a instalação dos pacotes e o download dos mesmos.

Primeiramente faça a instalação dos seguintes pacotes:
Obedecendo essa ordem.

Copie os arquivos:
Para a pasta /etc/sane.d, abrindo o terminal/consola e digitado:

sudo cp dll.conf /etc/sane.d
$ sudo cp lexmark.conf /etc/sane.d


Copie agora esse arquivo Lexmark:X1200_USB1.1.drc para a pasta /home/USER/.sane/Xsane.

Repita o mesmo procedimento:

sudo cp home-User-.sane-Xsane/Lexmark:X1200_USB1.1.drc /home/USER/.sane/Xsane

Copie agora esses quatro arquivos:
Para a pasta /usr/lib/sane, repetindo o mesmo procedimento:

sudo cp libsane-lexmark.la
$ sudo cp libsane-lexmark.so.1
$ sudo cp libsane-lexmark.so.1.0.19


Pronto! E está funcionando, como vocês podem ver nessa imagem:
Linux: Instalação Multifucional Lexmark x1270
Outras dicas deste autor

Tutorial básico do APT-GET

SM56 Motorola com driver Smartlink

Internet Giro Embratel no Linux

Simulando um usuário root no terminal Linux

Zoom nas fontes de sites pelo Firefox

Leitura recomendada

Instalar Firefox com plugin Flash Player no Debian Squeeze

Aprenda a voar sem segredos com o Kernel Linux 2.6.34-omnislash

Instalando o cliente Oracle no Slackware 12 para uso do SQLPLUS

Nomeando / renomeando uma partição de disco

Ubuntu Satanic

  

Comentários

[2] Comentário enviado por Weidllan em 26/08/2010 - 12:15h

Pra quem usar Ubuntu 10.04
Vi no Forum: http://ubuntuforum-pt.org/index.php?topic=61465.0
Ta todos os pacotes necessários para a instalação: http://www.easy-share.com/1908438339/Z617.tar.gz

[3] Comentário enviado por tiagomota em 23/10/2011 - 12:39h

_Poxa... quando eu uso o DPKG --force-all -iz600*.deb aparece o seguinte erro,

[email protected]:/home/mota/Downloads/lexmark# dpkg --force-all -i z600*.deb
dpkg-deb: 'z600cups_1.0-2_i386.deb' não é um formato de arquivo debian
dpkg: erro processando z600cups_1.0-2_i386.deb (--install):
sub-processo dpkg-deb --control retornou estado de saída de erro 2
dpkg-deb: 'z600llpddk_2.0-2_i386.deb' não é um formato de arquivo debian
dpkg: erro processando z600llpddk_2.0-2_i386.deb (--install):
sub-processo dpkg-deb --control retornou estado de saída de erro 2
Erros foram encontrados durante o processamento de:
z600cups_1.0-2_i386.deb
z600llpddk_2.0-2_i386.deb
[email protected]ota-desktop:/home/mota/Downloads/lexmark#

_O que devo fazer???

[4] Comentário enviado por Weidllan em 26/10/2011 - 17:03h

Saia do usuário 'ROOT'

E como usuário comum digite: sudo dpkg -i *.deb
Caso ocorra algum erro mesmo assim, execute em modo gráfico os pacotes e faca a instalação, caso notifique que as dependências não foram satisfeitas, pegue o nome do pacote e instale.

Espero ter ajudado!
Qualquer coisa, estamos as ordens!
Boa Tarde.

[5] Comentário enviado por tiagomota em 14/11/2011 - 11:15h

Então mesmo sem ser Root, deu erro também

[email protected]:~/Downloads/lexmark$ sudo dpkg -i *.deb
dpkg: erro processando *.deb (--install):
impossível acessar arquivo: Arquivo ou diretório não encontrado
Erros foram encontrados durante o processamento de:
*.deb

repetindo todo o processo acima aconteceu o seguinte....

[email protected]:~/Downloads/lexmark$ sudo cp dll.conf /etc/sane.d
cp: impossível obter estado de `dll.conf': Arquivo ou diretório não encontrado

mais quado eu dou o wget ele finaliza assim óh...

[email protected]:~/Downloads/lexmark$ wget -c http://www.indexdata.com.br/Linux/Drivers/Impressoras/LexMark/etc-sane.d/lexmark.conf">http://www.indexdata.com.br/Linux/Drivers/Impressoras/LexMark/etc-sane.d/lexmark.conf
--2011-11-14 11:21:57-- http://www.indexdata.com.br/Linux/Drivers/Impressoras/LexMark/etc-sane.d/lexmark.conf">http://www.indexdata.com.br/Linux/Drivers/Impressoras/LexMark/etc-sane.d/lexmark.conf
Resolvendo http://www.indexdata.com.br..">www.indexdata.com.br... 74.53.231.66
Conectando-se a http://www.indexdata.com.br|74.53.231.66|:80..">www.indexdata.com.br|74.53.231.66|:80... conectado!
HTTP requisição enviada, aguardando resposta... 302 Found
Localização: http://www.indexdata.com.br [seguinte]
--2011-11-14 11:21:57-- http://www.indexdata.com.br/
Reaproveitando a conexão existente para www.indexdata.com.br:80.
HTTP requisição enviada, aguardando resposta... 416 Requested Range Not Satisfiable

O arquivo já foi completamente obtido; nada a ser feito.

ele aparece essa ultima frase em todos os downloads... não sei o que fazer, não faço idéia do problema...

[6] Comentário enviado por Weidllan em 18/11/2011 - 00:09h

Os links do sistema não está mais funcionado!
Mas achei um um passo-a passo: http://ubuntuforum-pt.org/index.php?topic=10260.0
Espero que ajude, qualquer coisa volte a postar!

Boa Noite.

[7] Comentário enviado por Blanchu em 25/01/2012 - 21:03h

Eu estou enfrentando o seguinte problema na instalação da impressora lexmark x1270:

Usei dois procedimentos parecidos:
$ mkdir lexmark _temp
$ mv CJLZ600LE-CUPS-1.0-1.TAR.gz lexmark _temp # move o pacote abaixado para uma pasta.
$ tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz # extrai os drives.
$ tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz # extrai os arquivos binários do script de instalação.
$ tar -xvzf install.tar.gz # extrai os drives do arquivo de instalação produzidos pelo tail.
$ alien -t z600cups-1.0-1.i386.rpm # converte pacotes rpm para tgz.
$ alien -t z600llpddk-2.0-1.i386.rpm # converte pacotes rpm para tgz.
$ sudo tar xvzf z600llpddk-2.0.tgz -C / # extrai os pacotes .tgz para seus devidos lugares.
$ sudo tar xvzf z600cups-1.0.tgz -C / # extrai os pacotes .tgz para seus devidos lugares.
$ sudo ldconfig # Atualiza as bibliotecas dos computador
$ cd /usr/share/cups/model
$ sudo gunzip Lexmark-Z600-lxz600cj-cups.ppd.gz # descompacta o arquivo ppd
Com isso o drive foi instalado. Reinicie o cups-daemon:
/etc/init.d/cupsys restart
(O resultado, a partir daqui deu no seguinte erro:
:/$ /etc/init.d/cupsys restart
bash: /etc/init.d/cupsys: Arquivo ou diretório não encontrado

:/$ cd /etc/init.d/etc/init.d/
:/etc/init.d$
:/$ cupsys
restart
cupsys: comando não encontrado)
Verifique se a impressora está funcionando:
$ cd /usr/lib/cups/backend $ ./z600
O resultado do comando acima deve ser parecido com isso:
direct z600:/dev/usb/lp0 "Lexmark Lexmark Z600 Series" "Lexmark Printer"
Pronto! Agora você deve ir no menu Sistema->Administração->Imprimindo. Quando tiver que selecionar o drive escolha o drive que você tiver instalado (z600, z35, ...).

Um outro método similar:
$ mkdir lexmark_temp
$ mv CJLZ600LE-CUPS-1.0-1.TAR.gz lexmark_temp # move the package to a folder. optional, but recommended.
$ tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz # extract the driver.
$ tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz # the sh script is broken for newer systems. use `tail` to extract the binary portion of the script.
$ tar -xvzf install.tar.gz # extract the contents produced by tail
$ alien -t z600cups-1.0-1.i386.rpm # convert unusable rpm packages to tgz.
$ alien -t z600llpddk-2.0-1.i386.rpm # convert unusable rpm packages to tgz.
$ sudo tar xvzf z600llpddk-2.0.tgz -C / # extract the tgz's to / putting the files in their right place
$ sudo tar xvzf z600cups-1.0.tgz -C / # extract the tgz's to / putting the files in their right place
$ sudo ldconfig # DO NOT SKIP THIS STEP or your printer backend won't find required libraries
$ cd /usr/share/cups/model
$ sudo gunzip Lexmark-Z600-lxz600cj-cups.ppd.gz # unzip the ppd, which should _not_ be gzipped
# The driver is now installed.
Restart the cups daemon:
# /etc/rc2.d/S19cupsys restart
(resultou no mesmo erro:
bash: /etc/irc2.d/S19upsys: Arquivo ou diretório não encontrado

:/$ cd /etc/rc2.d/
:/etc/rc2.d$
:/$ cupsys
restart
cupsys: comando não encontrado)

Check whether the printer backend works:
#$ cd /usr/lib/cups/backend

$ ./z600

The output of the above command should be _similar_ to this:
direct z600:/dev/usb/lp0 "Lexmark Lexmark Z600 Series" "Lexmark Printer"

If you get no output, mount the usb filesystem.
Add this to your /etc/fstab file:
usbfs /proc/bus/usb usbfs devgid=14,devmode=0660 0 0

Then just type: sudo mount usbfs. That should fix it.

Now simply set up your printer through the System->Administration->Printing in gnome. Make sure you select the z600 driver, and you're golden.


Mesmo antes desses procedimentos, o scanner já funcionava perfeitamente, mas a impressora não.

[8] Comentário enviado por weidllan em 05/02/2012 - 14:15h

Fiz a instalação em outro sistema e só precisei do meus com os pacotes .DEB e consegui fazer a impressora funcionar, mas só é compatível se o sistema for 32bits.




Contribuir com comentário