Iniciando conexão ADSL no boot do Ubuntu (problemas com PPPOECONF)

Publicado por Paulo Moraes em 14/09/2006

[ Hits: 14.929 ]

 


Iniciando conexão ADSL no boot do Ubuntu (problemas com PPPOECONF)



Olá, esta é minha primeira dica aqui no VOL e decidi colocá-la pela escassez de informação sobre o assunto que verifiquei na internet. Fui (e ainda sou) usuário do Slackware por muito tempo, mas resolvi "experimentar" o tal de Ubuntu. A primeira versão que instalei foi a 5.10 e atualmente utilizo a 6.06, porém desde a primeira versão utilizada tenho um problema com o utilitário PPPOECONF: não sei porque, ele se recusa a conectar durante o boot e tenho que reconfigurá-lo a cada vez que vou acessar a internet. Resolvi esse problema iniciando a conexão "na marra" e sem ajuda do pppoeconf. Vamos a ela:

1º - Configurando o PPPOECONF:
Configure ele normalmente, porém, quando questionado se deseja iniciar a conexão durante o boot, selecione NÃO.

2º - Crie um script de inicialização
Crie um script de inicialização (arquivo simples de texto) com seu editor preferido no diretório /etc/init.d/, no meu caso o chamei de "pppoeload", em seu conteúdo deixe o seguinte:

#!/bin/sh
pon dsl-provider

3º - Torne o arquivo executável:

$ sudo chmod +x /etc/init.d/pppoeload

4º - Atualize seus RCs:

$ sudo update-rc.d pppoeload defaults

Pronto, com isso sua conexão via pppoe deve estar sendo iniciada sem problemas durante o boot, agora é só navegar!

Espero ter ajudado com a dica.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Criando e utilizando um catálogo de e-mails no Claws

Skype nativo no Linux

Instalando o Firefox Developer Edition no Fedora 26

Renomeando nomes de documentos no Google Docs

Resolvendo o vídeo rosa no Youtube

  

Comentários
[1] Comentário enviado por julianlinuxer em 14/05/2007 - 18:51h

Foi o que resolveu meu problema de reconfiguração a cada boot, foi boa!

[2] Comentário enviado por ghosturbo em 09/09/2007 - 22:49h

Cara, já estava aceitando que toda vez que eu entrar no ubuntu teria que configurar a internet, só esse seu tutorial que me salvou, deu certinho cara. Valeu!!!

[3] Comentário enviado por firedragon em 10/09/2007 - 19:50h

Eu prefiro ainda o modo pppoeconf mesmo. É simples. Eu só consigui após apagar no login o "username", e colocar só o email mesmo. Ou também tem abas iniciais.

[4] Comentário enviado por steles em 23/05/2008 - 09:42h

Parabéns pela dica.
Uso o BigLinux e estava com esse problema há meses.
Agora foi resolvido.
steles

[5] Comentário enviado por matiazixavier em 19/11/2008 - 10:30h

Muito Bom Este Tut, Simples E Bem Útil.
Vlwwww



Contribuir com comentário