IceDove e Lightning - Resolvendo problema de incompatibilidade

Publicado por Daniel Roque em 14/02/2013

[ Hits: 4.018 ]

 


IceDove e Lightning - Resolvendo problema de incompatibilidade



As pessoas que utilizam o IceDove (versão 10, até o momento), ao tentar instalar o Lightning vão se deparar com uma mensagem dizendo que o Lightning não é compatível com a versão 10, mesmo o IceDove sendo a última versão e o Lightning também.

Isto ocorre porque o plugin do Lightning se baseia na versão do Thunderbird para fazer controle, e que atualmente está na 17.

Como contornar: O que eu fiz foi baixar o XPI do Lightning e descompactar em uma pasta, alterei o arquivo "install.rdf" na linha:
<em:minVersion>17.0</em:minVersion>


Onde estava 17, eu troquei para uma versão anterior ao do IceDove, para a 9.

Ficando assim:

<em:minVersion>9.0</em:minVersion>

Reempacotei e mandei instalar o arquivo.

Passos a seguir

Baixe o Lightning aqui:
Crie uma pasta de trabalho chamada tmp (por exemplo) e coloque o arquivo lá dentro. Entre na pasta tmp e, supondo que o nome do arquivo seja "lightning-1.9-sm+tb-linux.xpi", descompacte:

cd caminho/da/pasta/tmp
$ unzip -x lightning-1.9-sm+tb-linux.xpi


Agora altere o arquivo "install.rdf", estou usando o MCEdit, mas utilize o editor que quiser:

mcedit install.rdf

Remova o XPI que você baixou de dentro desta pasta, para que possamos em seguida reempacotar:

rm lightning-1.9-sm+tb-linux.xpi
$ zip -r ../lightning-debian.xpi *


Pronto, abra o IceDove. Vá em seus complementos e instale o arquivo que você gerou: lightning-debian.xpi

Boa sorte!

Fonte: icedove: Lightning plugin won't install - linux-gnu_x86-gcc3 error « Debian.org

Outras dicas deste autor

Java no Firefox - Atualizando o plugin no Debian

Colocando o XRDP para funcionar

Conectando Debian em roteador VPN Cisco 3000 com IPsec

CCSM: Bug após atualização do Debian [Resolvido]

Expandindo partição ext3 em discos lógicos e qcow2 em ambiente de virtualização

Leitura recomendada

Calculadora financeira simples para Linux

Resolvendo problemas de dependências das bibliotecas do X

Mplayer no SuSE 10.1

Aprenda a instalar o Adobe Acrobat Reader no Fedora Core 6

Atualizando VMWARE Esxi 4.0 para 4.1

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts