Google Chrome no CentOS 6.x - Instalação via script

Publicado por William em 30/09/2013

[ Hits: 21.724 ]

Blog: http://bwilding.wordpress.com

 


Google Chrome no CentOS 6.x - Instalação via script



O repositório do Google Chrome não dá mais suporte ao CentOS, logo, mesmo que você adicione o repositório do Google Chrome, não terá êxito na instalação do mesmo via yum.

Sua instalação pode brecar num erro do tipo:
Requires: libstdc++.so.6(GLIBCXX_3.4.15)

Felizmente, Richard Lloyd criou um script que instala automaticamente a versão recente do navegador, instalando as bibliotecas necessárias em /opt/google/chrome/lib.

Para usar este script e instalar o Google Chrome no CentOS 6.x, execute os seguintes comandos no terminal:

# wget http://chrome.richardlloyd.org.uk/install_chrome.sh
# chmod u+x install_chrome.sh
# ./install_chrome.sh


Outras dicas deste autor

aMSN no Conectiva Linux 10

Leitura recomendada

SLOG - Software Livre Oeste Goiano

GnuCash e Expense Register: GNU/Linux e Android no controle das finanças

Instalando o aMSN 0.97.2 no Slackware 12 sem compilar nada

Como instalar codecs no Kaffeine - openSUSE

Instalando Picasa 3.0 no Slackware em 3 passos

  

Comentários
[1] Comentário enviado por brbmendes em 27/11/2013 - 02:36h

William,

Funcionou perfeitamente.

Meus parabéns e muito obrigado pela ajuda.

[2] Comentário enviado por kaiquealmeida em 20/01/2014 - 13:03h

Funcionou :)

[3] Comentário enviado por jorgebrgo em 19/02/2014 - 18:04h

Parabens, funcionou perfeitamente e ja veio com flash instalado.
Gostei!

[4] Comentário enviado por cleitoncsl em 01/03/2014 - 09:21h

Muito Obrigado!

[5] Comentário enviado por Matheus007 em 03/06/2014 - 22:44h

Muito Obrigado!

[6] Comentário enviado por dannyalisson em 15/12/2014 - 14:42h

Showwww Deu certo VLW :D

[7] Comentário enviado por renatotec em 13/02/2015 - 15:26h

Galera, essa dica continua valendo, porém tanto o chrome como o chromium instalado do repositório da NCSU ITECS, ambos não acentuam mais nenhuma letra nem na barra de endereços, nem em nenhuma caixa de texto, em nenhum website... Alguém aí com o mesmo problema?

[8] Comentário enviado por bwilding em 13/02/2015 - 15:50h


[7] Comentário enviado por renatotec em 13/02/2015 - 15:26h

Galera, essa dica continua valendo, porém tanto o chrome como o chromium instalado do repositório da NCSU ITECS, ambos não acentuam mais nenhuma letra nem na barra de endereços, nem em nenhuma caixa de texto, em nenhum website... Alguém aí com o mesmo problema?


Uma vez tive este mesmo problema, a solução foi ir em Configurações -> Seletor de método de entrada. E selecionar iBus ao invés de X compose table. Veja se funciona também com você.

[9] Comentário enviado por jorgedasilva em 29/09/2015 - 09:34h

Muito bom o material, obrigada pela ajuda...

[10] Comentário enviado por daianrech em 15/12/2015 - 19:32h

Muito bom o tutorial... e complementando ainda mais, após a instalação, para atualizar ou desinstalar o Chrome seguem os comandos:

ATUALIZAR
# yum update google-chrome-stable
ou execute novamente o script
# ./install_chrome.sh

DESINSTALAR
# yum remove google-chrome-stable chrome-deps-stable
ou execute o script
# ./install_chrome.sh -u





[11] Comentário enviado por vjorge em 11/03/2016 - 13:22h


Por muito tempo me basei nesta dica para instalar o google-chrome no centOS e Linux Cientific e sempre funcionou. Ocorre que recentemente está me retornando esta mensagem quando executo o script.

[enfermagem@localhost Downloads]$ ./install_chrome.sh

ERROR: Unsupported architecture (i686) - aborted

Aparentemente não tenho nenhum problema com a arquitetura.

[enfermagem@localhost Downloads]$ uname -i
i386

[enfermagem@localhost Downloads]$ uname -r
2.6.32-431.el6.i686

[enfermagem@localhost Downloads]$ uname -a
Linux localhost.localdomain 2.6.32-431.el6.i686 #1 SMP Thu Nov 21 13:48:12 CST 2013 i686 i686 i386 GNU/Linux

O que será que pode ser?

[12] Comentário enviado por flaviotecnico em 17/05/2016 - 21:39h

Olá ! Muito obrigado, muito bom tutorial, consegui instalar.
Para o google chrome aparecer entre os navegadores, só precisei reiniciar o PC.
Como instalar o módulo adicional da caixa no centOs ? No site da cef vi um tutorial, mas acho que não serve para centOS.

[13] Comentário enviado por rodribeze em 16/11/2016 - 18:44h

Muito obrigado



Contribuir com comentário