Google Chrome e Earth - Instalação via terminal [para iniciantes]

Publicado por Jairo Regio em 14/06/2013

[ Hits: 21.284 ]

 


Google Chrome e Earth - Instalação via terminal [para iniciantes]



Essa dica é para iniciantes no mundo GNU/Linux.

Utilizo a distribuição Linux Mint, mas a dica também funciona para Ubuntu. Sendo o Mint desenvolvido com base no Ubuntu é evidente que irá funcionar.

Abra o terminal e digite (ou cole):

sudo gedit /etc/apt/sources.list

Inclua a seguinte linha:

deb http://dl.google.com/linux/chrome/deb/ stable main

Salve e saia.

Baixe a chave pública, então digite (ou cole) no terminal:

wget -vc https://dl-ssl.google.com/linux/linux_signing_key.pub

Instale a chave pública. Digite o comando abaixo no terminal:

sudo apt-key add linux_signing_key.pub

Deve aparecer a expressão "OK" mostrando que tudo está correndo tranquilo.

Atualize a lista de repositórios de sua máquina com:

sudo apt-get update

Agora é só instalar os aplicativos via terminal:

sudo apt-get install google-chrome-stable google-earth-stable

Um abraço e seja bem-vindo.

Outras dicas deste autor

Gerador automático de sources.list para Ubuntu

Instalando Java no Linux Mint, Ubuntu e derivados

Leitura recomendada

Logs do Squid de forma legível

Instalando o plugin do Flash no Debian Etch 4 - Iceweasel / Firefox

Instalando o Firefox 3.0.6 com Flash Player 10 no KUbuntu 8.04

Configurando WPAD

Firefox abrindo em modo offline

  

Comentários
[1] Comentário enviado por jairodepaula em 14/06/2013 - 18:13h

Outro detalhe para os iniciantes :

Na dica acima, os comando devem ser colados (ou digitados) no terminal sem o cifrão.

Para quem não sabe, cifrão é isso ----------> $

Te +

[2] Comentário enviado por anderson_felipe_ em 06/11/2013 - 12:27h

"Impossível encontrar o pacote google-chrome-stable".

O que faço?

[3] Comentário enviado por jairodepaula em 06/11/2013 - 18:34h

Qual distribuição vc usa e qual sua máquina ?

Se vc adicionou o repositório do Google com sucesso e utiliza o Ubuntu ou derivados dele (Mint, Lubuntu, Xubuntu e etc...) utilize o seguinte comando:

$ sudo apt-cache search chrome

ou

$ sudo apt-cache search google

Vai aparecer para vc uma lista (Talvez enorme) de aplicativos que tenha essas palavras. O nome do instalador do Google Chrome pode ter mudado de por isso vc não o acha. Mesmo uma mudança ínfima, como por exemplo uma letra maiúscula trocada por uma minuscula, pode fazer toda a diferença.

Caso não consiga aconselho procurar nos fóruns da internet se alguém teve um problema parecido.

Um abraço pra vc.


[2] Comentário enviado por anderson_felipe_ em 06/11/2013 - 12:27h:

"Impossível encontrar o pacote google-chrome-stable".

O que faço?


[4] Comentário enviado por Vinicius_Vargas em 26/12/2013 - 16:49h

Muito obrigado pelas dicas.
Para mim deu erro no pacote do google earth, mas meu interesse era o crhome mesmo então não foi problema.

[5] Comentário enviado por jairodepaula em 26/12/2013 - 18:43h

Fico feliz em ter podido ajudar.

Mas só por curiosidade. Qual o erro que deu ao tentar instalar o Google Earth ??



[4] Comentário enviado por Vinicius_Vargas em 26/12/2013 - 16:49h:

Muito obrigado pelas dicas.
Para mim deu erro no pacote do google earth, mas meu interesse era o crhome mesmo então não foi problema.



[6] Comentário enviado por cherly em 04/06/2014 - 21:22h

fiz como o instruído, mas não foi instalado...olhe os erros:
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
google-chrome-stable: Depende: gconf-service mas não é instalável
Depende: libasound2 (>= 1.0.23)
Depende: libgconf-2-4 (>= 2.31.1) mas não é instalável
Depende: libgcrypt11 (>= 1.4.5) mas 1.4.4-5ubuntu2.2 está para ser instalado
Depende: libgdk-pixbuf2.0-0 (>= 2.22.0) mas não é instalável
Depende: libglib2.0-0 (>= 2.26.0) mas 2.24.1-0ubuntu2 está para ser instalado
Depende: libgtk2.0-0 (>= 2.24.0) mas 2.20.1-0ubuntu2.1 está para ser instalado
Depende: libnspr4 (>= 1.8.0.10) mas não é instalável
Depende: libnss3 (>= 3.14.3) mas não é instalável
Depende: libstdc++6 (>= 4.6) mas 4.4.3-4ubuntu5.1 está para ser instalado
Depende: libx11-6 (>= 2:1.4.99.1) mas 2:1.3.2-1ubuntu3.1 está para ser instalado
E: Pacotes quebrados
o que eu faço? minha distro é a 10.04, acaso é a distro? meu pc tem apenas 512mb de RAM, é um Duron e tem uma placa jurássica de 128mb...tou com receio de atualizar p versão 12 e a máquina não aguentar...obrigada desde já.

[7] Comentário enviado por eriltonm em 06/11/2014 - 22:42h

Olha o que apareceu no meu, sou novato no linux nem sei o que tenho que fzer...


alferes@alferes-desktop:~$ sudo apt-cache search chrome
splix - Driver for Samsung's SPL2 (bw) and SPLc (color) laser printers
xserver-xorg-video-openchrome - X.Org X server -- VIA display driver
libslang2-dev - The S-Lang programming library, development version
libxpm-dev - X11 pixmap library (development headers)
libxpm4 - X11 pixmap library
libxpm4-dbg - X11 pixmap library (debug package)
libjs-excanvas - HTML5 Canvas for Internet Explorer
libv8-2.0.3 - V8 JavaScript Engine
libv8-dbg - Development symbols for the V8 JavaScript Engine
libv8-dev - Development files for the V8 JavaScript Engine
linuxlogo - Color ANSI System Logo
minidjvu - Monochrome DjVu multipage encoder, single page encoder/decoder
murrine-themes - themes for gtk2 murrine engine
xserver-xorg-video-via - X.Org X server -- VIA display driver (dummy transitional package)
picon-domains - Picon (Personal Images) database of for Internet domain logos.
picon-misc - Picon (Personal Images) database of common accounts and misc.
picon-news - Picon (Personal Images) db of Usenet newsgroups and hierarchies
picon-unknown - Picon (Personal Images) database for very high-level domains
picon-usenix - Picon (Personal Images) db of Usenix conference attendees
picon-users - Picon (Personal Images) database of individual Internet accounts
picon-weather - Picon (Personal Images) database for displaying weather forecasts.
chromium-browser - navegador Chromium
google-chrome-beta - The web browser from Google
google-chrome-stable - The web browser from Google
google-chrome-unstable - The web browser from Google
alferes@alferes-desktop:~$ sudo apt-get install google-chrome-stable
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
google-chrome-stable: Depende: gconf-service mas não é instalável
Depende: libasound2 (>= 1.0.23)
Depende: libgconf-2-4 (>= 2.31.1) mas não é instalável
Depende: libgdk-pixbuf2.0-0 (>= 2.22.0) mas não é instalável
Depende: libglib2.0-0 (>= 2.28.0) mas 2.24.1-0ubuntu1 está para ser instalado
Depende: libgtk2.0-0 (>= 2.24.0) mas 2.20.1-0ubuntu2 está para ser instalado
Depende: libnspr4 (>= 1.8.0.10) mas não é instalável
Depende: libnss3 (>= 3.14.3) mas não é instalável
Depende: libstdc++6 (>= 4.6) mas 4.4.3-4ubuntu5.1 está para ser instalado
Depende: libx11-6 (>= 2:1.4.99.1) mas 2:1.3.2-1ubuntu3 está para ser instalado
Depende: libxfixes3 (>= 1:5.0) mas 1:4.0.4-1 está para ser instalado
Depende: libappindicator1 mas não é instalável
E: Pacotes quebrados
alferes@alferes-desktop:~$

[8] Comentário enviado por jairodepaula em 07/11/2014 - 06:05h

o comando "sudo apt-cache search [nome do aplicativo]" que vc utilizou serve para procurar nos repositórios (bancos de aplicativos e arquivos online) o programas, ou arquivos, com o nome que vc especificou. .

Quando vc colocou " chrome " vai ver que aparece vários programas, entre eles, google-chrome-beta, google-chrome-stable e google-chrome-unstable.

A partir disso é só escolher qual deles deseja instalar. Exemplo : sudo apt-get install google-chrome-stable

Depois disso é só dizer "sim" e deixar o apt-get fazer o trabalho dele.

Mas como vc fez isso é apareceu mensagens mostrando problemas de dependência. Uma forma de tentar resolver isso é utilizando o comando sudo apt-get install -f e depois tentar instalar novamente o programa.

Se não der certo vc vai ter que procurar cada uma dassas dependências e instalá-las uma por uma. Dá um trabalhão. Mas isso é curioso...qual sua distribuição ? Esse quantidade de dependências quebradas não é normal.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts