Fazendo o Processo Judicial Eletrônico (PJe) funcionar no Linux

Publicado por Marcos Alves Pintar em 02/05/2016

[ Hits: 17.266 ]

 


Fazendo o Processo Judicial Eletrônico (PJe) funcionar no Linux



Conforme é do conhecimento de todos, o Poder Judiciário Brasileiro vem passando por um rápido processo de informatização, que levará em breve ao desaparecimento do papel.

O Conselho Nacional de Justiça (CNJ), Órgão de cúpula do Judiciário, criou o chamado PJe, que é na verdade uma infraestrutura completa de processo eletrônico a ser implantada pelos Tribunais e em uso pelo próprio CNJ. O PJe gerou uma série de críticas e discussões, consumindo vultosos recursos orçamentários e longo tempo para seu desenvolvimento, sem que contudo o sistema possa ser considerado como bom.

De qualquer forma, os Tribunais estão implantando progressivamente o famigerado PJe, trazendo uma série de problemas. Para se ter ideia, o Tribunal Regional Federal da 3.ª Região começou a receber o recurso chamado agravo de instrumento pelo PJe no dia 04.04.2016, mas para se utilizar o sistema é necessário se utilizar uma versão totalmente defasada do Firefox (versão 41 ou anterior), sob pena do sistema não funcionar (ao menos no Windows).

Em nosso escritório nunca conseguimos fazer o PJe funcionar adequadamente no Linux (usamos Arch) devido ao fato de que o certificado digital nunca era reconhecido. O problema se repete em alguns outros sistemas de processo eletrônico, como o do Superior Tribunal de Justiça.

Depois de muito quebrar a cabeça acabei por encontrar uma solução bem simples, que por sinal está na própria wiki do PJe, porém de forma um tanto "camuflada". Tentem procurar a informação e verão o que estou dizendo.

Primeiro devemos criar a pasta ".pje" no diretório do usuário":

mkdir ~/.pje

Feito isso, com o editor de sua preferência crie o arquivo ~/.pje/pkcs11.conf:

nano ~/.pje/pkcs11.conf

Feito isso, basta inserir duas linhas no arquivo:

library=<caminho_do_driver>/<nome_do_driver_pkcs11>
name=PersonalProvider

No meu caso ficou assim:

library=/usr/lib/libaetpkss.so.3.0.2635
name=PersonalProvider

A partir desses passos, o PJe reconhece o certificado digital e loga e assina os documentos normalmente.

Estou usando o icedtea-web como plugin do Java para o navegador, combinado como o Openjdk. Não sei dizer se a solução funciona com o JRE.

O interessante é que todas as versões do PJe que eu testei, em diferentes Tribunais, funciona normalmente mesmo com a versão atual do Firefox (45), enquanto no Windows simplesmente não funciona, sendo necessária a utilização de uma versão antiga do navegador.

Espero que a dica tenha ajudado.

Até a próxima.

Outras dicas deste autor

Criando arquivos pdfs com tamanho reduzido e boa qualidade a partir de imagens

GPU Accelerated Flash Player - Acelerando o Flash no Firefox via GPU

Leitura recomendada

Instalando plugin Java no AMD Fedora Core

Instalando plugin Java no Chrome - Acesse a sua conta bancária

GlassFish vs Apache

Guardião Itau 30 horas no Google Chrome

Instalando Java e Limewire no Debian

  

Comentários
[1] Comentário enviado por bendjouya em 02/05/2016 - 20:35h

Estava procurando isso faz tempo, porém ainda não tive êxito e talvez faltou algumas informações:

1. Que tipo de certificado funciona? A1 ou A3?
2. Precisa de mais alguma dependência? como o safesign identity client? (não funciona no ubuntu 16.04)

Parabéns por compartilhar.

[2] Comentário enviado por mapintar em 03/05/2016 - 00:07h


[1] Comentário enviado por bendjouya em 02/05/2016 - 20:35h

Estava procurando isso faz tempo, porém ainda não tive êxito e talvez faltou algumas informações:

1. Que tipo de certificado funciona? A1 ou A3?
2. Precisa de mais alguma dependência? como o safesign identity client? (não funciona no ubuntu 16.04)

Parabéns por compartilhar.



Usamos o A3 fornecido pela OAB em parceria com a Certisign (token GD Starsign). Não sei dizer se funciona com o A1.

Quanto à dependência, o arquivo /usr/lib/libaetpkss.so.3.0.2635 faz parte do pacote safesign identity client, que possibilita acessar o certificado. No meu caso estou usando a versão 3.0.93 convertido de um pacote deb, e funciona perfeitamente no Arch.

Basicamente, a biblioteca libaetpkss.so é o que possibilita o sistema operacional acessar o token, que pelo que sei vem criptografado. É um software fechado, de propriedade da Certisign, creio. O problema é que o PJe não conseguia acessar essa biblioteca, por não saber onde está, e com o arquivo de configuração sugerido pelo artigo passa a funcionar.

Se o software do token for outro, certamente será outra biblioteca. Não sei dizer sobre isso, pois desde que comecei a usar é sempre o safesign identity client.

Quanto ao funcionamento no ubuntu, creio que a melhor forma de tentar resolver o problema é usar a versão mais atualizada do safesign identity client, que curiosamente não é fornecido nem pela Certisign, nem pela OAB. A partir daí, tente rodar o programa tokenadmin pelo terminal e veja as mensagens de erro. A falha provavelmente deve estar associada ao fato de que o programa não consegue encontrar alguma dependência. A partir daí, tente criar links simbólicos visando suprir a dependência não encontrada.

Espero ter ajudado.



[3] Comentário enviado por djteix em 29/05/2016 - 01:14h

Cara preciso preparar meu manjaro 16.06 KDE para assinar em processo digital da justiça, desde o drive da leitora, passando pelo reconhecimento do certificado OAB até a assinatura digital. Vc poderia fazer um tutorial como faço para configurar tudo? Já pesquisei muito e não acho nada ensinando. Atualmente quando conecto a leitora com o cartão com o chip da OAB não reconhece nada. Não gostaria de inslatar o ruindons para apenas assinar documentos.
Valeu.

[4] Comentário enviado por mapintar em 30/05/2016 - 12:11h


[3] Comentário enviado por djteix em 29/05/2016 - 01:14h

Cara preciso preparar meu manjaro 16.06 KDE para assinar em processo digital da justiça, desde o drive da leitora, passando pelo reconhecimento do certificado OAB até a assinatura digital. Vc poderia fazer um tutorial como faço para configurar tudo? Já pesquisei muito e não acho nada ensinando. Atualmente quando conecto a leitora com o cartão com o chip da OAB não reconhece nada. Não gostaria de inslatar o ruindons para apenas assinar documentos.
Valeu.


Infelizmente não estou familiarizado com o Manjaro, mas pelo que sei usa o sistema de empacotamento do Arch. Assim, vou me basear aqui nos procedimentos de rotina usados no próprio Arch, que devem ser idênticos para o Manjaro.

Para fazer o certificado digital funcionar você precisa primeiro instalar o pacote pcsclite, que está no repositório oficial, e iniciar o serviço:

pacman -S pcsclite
systemctl start pcscd.service

A partir daí vem a parte difícil. Para acessar o certificado digital é preciso usar o safesign client, que infelizmente não está empacotado para o Arch (e possivelmente para o Manjaro). Para piorar, a Certisign e a OAB não disponibilizam o programa para Linux.

A solução é fazer na mão. Primeiro obtenha o programa em site de terceiros. Sei que esses funcionam:

http://www.validcertificadora.com.br/upload/downloads/linux32bits/safesignidentityclient_3.0.77-Ubun...

http://www.validcertificadora.com.br/upload/downloads/linux64bits/safesignidentityclient_3.0.77-Ubun...

Depois use essa pkgbuild para criar o pacote:

# Maintainer: Seu_Nome <Seu_Email>

pkgname=safesign-client
pkgver=3.0.77
pkgrel=1
pkgdesc="A droga do safesign para Linux"
arch=('any')
license=('GPL')
source=("safesignidentityclient_3.0.77-Ubuntu_amd64.deb")
md5sums=('0d9fe081d21ff26455e8a778888babf7')

package() {
cd $srcdir
tar -vzxf data.tar.gz
#mkdir -p $pkgdir/usr/bin/
cp -r usr $pkgdir/usr
#install -m755 $pkgname $pkgdir/usr/bin/
}

Se der tudo certo irá criar o pacote sem problemas, na versão de 64. Para 32 é preciso modificar.

Instale o pacote, e rode o comando tokenadmin via terminar e veja se funciona. Caso o certificado não seja reconhecido reinicie o serviço pcscd e tente novamente. Se surgir erros na iniciação do programa tokenadmin a causa provável será a não localização de bibliotecas, e a solução será criar links simbólicos visando "enganar" o programa.

Teste e poste os resultados.

[5] Comentário enviado por marcio1980 em 07/06/2016 - 12:42h

Em meu escritório utilizamos o Ubuntu 16.04 e consegui configurar perfeitamente o acesso ao PJ-e TRT4.

No site do ITI Brasil tem o manual de instalação: http://www.iti.gov.br/noticias/indice-de-noticias/4599-iti-disponibiliza-tutorial-de-instalacao-do-c...

Após seguir os passos do manual já será possível acessar o Token pelo Terminal digitando # pcsc_scan, ele estará totalmente funcional.

Entretanto, possivelmente ocorra um erro ao tentar instalar a interface Safesing Client/Tokenadmin, sendo necessário instalar mais alguns pacotes de drives, que podem ser acessados aqui: http://www.validcertificadora.com.br/SafeSignLinux. Baixe os pacotes e instale pelo terminal com o comando # dpkg -i nome_do_pacote.deb.

No meu caso, a Biblioteca/Library apontada para encontrar o token foi a seguinte: /usr/lib/libaetpkss.so.3.0.2528.

Espero que ajude.

Márcio Laini.

[6] Comentário enviado por bendjouya em 07/06/2016 - 13:51h


[5] Comentário enviado por marcio1980 em 07/06/2016 - 12:42h

Em meu escritório utilizamos o Ubuntu 16.04 e consegui configurar perfeitamente o acesso ao PJ-e TRT4.

No site do ITI Brasil tem o manual de instalação: http://www.iti.gov.br/noticias/indice-de-noticias/4599-iti-disponibiliza-tutorial-de-instalacao-do-c....

Após seguir os passos do manual já será possível acessar o Token pelo Terminal digitando # pcsc_scan, ele estará totalmente funcional.

Entretanto, possivelmente ocorra um erro ao tentar instalar a interface Safesing Client/Tokenadmin, sendo necessário instalar mais alguns pacotes de drives, que podem ser acessados aqui: http://www.validcertificadora.com.br/SafeSignLinux. Baixe os pacotes e instale pelo terminal com o comando # dpkg -i nome_do_pacote.deb.

No meu caso, a Biblioteca/Library apontada para encontrar o token foi a seguinte: /usr/lib/libaetpkss.so.3.0.2528.

Espero que ajude.

Márcio Laini.


Boa tarde Márcio,

muito obrigado pelo tutorial, infelizmente essa parte já está totalmente funcional. No caso o problema é depois disso, no PJ-e depois que pede o PIN ele informa que o token não está inserido.

Aproveitando, no TJRS ele abre o applet e não encontra o certificado.

E essa dica é para A3, não consigo fazer funcionar com A1 também.

Abraço e novamente obrigado

[7] Comentário enviado por Paulo.r.30 em 07/06/2016 - 20:21h


[6] Comentário enviado por bendjouya em 07/06/2016 - 13:51h


[5] Comentário enviado por marcio1980 em 07/06/2016 - 12:42h

Em meu escritório utilizamos o Ubuntu 16.04 e consegui configurar perfeitamente o acesso ao PJ-e TRT4.

No site do ITI Brasil tem o manual de instalação: http://www.iti.gov.br/noticias/indice-de-noticias/4599-iti-disponibiliza-tutorial-de-instalacao-do-c....

Após seguir os passos do manual já será possível acessar o Token pelo Terminal digitando # pcsc_scan, ele estará totalmente funcional.

Entretanto, possivelmente ocorra um erro ao tentar instalar a interface Safesing Client/Tokenadmin, sendo necessário instalar mais alguns pacotes de drives, que podem ser acessados aqui: http://www.validcertificadora.com.br/SafeSignLinux. Baixe os pacotes e instale pelo terminal com o comando # dpkg -i nome_do_pacote.deb.

No meu caso, a Biblioteca/Library apontada para encontrar o token foi a seguinte: /usr/lib/libaetpkss.so.3.0.2528.

Espero que ajude.

Márcio Laini.


Boa tarde Márcio,

muito obrigado pelo tutorial, infelizmente essa parte já está totalmente funcional. No caso o problema é depois disso, no PJ-e depois que pede o PIN ele informa que o token não está inserido.

Aproveitando, no TJRS ele abre o applet e não encontra o certificado.

E essa dica é para A3, não consigo fazer funcionar com A1 também.

Abraço e novamente obrigado



Olá, esse erro, "token não está inserido", ocorre quando é instalado o Token Giesecke & Devrient Starsign (driver /usr/lib/libaetpkss.so.3.0.2528) e, depois, instalado o eToken Pro Aladdin (driver /usr/lib64/libeToken.so). Ao indicar o caminho do último, não consegui mais voltar ao primeiro.
Para dar certo, é preciso seguir esses passos:
Para todos os modelos de eToken, baixe o arquivo em http://vqv.com.br/cnj/libhal1_0.5.14-8_amd64.deb e instale-o

$ cd ~/Downloads
$ sudo dpkg -i libhal1_0.5.14-8_amd64.deb

Há vários modelos de eToken. Neste roteiro são tratados o eToken Pro Aladdin e o eToken GD Starsign. Para verificar o modelo de seu eToken, conecte-o a uma USB e use o comando:

$ lsusb

Para eToken Pro Aladdin:

Baixe http://vqv.com.br/cnj/cliente-safenet.tar.gz

Descompacte, ajuste as permissões e execute o script de instalação

$ cd ~/Downloads
$ tar -zvxf cliente-safenet.tar.gz
$ chmod 700 install_SafenetAuthenticationClient-8.1.0-4_amd64.deb.sh
$ sudo ./install_SafenetAuthenticationClient-8.1.0-4_amd64.deb.sh
$ sudo apt-get -f install

Crie os links simbólicos para as bibliotecas necessárias

$ cd /usr/lib
$ sudo ln -sv /usr/lib64/libeToken.so /usr/lib/libeToken.so.8
$ sudo ln -sv /usr/lib64/libeTokenUI.so /usr/lib/libeTokenUI.so.8

Acesse uma instalação do PJe.

Na primeira tentativa, você será solicitado a selecionar o driver. Escolha:

/usr/lib64/libeToken.so

Para eToken Giesecke & Devrient Starsign:

Baixe http://vqv.com.br/cnj/safesignidentityclient_3.0.77-Ubuntu_amd64.deb

Instale o cliente

$ cd ~/Downloads
$ sudo dkpg -i /safesignidentityclient_3.0.77-Ubuntu_amd64.deb
$ sudo apt-get -f install

Na primeira vez que acessar o PJe, selecionar o driver

/usr/lib/libaetpkss.so.3.0.2528
Nessa última instalação talvez seja necessário instalar algumas pendencias. Estes arquivos podem ser baixados da http://www.validcertificadora.com.br/SafeSignLinux.

Essa informações estão do site http://www.pje.jus.br/wiki/index.php/Desenvolvedor#Ubuntu_64_bits.

Mas tem uma coisa que não sei fazer (renomear o driver - as tentativas que fiz não deram certo, depois de escolher /usr/lib64/libeToken.so, não consegui voltar para o outro:
No site diz que para alternar entre diferentes tipos de eTokens, deve-se renomear o driver, inserir o próximo eToken e carregar o PJe e ao acessar o PJe, você será solicitado a escolher um novo driver. devendo selecionar conforme o tipo de eToken, de acordo com o explicado anteriormente.

Finalmente, até agora não obtive sucesso no TJ-RS.

[8] Comentário enviado por mfmtorres em 17/06/2016 - 19:19h

Olá,
Amigo, estou tendo problemas com o Mac. Será que você poderia me ajudar? O que está pegando para mim é identificar esse caminho. Como faço para saber como montar esse arquivo?

library=<caminho_do_driver>/<nome_do_driver_pkcs11>

name=PersonalProvider

Agradeço se puder me ajudar!

[9] Comentário enviado por pedrofuly em 06/08/2016 - 22:07h

Olá, amigo,

Uso o archlinux e consegui executar o safesign com o pacote safesignidentityclient disponível no AUR.

Entretanto, só consegui que meu token G&D StarSign fosse identificado depois de instalar o pacote ccid. Não sei se faz sentido considerar como uma dependência, mas sem ele não funcionou aqui.

A propósito, uso o JRE mesmo.

Para o PJe, fundamental mesmo foi a pasta .pje, com o arquivo que você descreveu.

Muito obrigado!

[10] Comentário enviado por geanckn em 17/01/2017 - 15:49h

Olá colegas!

Como forma de tentar contornar o problema do acesso ao sistema de peticionamento eletrônico do TJRS, pode-se acessar o sistema informando o CPF e senha. Todavia, o sistema fica limitado à visualização dos processos e peticionamento de documentos previamente assinados digitalmente, uma vez que a ferramenta do sistema também retorna o mesmo tipo de erro de "Certificado não encontrado" quando é realizado o procedimento de assinatura digital.

Espero que os desenvolvedores desses sistemas resolvam logo essa questão da interoperabilidade dos sistemas de processo eletrônico, já que do jeito que está, acabamos ficando reféns do MS Windows.

Uma das soluções que, em princípio, está para ser disponibilizada "em breve" é o "Escritório Digital" do CNJ, que, em tese, possibilitará o acesso e peticionamento de qualquer sistema operacional, em todos os Tribunais do País.

Abraço a todos!

[11] Comentário enviado por aldones em 04/11/2017 - 23:26h

Está complicada a situação.
Estou com o token funcionando no CentOS 7. Funciona no eproc2 do TRF4. Funciona no e-cac da Receita Federal (que eles recomendam para testes).

Só no PJe que não funciona (TJMG e TRT3).

Na verificação de ambiente, pede o PIN e funciona "Leitura e assinatura da certificação digial Ok.".

Mas se cloco em Acessar com certificado digital, sempre retorna "Não foi possível realizar a autenticação. Verifique se o cartão ou token estão conectados".

Versões do Firefox testadas: 38.8.0esr, 41.0.2 (que é mesma que o CNJ usa para o NavegadorPJe) e a 52.4.0 (só pra desencargo de consciência).

Versões do Java testadas: 7u80, 8u77, 8u131, 8u144 (utilizada pelo CNJ no NavegadorPJe) e 8u151

Em Preferências->Avançado->Ver Certificados, aparece o certificado direitinho.
Em Dispositivos de Segurança, aparece o "SafeSign PKCS #11 Library" e o "Token VALID".

Estou aberto a sugestões. Simplesmente não faz sentido não funciona nesse ponto.

[12] Comentário enviado por mamp em 04/12/2018 - 11:44h

tem comunidade para debater pje
https://www.vivaolinux.com.br/comunidade/PJe

e eu uso pje no linux e escrevi isto, se ajudar
https://www.vivaolinux.com.br/artigo/Sou-advogado-e-consegui-instalar-Certificado-Digital-para-PJe/

ou no meu blog
http://www.pje.blog.br/2016/10/pje-e-direito-digital-configurando.html


pretendo nas ferias forenses atualizar meu artigo com scritps

[13] Comentário enviado por Mello_Arismar em 22/04/2019 - 00:10h

Que legal.
Que bom que vocês conseguiram.
Estou no Deepin, que utiliza do Debian Stable, atualmente, mas não consegui de forma alguma.
E sou iniciante em linux, não sei fazer estas formatações via terminal.
Para mim, seria quase impossível conseguir mesmo. No Windows, basta baixar o navegador fornecido pelo CNJ e instalar o aplicativo da Certising, o próprio aplicativo faz todo o resto sozinho, tão mais prático e fácil...
Como não utilizo dual boot, criei uma máquina virtual com o virtual box, acabou sendo mais simples e fácil.
Outra questão é que no meu estado os Juizados Especiais utilizam o ProJudi, que necessita de assinatura digital antes do protocolo e o assinador só funciona no windows.
Talvez se os profissionais de TI das seccionais da OAB se dispusessem a ajudar os advogados com linux...
O advogado chega lá com o windows e eles instalam, com MacBook, eles passam a tarde toda, mas instalam, como já ocorreu com diversos colegas.
Mas se você chega lá com um linux eles mandam você jogar fora o OS, pois não serve para o PJE, nem ao menos tentam te ajudar...
Para eles, simplesmente não funciona e ponto.
Mas deixa, prefiro ficar com o Deepin assim mesmo do que ficar preso ao Windows.
Fico feliz por vocês.

[14] Comentário enviado por mamp em 11/06/2019 - 18:57h

Mello_Arismar eu gosto do Debian e Fedora que Debian gratuito. Sei se vc paga suporte eles te auxiliam, mas eu tentei muito no Fedora e no Debian e nao funcionava..
So tive pleno acesso e pleno funcionamento do Pje e outros tribunais com Ubuntu.
Inclusive estou usando Ubuntu 19.10

[15] Comentário enviado por inesambrosioadv em 23/06/2019 - 20:07h

Finalmente, 22/06/2019, consegui logar no PJe (TRF3, 2ª instância) e E-saj utilizando o certificado digital OAB SP A3, navegadores Chrome e Firefox

Primeiro, quero agradecer todas as informações. Valeu muito!!

E agora deixar aqui o caminho que segui para conseguir utilizar o processo eletrônico (site PJe e site E-saj) com o certificado digital (advogados)

O que eu tenho comigo?
Ubuntu 18.04.2 LTS;
Sistema de 64 bits;
Chrome Versão 75.0.3770.100 (Versão oficial) 64 bits
Firefox Quantum 67.0.3 (64-bits)
Token GD - Giesecke & Devrient Starsign* Crypto USB

Depois de ter problemas e formatar o computador, pesquisei várias fontes (que vou indicando abaixo) e segui alguns dos procedimentos:

PREPARAÇÃO: a) dentro da pasta Downloads, criei uma subpasta para salvar os pacotes baixados; b) no terminal, entrei como usuário root (sudo su); verifiquei atualizações (apt-get update) e upgrades (apt-get upgrade)

***1ª Fonte-Guicolândia: http://www.guicolandia.net/peticionamento-eletronico-no-ubuntu-18-04.html

1.1. Criei grupo "scard"

sudo addgroup scard

1.2. Adicionei meu usuário ao grupo

sudo adduser "seu-usuário" scard

1.3. Instalei pacotes indicados por essa Fonte-Guicolândia

sudo apt install libengine-pkcs11-openssl libp11-3 libpcsc-perl libccid libpcsclite1 pcscd pcsc-tools libasedrive-usb opensc libssl1.0.0 openssl libopensc-openssl

1.4. Instalei nessa ordem as dependências específicas (as oferecidas pela Fonte-Guicolândia mesmo), via download, descompactação, etc.

libgdbm3
libwxbase2.8-0
libwxgtk2.8-0
Dependências da libwxgtk2.8-0:
libpng12-0
libjpeg62-turbo

1.5. Testei o token

pcsc_scan

1.6. Instalei o gerenciador criptográfico SafeSign fornecido pela Valid Certificadora, conforme indicação dessa 1ª Fonte-Guicolândia (safesignidentityclient_3.0.77-Ubuntu_amd64.deb)

a) mas o fiz via terminal: caminhei até a minha subspasta que criei em Downloads

b) para download: comando wget

para não dar erro, revirei o site da Valid até encontrar (https://www.validcertificadora.com.br/SafeSignLinux) os links do download, com o botão direito do mouse, copiei o endereço do link do pacote deb e montei o comando no terminal

sudo wget https://s3-sa-east-1.amazonaws.com/shared-www.validcertificadora.com.br/safesignidentityclient_3.0.7...

c) para instalação: comando dpkg -i

sudo dpkg -i safesignidentityclient_3.0.77-Ubuntu_amd64.deb

1.7. Linkei o token com o Firefox

a) abri o administrador de token, que reconheceu meu certificado digital
b) cliquei em integração
c) segui os passos do programa

***2ª Fonte: https://esaj.tjsp.jus.br/petpg/abrirVerificacaoRequisitosPet.do

2.1. na verificação de requisitos do e-saj, logo recomendou a instalação do plug-in "Web Signer", que foi feita clicando lá mesmo e direcionando para o endereço da softplan

(https://websigner.softplan.com.br/Setup?brand=&jslib=&browser=Chrome&returnUrl=)

no e-saj, então, problema resolvido

****3ª Fonte: http://www.pje.jus.br/wiki/index.php/PJeOffice#PJeOffice_no_Linux

3.1. Baixei via terminal o programa PJeOficial (tenho rodando o Ubuntu, mas arrisquei instalar o pacote deb para Debian 64 bits)

sudo wget http://ftp.pje.jus.br/pje/programs/pje-office/pje-office_amd64.deb

3.2. Instalei o pacote pelo terminal

sudo dpkg -i pje-office_amd64.deb

3.3. cf. orientação na mesma página mais em baixo, no subtítulo "PJeOffice no Linux", pelo terminal, executei o comando

./pjeOffice.sh &


OBS: a) feito isso, notei que acessando o site do PJe e tentando logar com certificado digital, o programa PJeOffice não inicializava, ou seja, não fazia a ponte entre o site PJe e o meu certificado digital

b) foi aí que percebi que executando esse arquivo "pjeOffice.sh" no terminal através daquele comando (./pjeOffice.sh &), e acessando o site PJe logo em seguida, era possível fazer essa ponte

c) daí que surgiu outro problema: meu certificado digital não estava sendo reconhecido pelo PJeOffice

***4ª Fonte: http://www.pje.jus.br/wiki/index.php/Configura%C3%A7%C3%A3o_do_Ambiente#Observa.C3.A7.C3.B5es_para_L...

4.1. cf. orientação dessa página, mais embaixo, no subtítulo "Observações para Linux e Mac OS X", é necessário criar na pasta home/"usuário" uma subpasta ".pje", e dentro dela criar um arquivo de texto com nome "pkcs11.conf"

esse arquivo de texto deve conter:

library=<caminho_do_driver>/<nome_do_driver_pkcs11>

name=PersonalProvider


****5ª Fonte-Viva o Linux: https://www.vivaolinux.com.br/dica/Fazendo-o-Processo-Judicial-Eletronico-PJe-funcionar-no-Linux/

5.1. pesquisando no google que driver seria esse "pkcs11", encontrei essa 5ª Fonte-Viva o Linux, exemplificando como fazer e preencher esser arquivo de texto, que então criei com o driver "libaetpkss.so.3.0.2528"

5.2. o PJeOffice ainda não conseguia reconhecer meu certificado digital, então lendo um pouco mais, segui o link indicado no comentário nº 7 da mesma página

****6ª Fonte: http://www.pje.jus.br/wiki/index.php/Desenvolvedor#Ubuntu_64_bits

segui totalmente esses procedimentos:

6.1. "Roteiro para Instalação do Java (Sistema Linux 64 bits)" (NÃO SEI SE IRIA AJUDAR EM ALGUMA COISA, MAS FIZ)

6.2. "Roteiro para Instalação e Configuração do Cliente para Certificados Digitais"

6.2.1. "Ubuntu 64 bits"

****Por fim, inconformada por ter que abrir o terminal e executar aquele comando ./pjeOffice.sh & (3.3.) sempre que fosse usar o PJe, comecei a pesquisar sobre system tray e desisti.

Mas reinstalando os programas que eu costumava utilizar, vi por acaso no "Software Ubuntu" que o computador já tinha um programa: "aplicativos iniciais de sessão"

Abrindo esse programa, o PJeOffice estava lá, mas não inicializava sozinho

Nas configurações, ele apontava para um caminho e arquivo que deu erro quando testei no nautilus

Então, arrisquei substituir pelo caminho e arquivo "pjeOffice.sh" do item 3.3.

Foi então que ele começou a funcionar sozinho, sem eu ter que executar no terminal

Agora basta para mim entrar no site do PJe, clicar para logar com certificado digital, que o resto acontece, tanto no Firefox quanto no Chrome

Apenas no Firefox ele me pede para escolher o certificado antes de digitar o PIN.

Boa sorte para todos!

Inês Ambrósio

[16] Comentário enviado por 1988spindola em 28/06/2019 - 11:59h


[15] Comentário enviado por inesambrosioadv em 23/06/2019 - 20:07h

Finalmente, 22/06/2019, consegui logar no PJe (TRF3, 2ª instância) e E-saj utilizando o certificado digital OAB SP A3, navegadores Chrome e Firefox

Primeiro, quero agradecer todas as informações. Valeu muito!!

E agora deixar aqui o caminho que segui para conseguir utilizar o processo eletrônico (site PJe e site E-saj) com o certificado digital (advogados)

O que eu tenho comigo?
Ubuntu 18.04.2 LTS;
Sistema de 64 bits;
Chrome Versão 75.0.3770.100 (Versão oficial) 64 bits
Firefox Quantum 67.0.3 (64-bits)
Token GD - Giesecke &amp; Devrient Starsign* Crypto USB

Depois de ter problemas e formatar o computador, pesquisei várias fontes (que vou indicando abaixo) e segui alguns dos procedimentos:

PREPARAÇÃO: a) dentro da pasta Downloads, criei uma subpasta para salvar os pacotes baixados; b) no terminal, entrei como usuário root (sudo su); verifiquei atualizações (apt-get update) e upgrades (apt-get upgrade)

***1ª Fonte-Guicolândia: http://www.guicolandia.net/peticionamento-eletronico-no-ubuntu-18-04.html

1.1. Criei grupo "scard"

sudo addgroup scard

1.2. Adicionei meu usuário ao grupo

sudo adduser "seu-usuário" scard

1.3. Instalei pacotes indicados por essa Fonte-Guicolândia

sudo apt install libengine-pkcs11-openssl libp11-3 libpcsc-perl libccid libpcsclite1 pcscd pcsc-tools libasedrive-usb opensc libssl1.0.0 openssl libopensc-openssl

1.4. Instalei nessa ordem as dependências específicas (as oferecidas pela Fonte-Guicolândia mesmo), via download, descompactação, etc.

libgdbm3
libwxbase2.8-0
libwxgtk2.8-0
Dependências da libwxgtk2.8-0:
libpng12-0
libjpeg62-turbo

1.5. Testei o token

pcsc_scan

1.6. Instalei o gerenciador criptográfico SafeSign fornecido pela Valid Certificadora, conforme indicação dessa 1ª Fonte-Guicolândia (safesignidentityclient_3.0.77-Ubuntu_amd64.deb)

a) mas o fiz via terminal: caminhei até a minha subspasta que criei em Downloads

b) para download: comando wget

para não dar erro, revirei o site da Valid até encontrar (https://www.validcertificadora.com.br/SafeSignLinux) os links do download, com o botão direito do mouse, copiei o endereço do link do pacote deb e montei o comando no terminal

sudo wget https://s3-sa-east-1.amazonaws.com/shared-www.validcertificadora.com.br/safesignidentityclient_3.0.7....

c) para instalação: comando dpkg -i

sudo dpkg -i safesignidentityclient_3.0.77-Ubuntu_amd64.deb

1.7. Linkei o token com o Firefox

a) abri o administrador de token, que reconheceu meu certificado digital
b) cliquei em integração
c) segui os passos do programa

***2ª Fonte: https://esaj.tjsp.jus.br/petpg/abrirVerificacaoRequisitosPet.do

2.1. na verificação de requisitos do e-saj, logo recomendou a instalação do plug-in "Web Signer", que foi feita clicando lá mesmo e direcionando para o endereço da softplan

(https://websigner.softplan.com.br/Setup?brand=&amp;jslib=&amp;browser=Chrome&amp;returnUrl=)

no e-saj, então, problema resolvido

****3ª Fonte: http://www.pje.jus.br/wiki/index.php/PJeOffice#PJeOffice_no_Linux

3.1. Baixei via terminal o programa PJeOficial (tenho rodando o Ubuntu, mas arrisquei instalar o pacote deb para Debian 64 bits)

sudo wget http://ftp.pje.jus.br/pje/programs/pje-office/pje-office_amd64.deb

3.2. Instalei o pacote pelo terminal

sudo dpkg -i pje-office_amd64.deb

3.3. cf. orientação na mesma página mais em baixo, no subtítulo "PJeOffice no Linux", pelo terminal, executei o comando

./pjeOffice.sh &amp;


OBS: a) feito isso, notei que acessando o site do PJe e tentando logar com certificado digital, o programa PJeOffice não inicializava, ou seja, não fazia a ponte entre o site PJe e o meu certificado digital

b) foi aí que percebi que executando esse arquivo "pjeOffice.sh" no terminal através daquele comando (./pjeOffice.sh &amp;), e acessando o site PJe logo em seguida, era possível fazer essa ponte

c) daí que surgiu outro problema: meu certificado digital não estava sendo reconhecido pelo PJeOffice

***4ª Fonte: http://www.pje.jus.br/wiki/index.php/Configura%C3%A7%C3%A3o_do_Ambiente#Observa.C3.A7.C3.B5es_para_L....

4.1. cf. orientação dessa página, mais embaixo, no subtítulo "Observações para Linux e Mac OS X", é necessário criar na pasta home/"usuário" uma subpasta ".pje", e dentro dela criar um arquivo de texto com nome "pkcs11.conf"

esse arquivo de texto deve conter:

library=&lt;caminho_do_driver&gt;/&lt;nome_do_driver_pkcs11&gt;

name=PersonalProvider


****5ª Fonte-Viva o Linux: https://www.vivaolinux.com.br/dica/Fazendo-o-Processo-Judicial-Eletronico-PJe-funcionar-no-Linux/

5.1. pesquisando no google que driver seria esse "pkcs11", encontrei essa 5ª Fonte-Viva o Linux, exemplificando como fazer e preencher esser arquivo de texto, que então criei com o driver "libaetpkss.so.3.0.2528"

5.2. o PJeOffice ainda não conseguia reconhecer meu certificado digital, então lendo um pouco mais, segui o link indicado no comentário nº 7 da mesma página

****6ª Fonte: http://www.pje.jus.br/wiki/index.php/Desenvolvedor#Ubuntu_64_bits

segui totalmente esses procedimentos:

6.1. "Roteiro para Instalação do Java (Sistema Linux 64 bits)" (NÃO SEI SE IRIA AJUDAR EM ALGUMA COISA, MAS FIZ)

6.2. "Roteiro para Instalação e Configuração do Cliente para Certificados Digitais"

6.2.1. "Ubuntu 64 bits"

****Por fim, inconformada por ter que abrir o terminal e executar aquele comando ./pjeOffice.sh &amp; (3.3.) sempre que fosse usar o PJe, comecei a pesquisar sobre system tray e desisti.

Mas reinstalando os programas que eu costumava utilizar, vi por acaso no "Software Ubuntu" que o computador já tinha um programa: "aplicativos iniciais de sessão"

Abrindo esse programa, o PJeOffice estava lá, mas não inicializava sozinho

Nas configurações, ele apontava para um caminho e arquivo que deu erro quando testei no nautilus

Então, arrisquei substituir pelo caminho e arquivo "pjeOffice.sh" do item 3.3.

Foi então que ele começou a funcionar sozinho, sem eu ter que executar no terminal

Agora basta para mim entrar no site do PJe, clicar para logar com certificado digital, que o resto acontece, tanto no Firefox quanto no Chrome

Apenas no Firefox ele me pede para escolher o certificado antes de digitar o PIN.

Boa sorte para todos!

Inês Ambrósio


Olá Inês, parabéns por ter conseguido!
Você se deparaou com este problema "sun.security.pkcs11.wrapper.PKCS11Exception: CKR_DEVICE_ERROR" ao acessar o pje?

[17] Comentário enviado por mamp em 28/06/2019 - 12:07h

A Ines acho que esta publicando em tudo. No meus post ela fez o mesmo.
As versoes novas da Valid pede para atualizar a biblioteca libgdbm3
Estou usando Ubuntu 19.04 com novo cliente de assinatura do TOken da Valid versao 03
Mas o Pjeoffice nao esta estavel com esta nova versao da Valid. Deveremos ter novas correcoes.




Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts