Fazendo mouse Mtek funcionar no Debian com kernel 2.6

Publicado por G. Magalhaes em 30/03/2007

[ Hits: 5.381 ]

 


Fazendo mouse Mtek funcionar no Debian com kernel 2.6



Oi gente! Seguinte, instalei o Debian com o kernel 2.4 e meu mouse Mtek (serial, óptico com scroll) funcionou muito bem, mas quando reinstalei o Debian usando o kernel 2.6 ele parou de funcionar, ficando estático no centro da tela. Fui no /etc/X11/XF86Config e alterei o device de /dev/ttyS0 para /dev/input/mice e reiniciei, aí ele ficou doidinho se movendo como louco ao menor toque.

Aí percebi que tinha um outro arquivo de configuração, /etc/X11/XF86Config-4, que continha dados diferentes do outro. Então decidi torná-los iguais e ver o que dava. Bem, após um "shutdown -r now" o X não carregou, usando prompt dei um startx e uma mensagem de erro surgiu se referindo a uma linha do arquivo /etc/X11/XF86Config-4 "Configured Mouse", então usando o joe editei o arquivo e alterei essa linha (que antes, diga-se de passagem, de eu fazer a primeira edição já era assim), mas deixei as demais linha alteradas e funcionou!!! No final os arquivos ficaram assim:

# /etc/X11/XF86Config

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "CorePointer"
        Option      "Protocol" "IMPS/2"
        Option      "Emulate3Buttons" "true"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
EndSection

# /etc/X11/XF86Config-4
Section "InputDevice"
        Identifier  "Configured Mouse"
        Driver      "mouse"
        Option      "CorePointer"
        Option      "Device"            "/dev/input/mice"
        Option      "Protocol"          "IMPS/2"
        Option      "Emulate3Buttons"   "true"
        Option      "ZAxisMapping"      "4 5"
EndSection

Somente agora estou podendo estudar Linux direito, então não sei se isso é trivial, mas não achei referência direta sobre esse tipo de problema com este modelo de mouse no VOL, mas encontrei vários artigos sobre mouses VCOM que me ajudaram e muito a resolver o meu problema. Então fica aí a minha dica, espero poder ajudar.

Abraço a todos(as).

Outras dicas deste autor

mailx não envia cópia carbono nem cópia carbono oculta [RESOLVIDO]

[RESOLVIDO] Squirrelmail não encaminha mensagens

Leitura recomendada

Áudio no Ubuntu 10.04 - notebook HP G42-230

Configurando o som no Acer Aspire 3660

cpuinfo - Verificando CPU e Core

Configurando sua webcam Creative NX PRO

Conectando a uma rede com MAC mudado, placas Atheros

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts