Drivers do Dell 5470 no Ubuntu 14.04, Linux Mint ou derivados

Publicado por Lucas em 09/06/2014

[ Hits: 34.215 ]

 


Drivers do Dell 5470 no Ubuntu 14.04, Linux Mint ou derivados



Abaixo, você encontrará passos para a resolução de alguns problemas que tive.

Temos quatro problemas básicos após a instalação do GNU/Linux no Vostro 5470:
  1. O botão direito do touchpad não funciona;
  2. Áudio baixo e o subwoofer não funciona;
  3. Sem driver para a placa de vídeo NVIDIA GT 740M;
  4. Leitor de digitais não funciona no GNU/Linux, mas mesmo assim, continua sugando energia, eu acho...

Para fazer os passos, utilizaremos linhas de comando e um pouco de edição de arquivos usando o GEdit, por isso, tenha em mãos o terminal e um pouco de atenção. :)

Touchpad

Referências: Linux Mint Forums • View topic - Installing Linux Mint 16 Petra 64-bit on Dell Vostro 5470

cd ~ && wget http://people.canonical.com/~acelan/bugs/lp1188025/mouse.tgz
sudo gedit /etc/rc.local

* Atenção: substitua a parte do código que tem "seu-nome-de-usuário" pelo nome do seu usuário (exemplo: lucas) e adicione o código modificado por você antes de "exit 0":

cd /home/seu-nome-de-usuário/mouse && make && sudo cp psmouse.ko /lib/modules/`uname -r`/kernel/drivers/input/mouse/psmouse.ko && sudo rmmod psmouse && sudo modprobe psmouse

- Pergunta: O que os passos acima fazem?

- Reposta: baixam um driver postado por um usuário num fórum da Canonical e adicionam comandos para que o driver seja instalado toda vez que você reiniciar sua máquina. Isso é necessário, pois após as atualizações do kernel, o driver seria quebrado/removido sem essas linhas de código.

Áudio e Subwoofer

Áudio baixo e o subwoofer não funciona.

Referência: sound - Subwoofer doesn't work on Dell Inspiron 17R after upgrade to 13.10 - Ask Ubuntu

sudo apt-get install alsa-tools alsa-tools-gui && hdajackretask

Selecione Realtek ACL290, na parte Select a Codec:
Linux: Drivers do Dell 5470 no Ubuntu 14.04, Linux Mint ou derivados
Na parte Options, selecione Show unconnected pins.

Em: Pin ID: 0x18, selecione: Override

E selecione também Internal Speaker (LFE), bem abaixo do Override, que você acabou de selecionar:
Linux: Drivers do Dell 5470 no Ubuntu 14.04, Linux Mint ou derivados
Clique em Apply Now e teste. Se funcionar (deve funcionar), clique em\; Install boot Override.

- Pergunta: o que os passos acima fazem?

- Reposta: baixam e instalam um assistente para configurar alguns dispositivos da máquina.

NVIDIA Drivers

Referência: Linux Mint Forums • View topic - Installing Linux Mint 16 Petra 64-bit on Dell Vostro 5470

Adicione a PPA para os drivers da NVIDIA e Bumblebee (economia de energia¹):

sudo add-apt-repository ppa:xorg-edgers/ppa && sudo add-apt-repository ppa:bumblebee/stable
$ sudo apt-get update


Remoção do Bumblebee anteriormente instalado e/ou drivers da NVIDIA:

sudo apt-get purge bbswitch-dkms bumblebee-nvidia
$ sudo apt-get purge nvidia*


Instalação do driver NVIDIA 331 e Bumblebee

sudo apt-get install nvidia-331 bumblebee bumblebee-nvidia primus

Reinicie o sistema.

Veja se o driver da NVIDIA e o Bumblebee se estão funcionando (não testei²).

optirun glxgears

Se você tiver tido algum problema com áudio nos vídeos do YouTube, essa também é a hora de testar³.

Leitor de digitais

Referência: Linux Mint Forums • View topic - Installing Linux Mint 16 Petra 64-bit on Dell Vostro 5470

Desabilitando o leitor de digitais que não funciona no GNU/Linux, mas continua sugando energia:

Essa é fácil, basta desabilitá-lo na BIOS:
  • Pressione F2 durante o boot;
  • Vá até a aba: Advanced;
  • Selecione: Miscellaneous Devices;
  • E desative: Finger Print.

Notas

¹ Se você não for jogar, ou se for jogar mas não for jogar nada muito pesado, não precisará usar a placa da NVIDIA, portanto, ela só gastará mais energia.

Desativando-a, você terá uma maior duração de bateria, se você também quer fazer isso, pesquise "NVIDIA" no Dash (similar ao iniciar do Windows) e abra o NVIDIA x Server Settings. Na seção PRIME, selecione Intel e clique em Sair.

Para já colocar suas configurações em prática, basta encerrar sua sessão e entrar novamente com seu usuário.
Linux: Drivers do Dell 5470 no Ubuntu 14.04, Linux Mint ou derivados
² Como não pretendo usar a placa de vídeo, não cheguei a testar isso, a dica veio de alguém com o mesmo aparelho. :)

³ Não tive nenhum problema com isso, nem acho que tenha algo a ver, maaaas, se você tiver, pode ser que isso resolva. E se não resolver, fale com a gente aqui, que lhe ajudaremos. :)

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Servidor VNC no Funtoo

Dropbox - Como manter a configuração de aplicativos entre várias máquinas

Emulação de Impressora Jetdirect

sources.list complementar para o Debian Squeeze

Painel do Gnome todo transparente

  

Comentários
[1] Comentário enviado por eldermarco em 09/06/2014 - 10:13h

Fala Lucas! Excelente dicas!

Como um usuário empolgado dessa máquina, também tenho algumas coisas a dizer, rsrs:

Em relação ao clique com o botão direito não funcionar, eu registrei um bug contra o kernel no bugzilla da Red Hat e o problema já foi resolvido. Inclusive, recebi um e-mail dizendo que o patch já foi aplicado ao kernel. Creio que nas próximas atualizações -- não as primeiras -- não vamos mais precisar fazer um procedimento desse tipo:

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/drivers/input/mouse/elantech....


Em relação ao leitor de impressões digitais, já existe o driver e ele deve entrar na próxima versão da libfprint:

https://bugs.freedesktop.org/show_bug.cgi?id=61692

Eu apliquei esse patch na libfprint e gerei novamente o pacote para o fedora, além de ter tido que reempacotar o fprintd também. O dispositivo foi detectado, mas eu não sei se sou muito ruim para gravar uma impressão digital ou se esse tipo de dispositivo é que não é muito preciso. Só uma vez que funcionou o reconhecimento. Em todos os outros ele dizia que a impressão digital lida não batia com a gravada. Tentei de várias formas e nada.

Já em relação ao áudio, funcionou legal aqui. Mas parece que o som é um pouco mais baixo que em outras máquinas, não? Vou ver isso.

Em relação a placa Nvidia, eu acho que é porque não há suporte pra ela nas versões de driver que se encontram nos repositórios. Mas creio que em breve eles devem atualizar!

Valeu pelas dicas! =)

[2] Comentário enviado por removido em 09/06/2014 - 23:47h

Salve Lucas! O lance da placa NVIDIA, o que me deixou bastante satisfeito no Ubuntu 14.04 foi o aplicativo prime-indicator. Com apenas um click, caso seja necessário, você troca da placa da Intel para a placa da NVIDIA. Literalmente um clique mesmo.
Para instalar basta apenas já ter o driver atualizado da NVIDIA (sugiro instalá-lo pela central de programas do ubuntu - é a versão testada) e, logo após instalado, não precisa nem fazer log out na máquina e dar o seguinte comando:

$ sudo add-apt-repository ppa:nilarimogard/webupd8
$ sudo apt-get update
$ sudo apt-get install prime-indicator

A dica foi encontrada no site desse camarada aqui http://www.webupd8.org/2014/01/prime-indicator-lets-you-quickly-switch.html.

Grande abraço!

ps: aqui não funcionou a instalação do driver para controle do subwoofer. Não aparece as opção de PIN. Apenas "options" e "select codec". De qualquer forma vou tentar mais uma vez após fazer um upgrade do sistem. Assim que obtiver o resultado posto aqui.

[3] Comentário enviado por thiagomundo em 11/06/2014 - 09:47h

Lucas, instalei o ubuntu 14.04 no meu vostro 5470, tenho esses problemas que vc mostrou ai e mais alguns.
Não consegui arrumar o Touchpad, e quando fiz o comando para o som, o pc ficou mudo.

Sou novato com o Linux não sei se fiz os comandos certos. Se puder me diz se os comandos do jeito certo os comandos:ou comantar passo a passo como fiz:

Para funcionar o touchpad

1º abri o terminal, copiei e colei o comando: $ cd ~ && wget http://people.canonical.com/~acelan/bugs/lp1188025/mouse.tgz (sem o $)

2º ainda no terminal copiei e colei o comando: $ sudo gedit /etc/rc.local

3º Depois disso abriu o rc.local (/etc) -gedit

nessa janela que abriu eu copiei e colei o comando: cd /home/thiago/mouse && make && sudo cp psmouse.ko /lib/modules/`uname -r`/kernel/drivers/input/mouse/psmouse.ko && sudo rmmod psmouse && sudo modprobe psmouse
(com meu nome de usuário inserido, conforme você orientou)

essa janela ficou assim:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
# cd /home/thiago/mouse && make && sudo cp psmouse.ko /lib/modules/`uname -r`/kernel/drivers/input/mouse/psmouse.ko && sudo rmmod psmouse && sudo modprobe psmouse
exit 0


4º ai salvei a alteração e voltei para o terminal

e fiz update.

Não sei se fiz tudo certo, deve ter alguma falha nesse processo pode me ajudar com isso?

Agradeço por postar como resolver o problema

[4] Comentário enviado por lucasljj em 11/06/2014 - 11:13h

@thiagomundo, primeiramente, faltou um comando nessa dica, (tar zxvf mouse.tgz) logo depois do "wget..." após executar esse comando, faça novamente os passos a partir do 2º seguindo a ordem do seu comentário :) depois, remova o "#" que vocẽ colocou ali antes do código no /etc/rc.local, com esse "#" o código passa a ser somente um comentário e não fará nada

Quanto ao áudio, vá nas configurações do sistema e entre na parte do Som, lá, se por algum motivo obscuro houver alguma outra saída selecione ela, aumente o volume e teste, se não resolver mande uma screenshot (envie ao imgur.com) da janela do hdajackretask na parte em que você fez as modificações pra eu dar uma olhadinha no que você marcou



@eldermarco, queria responder depois de alguns testes, mas, esse é um dos meus males, sempre esqueço que notícia ruim é melhor que notícia nenhuma kkk, enfim, interessante a sua contribuição ao Kernel :) achei que seria beem complicado fazer um report de algo assim e preferi trilhar o caminho das pedras (gambiarra hahaha)

Quanto ao leitor de digitais, seria muito bem vindo um driver que funcione, vou esperar sair alguma versão nova dele com esse path, ou não, e vou testar ;)

Já quanto ao áudio, o Kernel 3.15 resolve (aparentemente de forma parcial no Ubuntu, vou testar com o Fedora nessa tarde, vai que é a algum controle energético a mais do Ubuntu... quem sabe...), o bendito subwoofer só liga mesmo quando eu desligo o áudio (fn + f6) e religo novamente, assim o áudio fica perfeito, isso sem fazer aquela dica ali do áudio, fazendo a dica ele fica 100% do tempo ligado, o que não é o ideal, já que distorce o som real, mas, fica BEEm alto, eu prefiro "baixo" com uma maior qualidade sonora, é uma pena não ter como editar a dica :/


@renatomaciel Legal a dica do Prime Indicator, vou lembrar dela caso queria usar a placa dedicada. Se ainda tiver problemas com o áudio é só dizer :)

[5] Comentário enviado por eldermarco em 11/06/2014 - 12:23h

Em relação ao som ficar alto, isso não ocorre no fedora também não. Mas eu havia lido que o volume desse computador não era alto mesmo e por isso não achei estranho. Se tu quiser testar o fedora já com essa correção, me avise que eu faço o upload do pacote do kernel com esse patch que corrige o problema com o mouse. Acho que ainda vai demorar alguns dias ou semanas até essa atualização chegar no fedora, embora ela já faça parte do kernel.
Se tu quiser testar o leitor de impressões digitais, também tenho os pacotes recompilados com o patch aplicado.

Update: Vi agora que o kernel com o patch para corrigir o problema já foi gerado pelo projeto fedora. São os pacotes kernel-3.14.7-200.fc20 e kernel-3.14.7-100.fc19. Devem já estar no repositório updates por esses dias e não será necessário mais nenhuma gambiarra. Eu também informei ao pessoal do Ubuntu em um bug similar no launchpad.

[6] Comentário enviado por thiagomundo em 11/06/2014 - 14:00h

Joia Lucas.
obg pelo retorno, mas ainda não deu certo o touchpad

quando faço o comando no rc.local (/etc) -gedit , aparece isso no terminal:

[email protected]:~# sudo gedit /etc/rc.local

(gedit:2759): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(gedit:2759): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
[email protected]:~#

Onde ta minha falha, da p identificar?

Valeu pelo retorno.

[7] Comentário enviado por eldermarco em 12/06/2014 - 07:58h

Thiago,

Não é necessário colocar isso no rc.local. Aliás, acho que nem o modprobe é necessário depois que tu reiniciar a máquina, uma vez que tu já terá colocado o módulo no lugar correto. Eu nunca cheguei a instalar um módulo individualmente, mas creio que o que eu disse abaixo deve funcionar.

Começando do zero, faça o seguinte como usuário comum:

$ cd
$ wget http://people.canonical.com/~acelan/bugs/lp1188025/mouse.tgz
$ tar xfv mouse.tgz
$ cd mouse
$ make

E se o módulo tiver sido compilado com sucesso, tu deverá ver um arquivo chamado psmouse.ko no diretório atual. Se não ver ele, é porque houve algum erro durante a compilação, provavelmente porque está faltando algum pacote de desenvolvimento necessário para que dê tudo certo. Mas se deu tudo certo, copie o módulo para o local que o Lucas sugeriu, mas antes faça um backup do módulo psmouse.ko que está na sua máquina:

$ sudo cp /lib/modules/`uname -r`/kernel/drivers/input/mouse/psmouse.ko /home/thiago

E então, copie o novo módulo compilado, sobrescrevendo esse:

$ sudo cp psmouse.ko /lib/modules/`uname -r`/kernel/drivers/input/mouse/

Atente para a crase (`) em `uname -r`

Em seguida, reinicie a sua máquina e veja se o botão direito funciona normalmente.

Uma outra alternativa seria, em vez de copiar o módulo para esse diretório, você descarregar o módulo que está lá e inserir esse:

$ sudo rmod psmouse
$ sudo insmod ./psmouse.ko

E testar o botão direito da sua máquina, sem precisar reiniciar. O problema é que tu terá que fazer isso toda vez que ligar a sua máquina, uma vez que o kernel vai sempre carregar o módulo psmouse oficial dessa maneira.


Eu sugiro acompanhar esse bug no launchpad:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1188025

E nesse bug que é citado esse procedimento e é bom acompanhar ele para saber se uma atualização do kernel com essa correção foi liberada. Quando tu instalar ela, já não vai mais precisar fazer nada disso.

[8] Comentário enviado por eldermarco em 13/06/2014 - 19:53h

Pronto senhores,

Quanto ao problema com o clickpad , isso já foi resolvido no fedora e uma atualização do kernel já está disponível para o fedora 19 e 20. Eu testei e está tudo OK. Em breve deve ser resolvido também em outras distros porque a correção já faz parte oficialmente do kernel.

[9] Comentário enviado por lucasljj em 05/07/2014 - 02:58h

Correção para outro problema: Vocês já devem ter notado que o touchpad é inteiramente sensível ao toque, inclusive os botões, certo?
As vezes quando vou clicar em algo acabo movendo sem querer o cursor um pouco e acabo clicando nos lugares errados, para solucionar o problema eu desativei a sensibilidade touch nos botões do touchpad.

Caso queira fazer o mesmo abra o "Aplicativos de sessão" e clique em "Adicionar"

em "Nome" insira: Fix do botões do touchpad
em "Comando" insira: synclient AreaBottomEdge=1700
e em "Comentário" insira: Desativa a sensibilidade touch nos botões do touchpad

isso tem uma cara danada de gambiarra e só funcionará para o seu usuário, caso queira fazer em outros usuários repita o processo, como é algo que achei hoje hoje/ontem a noite não tentei colocar o código no lugar correto :-P

fica a referência de onde inserir o código caso você saiba o que esteja fazendo /usr/share/X11/xorg.conf.d/50-synaptics.conf
Não insira isso em qualquer lugar do arquivo ou terá uma tela preta da morte quando reiniciar o pc kkkk eu mesmo detonei o meu X umas 2 vezes só testando jogar o código entre as "tags", tenha muito, muuito cuidado :)

PS: apartir de alguma versão do Kernel 3.15 o problema do click direito não funcionar foi resolvido, caso queiram deixar de lado a gambiarra acima basta atualizar o kernel pra versão 3.15 final ou + :)

[10] Comentário enviado por juliansoares em 31/03/2015 - 14:13h


Ola não consegui instalar mousepad e nem placa de video, poderia me ajudar?

[[email protected]] ~ $ sudo add-apt-repository ppa:xorg-edgers/ppa && sudo add-apt-repository ppa:bumblebee/stable

[[email protected]] ~ $ sudo apt-get update
Ign http://ppa.launchpad.net wheezy Release.gpg
Atingido http://ftp.debian.org wheezy-updates Release.gpg
Atingido http://http.debian.net wheezy-backports Release.gpg
Ign http://ppa.launchpad.net wheezy Release.gpg
Atingido http://dl.google.com stable Release.gpg
Atingido http://ftp.debian.org wheezy-updates Release
Atingido http://ftp.au.debian.org stable Release.gpg
Atingido http://security.debian.org wheezy/updates Release.gpg
Atingido http://http.debian.net wheezy-backports Release
Ign http://ppa.launchpad.net wheezy Release
Atingido http://security.debian.org wheezy/updates Release
Atingido http://security.debian.org wheezy/updates/main Sources
Atingido http://dl.google.com stable Release
Atingido http://security.debian.org wheezy/updates/contrib Sources
Atingido http://security.debian.org wheezy/updates/non-free Sources
Atingido http://ftp.debian.org wheezy-updates/main Sources
Atingido http://security.debian.org wheezy/updates/main amd64 Packages
Atingido http://security.debian.org wheezy/updates/contrib amd64 Packages
Ign http://ppa.launchpad.net wheezy Release
Atingido http://security.debian.org wheezy/updates/non-free amd64 Packages
Atingido http://security.debian.org wheezy/updates/contrib Translation-en
Atingido http://http.debian.net wheezy-backports/main amd64 Packages/DiffIndex
Atingido http://security.debian.org wheezy/updates/main Translation-en
Atingido http://security.debian.org wheezy/updates/non-free Translation-en
Atingido http://ftp.au.debian.org stable Release
Atingido http://ftp.debian.org wheezy-updates/contrib Sources
Atingido http://dl.google.com stable/main amd64 Packages
Atingido http://http.debian.net wheezy-backports/main Translation-en/DiffIndex
Atingido http://ftp.debian.org wheezy-updates/non-free Sources
Atingido http://ftp.au.debian.org stable/main Sources
Atingido http://ftp.debian.org wheezy-updates/main amd64 Packages/DiffIndex
Atingido http://ftp.debian.org wheezy-updates/contrib amd64 Packages
Atingido http://ftp.au.debian.org stable/contrib Sources
Atingido http://ftp.debian.org wheezy-updates/non-free amd64 Packages
Atingido http://ftp.debian.org wheezy-updates/contrib Translation-en
Atingido http://ftp.au.debian.org stable/non-free Sources
Atingido http://ftp.debian.org wheezy-updates/main Translation-en/DiffIndex
Atingido http://ftp.debian.org wheezy-updates/non-free Translation-en
Atingido http://ftp.au.debian.org stable/main amd64 Packages
Atingido http://ftp.au.debian.org stable/contrib amd64 Packages
Atingido http://ftp.au.debian.org stable/non-free amd64 Packages
Atingido http://ftp.au.debian.org stable/contrib Translation-en
Atingido http://ftp.au.debian.org stable/main Translation-pt_BR
Atingido http://ftp.au.debian.org stable/main Translation-pt
Ign http://dl.google.com stable/main Translation-pt_BR
Atingido http://ftp.au.debian.org stable/main Translation-en
Ign http://dl.google.com stable/main Translation-pt
Atingido http://ftp.au.debian.org stable/non-free Translation-en
Ign http://dl.google.com stable/main Translation-en
Err http://ppa.launchpad.net wheezy/main Sources
404 Not Found
Err http://ppa.launchpad.net wheezy/main amd64 Packages
404 Not Found
Ign http://ppa.launchpad.net wheezy/main Translation-pt_BR
Ign http://ppa.launchpad.net wheezy/main Translation-pt
Ign http://ppa.launchpad.net wheezy/main Translation-en
Err http://ppa.launchpad.net wheezy/main Sources
404 Not Found
Err http://ppa.launchpad.net wheezy/main amd64 Packages
404 Not Found
Ign http://ppa.launchpad.net wheezy/main Translation-pt_BR
Ign http://ppa.launchpad.net wheezy/main Translation-pt
Ign http://ppa.launchpad.net wheezy/main Translation-en
W: Falhou ao buscar http://ppa.launchpad.net/bumblebee/stable/ubuntu/dists/wheezy/main/source/Sources 404 Not Found

W: Falhou ao buscar http://ppa.launchpad.net/bumblebee/stable/ubuntu/dists/wheezy/main/binary-amd64/Packages 404 Not Found

W: Falhou ao buscar http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/dists/wheezy/main/source/Sources 404 Not Found

W: Falhou ao buscar http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu/dists/wheezy/main/binary-amd64/Packages 404 Not Found

E: Falhou o download de alguns ficheiros de índice. Foram ignorados ou os antigos foram usados em seu lugar.

[11] Comentário enviado por lucasljj em 01/04/2015 - 00:04h

[10] Comentário enviado por jukinha em 31/03/2015 - 14:13h

Ola não consegui instalar mousepad e nem placa de video, poderia me ajudar?


Posso sim, esta dando esses erros pois você esta usando Debian, mas...

No Ubuntu, a partir da versão 14.04.2, os problemas com o touchpad e o áudio foram resolvidos automaticamente já que a versão LTS agora usa o Kernel 3.16, mas, a gente pode ver o que dá pra fazer aí... amanhã dou uma olhada e te ajudo

[12] Comentário enviado por lucasfariaslf em 23/02/2016 - 02:54h

Espero que esteja alguém por aqui ainda... Comprei um 5470 hoje. Porém:

Já testei duas versões do Lubuntu, a mais recente LTS 14, e a 15.10. Em ambas, simplesmente, sem áudio. :(

Resolvi tentar a solução do subwoofer apresentada no post, só que quando clico em Apply Now, aparece: tee: /sys/class/sound/hwC1D0/reconfig: Device or resource busy.

No alsamixer, aparece a placa de hdmi e a Realtek ALC290. Mas mesmo mudando os controles de som continuo sem áudio.

Simplesmente desesperado. Por favor, ajudem.

[13] Comentário enviado por thatiane.lima01 em 10/12/2016 - 11:21h

Gente, alguém aqui teve o problema com a rede wifi? Eu sou novata no Linux e acabei de comprar o Vostro 5480 e a rede tá caindo de 5 em 5 minutos. No site da Dell eles instruem a instalar um drive mas não tem a opção para Linux. No site da intel tem mais de uma opção e eu não sei qual colocar e nem como instalar alguém pode me ajudar?
Obrigada



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts