Declarando "netbios name" no Samba

Publicado por Eduardo Colombo da Silva em 20/02/2004

[ Hits: 30.474 ]

 


Declarando "netbios name" no Samba



Quando vocês forem configurar o Samba, lembre-se de sempre pôr a seguinte linha no smb.conf:

netbios name = nome_da_maquina

Dessa forma, caso o Samba não consiga resolver o nome do servidor pelo DNS, será utilizado o nome declarado nesta configuração.

Já me aconteceu de o Samba não encontrar o nome da máquina e acabei penando até resolver isso.

Outras dicas deste autor

Montando um roteador com um 486

Red Hat 9 em Live CD

Senha de root no Kurumin

Desinstalando o Linux do HD

Bug no Samba

Leitura recomendada

Solicitar a alteração de senha no primeiro login - Samba

Usando Delta ISOs

O comando grep

Programando o seu Linux para desligar automaticamente

GRUB Rescue - recuperando o Grub com 4 comandos

  

Comentários
[1] Comentário enviado por mrluk em 22/02/2004 - 19:12h

mas isso é válido em q sentido?

No caso dos terminais windows não acharem o servidor samba na rede?

...ou o contrário?

Um grande abraço,

[2] Comentário enviado por linuxlive em 23/02/2004 - 08:22h

Quando o windows não encontra o samba, ou não acessa !

[3] Comentário enviado por mbmaciel em 24/07/2004 - 22:32h

Incrível !! só isso e já resolveu meu problema. valeu !

[4] Comentário enviado por xerif20 em 09/11/2004 - 15:43h

COMO FAÇO PARA DUAS ESTAÇOES LINUX SE ENCHERGAREM? NEM AS ESTAÇÕES WINDOWS ENCHERGAM A ESTAÇÃO LINUX, SO A LINUX QUE ENCHERGA A WINDOWS

[5] Comentário enviado por linuxlive em 12/11/2004 - 07:30h

Xerif20, se uma maquina estiver pingando a outra, basta compartilhar na maquina a pasta que deseja liberar o acesso, em ambas as maquinas. Recomendo vc usar o programa LinNeighborhood (ele é igual o ambiente de rede do windows) . adicione o IP da maquina linux, e pronto. vc conseguirá acessar a pasta que vc compartilhou na maquina Linux.

[6] Comentário enviado por dracillus em 05/04/2012 - 10:22h

Olá Amigo, inseri essa linha de código no meu smb.conf porem nada mudou

1)Instalei o meu Ubunto 10.4 com um usuário chamado proxy-squid

2)Instalei o samba e defini o mesmo para esta no meu grupo de trabalho chamado "Datacabos"

3)Abaixo da linha de comando

workgroup = DATACABOS (Funcinou)
netbios name = proxy-squid

Tento me conectar da estação windows na linux por \\proxy-squid e não funciona.
Se eu utilizar \\192.168.0.54, eu consigo me conectar. (IP da minha estação UBUNTO).

Aguardo uma resposta e agradeço desde já. Faz 2 dias que eu começei a utilizar o linux então peço paciencia hehe

Abraço

[7] Comentário enviado por linuxlive em 05/04/2012 - 10:30h

dracillus, primeiramente, o que voce passa no netbios name, é o Nome da maquina, e não o usuario que irá acessar.

Caso mesmo assim nao funcione, tente inicializar o nmb, que seria o servidor de nomes do samba. Este pacote é instalado juntamente com o samba, mas geralmente não é startado junto.

Segue a documentação do mesmo:
http://www.samba.org/samba/docs/man/manpages-3/nmbd.8.html


[8] Comentário enviado por gfbreis em 23/11/2015 - 15:44h


Migrei um servidor Fedora 14 com samba 3.5.5 para CentOS 7 e samba 4.1.12. Tudo funciona bem, mas as estações Windows 7 não rodam o script de logon automaticamente.


O que pode ser?



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts