Corrigindo problema do Acrobat Reader 7.0.9 no Ubuntu

Publicado por Roberson Carlos em 27/09/2007

[ Hits: 6.799 ]

Blog: http://carlrobers.wordpress.com

 


Corrigindo problema do Acrobat Reader 7.0.9 no Ubuntu



Após atualizar meu Ubuntu Feisty Fawn não havia reparado ainda que meu acroread havia parado de funcionar, não lei mais coisas no computador, mas houve um dia que baixei o cups-pdf e gerei alguns PDF's, quando fui testar qual não foi minha surpresa, meu acroread não dava nem sinal de vida, espera aí, sinal ele dava sim, quando executei-o em um terminal tive a seguinte mensagem:

expr: syntax error

Não liguei muito, comecei a usar o 'Visualizador de Documentos', mas o que ocorre é que o acroread começou a fazer falta e eu então me dispus a pesquisar em fóruns da Adobe pelo possível erro, mas nada de informação, foi uma 'caça' difícil, mas encontrei pessoas que tinham em comum comigo este erro, pois então uni informações de alguns fóruns e resolvi o problema.

Para tal faça da seguinte forma:

Entre no link abaixo e faça o download da LIB libgtk2.0-0_2.10.11-0ubuntu3_i386.deb:
Em seguida mova-a para o diretório /usr, vá para lá também fazendo uso de um terminal, passe o comando:

# dpkg -x libgtk2.0-0_2.10.11-0ubuntu3_i386.deb libgtk2

Em seguida edite o script acroread:

$ sudo gedit `which acroread`

E adicione e substitua as seguintes linhas no arquivo:

#!/bin/sh
#

LC_NUMERIC=C
export LC_NUMERIC
export GTK_IM_MODULE=xim
export LD_PRELOAD=/usr/libgtk2/usr/lib/libgtk-x11-2.0.so.0.1000.11

setLangENU()
{

Em seguida encontre e comente a linha abaixo no script:

check_gtk_ver_and_set_lib_path "$MIN_GTK_VERSION" ### returns 0 if found gtk >= 2.4

É isto aí, qualquer coisa estamos aí.

Veja como ficou no screenshot abaixo:



Roberson Carlos Fox - [email protected]
www.genovaengine.com

Outras dicas deste autor

Assinatura personalizada no e-mail (Evolution e Gmail)

Expressão regular com o Wget

Firefox 3.6 Tab Switching Preview

Instalar modem Motorola SM56

Cinco razões que fazem o Ubuntu 9.10 melhor que o Windows 7

Leitura recomendada

Driver para Sis 671/717 no Ubuntu 11.04

FIGlet - Letras grandes no modo texto

Habilitando o modo leitura no navegador Chromium

Pacote ttf-mscorefonts não instala no Ubuntu 16.04 LTS [RESOLVIDO]

PhotoFiltre 6.5.2 - Tradução para Português

  

Comentários
[1] Comentário enviado por User-kuruma em 27/09/2007 - 09:59h

Boa dica, estava com o mesmo problema e agora foi tudo resolvido.



Contribuir com comentário