Configurando modem HUAWEI E220 com operadora Tim no Ubuntu 11

Publicado por Fabiano Bazilio do Nascimento em 01/09/2011

[ Hits: 9.136 ]

 


Configurando modem HUAWEI E220 com operadora Tim no Ubuntu 11



Boa noite pessoal, hoje me deparei com o seguinte problema, precisei usar uma conexão 3G da TIM com meu notebook com Ubuntu 11 instalado.

Vamos parar de falar e colocar a mão na massa.

Algumas pesquisas depois encontrei a solução ai esta ela!

1 - Baixe o arquivo "huawei.out":

wget http://sfair.org/public/files/huawei.out

2 - Coloque ele em uma pasta e dê permissão de executável para ele.

chmod +x huawei.out

3 - Você vai precisar criar um arquivo de configuração em "/etv/wvdial.conf":

sudo touch /etc/wvdial.conf

4 - Edite este aquivo "wvdial.conf" e cole o que esta abaixo:

[Dialer 3g]
Modem = /dev/ttyUSB0
Baud = 921600
DialCommand = ATDT
Check Def Route = on
FlowControl = Hardware(CRTSCTS)
Username = tim
Password = tim
Phone = *99#
Stupid mode = 1
Auto Reconnect = off
Auto DNS = on
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 = AT+CGDCONT=1,"IP","tim.br"
ISDN = 0
Modem Type = Analog Modem

5 - Pronto agora é só discar e usar sua conexão 3G:

# wvdial

Bibliografia: http://wiki.ubuntu-br.org/TimWeb?highlight=%28huawei%29

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Atualizando para o Firefox 2.0

Bloqueando lista de diretorios do Apache

Versão correta do Moonlight para o site do Terra/Sonora

Easter Eggs no Google

Atualizando PHP e MySQL 4 para 5 e outros programas no CentOS 4.5

  

Comentários
[1] Comentário enviado por pinduvoz em 01/09/2011 - 01:08h

E o aqruivo huawei.out que vc falou para baixar e dar permissão de execução?

Não precisa ser executado?

Para que ele serve, então?

[2] Comentário enviado por bayt em 01/09/2011 - 08:12h

Bom dia .
Me desculpe eu coloquei o arquivo la e não espliquei o porque , o meu sistema não estava dectando
o modem automaticamente este ( huawe.out ) ele adiciona as regras do UDEV que são necessárias para
o sistema detectar o modem !

[3] Comentário enviado por julio_hoffimann em 01/09/2011 - 20:54h

*********ATENÇÃO**********

Como o nosso amigo André comentou sobre o tal arquivo huawei.out, decidi conferir e não tem nada de regras de udev! Se trata de um arquivo binário!

Portanto se você preza por segurança, não baixe o arquivo aqui proposto até que o autor justifique o formato binário.

Fabiano,

Poderia explicar melhor a origem desse arquivo? Pela rápida inspeção que fiz, parece ser de boa intenção.

[4] Comentário enviado por pinduvoz em 01/09/2011 - 20:58h

Sim, é um arquivo binário.

Eu baixei e conferi.

[5] Comentário enviado por julio_hoffimann em 01/09/2011 - 21:04h

Oi André,

Inspecionando os símbolos definidos no binário, as informações são coerentes com a configuração de um mini-modem, no entanto, não dá para confiar sem ver os fontes. ;-)

Abraço!

[6] Comentário enviado por bayt em 01/09/2011 - 21:57h

Um sim , sim , mas como foi o proprio wiki do ubuntu que disponibilizou este arquivo , julguei ser um arquivo confiavel , conforme descrito .
http://wiki.ubuntu-br.org/TimWeb?highlight=%28huawei%29

[7] Comentário enviado por pinduvoz em 01/09/2011 - 23:16h

Tudo bem, o arquivo não é perigoso ou malicioso.

Só que na dica que está na wiki do Ubuntu esse arquivo é executado como root.

Portanto, faltou uma parte importante da configuração da conexão na sua dica.

[8] Comentário enviado por julio_hoffimann em 02/09/2011 - 07:38h

Bom dia a todos!

A Wiki do Ubuntu contém o código em C, agora sim ficamos satisfeitos. :-)

Desculpa qualquer chatiação Fabiano.

Abraço!

[9] Comentário enviado por bayt em 02/09/2011 - 17:15h

Chateação nenhuma , discuçoes sadias so nos engrandece , e adiciona mas conhecimento !

[10] Comentário enviado por afrancisco em 14/05/2012 - 15:10h

Executei todos os procedimentos, mas não funcionou. Tutorial muito bom para Deus....não para um neófito como eu

[11] Comentário enviado por bayt em 14/05/2012 - 19:16h

OK mas este comentario afrancisco ( não funcionou ) pra mim fica muito vago, quais erros gerou , qual foi o retorno dos comandos , de uma olhada nos logs de erro e post para ver se eu ou mas alguem possa ajudar !

[12] Comentário enviado por nuno_nunes em 11/11/2012 - 13:07h

Eu tenho um modem desses e nunca tive esse problema



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts