Configurando cartão e-CNPJ no Firefox

Publicado por Alex Souza Resende em 03/06/2013

[ Hits: 13.034 ]

 


Configurando cartão e-CNPJ no Firefox

Aqui, onde trabalho, tive problemas em um site do Governo para acessar o programas deles. Vou postar essa dica, para caso alguém esteja com o mesmo problema.

Obs.: dica testada no Ubuntu.

Dependências para o programa SafeSign 3.0.77:
  • Libjbig0
  • libtiff4_3.9.6
  • Fontconfig-config
  • Libfontconfig1
  • Libwxbase2.8
  • Libwxgtk2.8
  • Libpcsclite1
  • Libccid_1.4.8-1
  • Pcscd_1.8.5

Podemos usar:

# dpkg -l | grep nome_da_dependência

Para verificar se o mesmo está instalado na máquina.

Caso não tenha alguma dependência, podemos usar o apt-get:

# apt-get install nome_da_dependência

Como segunda opção, podemos baixá-las no site da certificadora:

# cd /home/nome_do_usuario/certificado

Dependências para 32 bits:

# wget http://www.validcertificadora.com.br/upload/downloads/linux32bits/Libjbig0_2.0-2ubuntu1_i386.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux32bits/libtiff4_3.9.6-9ubuntu1_i386.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux32bits/Fontconfig-config_2.9.0-7_all.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux32bits/Libfontconfig1_2.9.0-7_i386.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux32bits/libwxbase2.8-0_2.8.12.1-6ubuntu2_i386.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux32bits/libwxgtk2.8-0_2.8.12.1-6ubuntu2_i386.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux32bits/libpcsclite1_1.8.5-1ubuntu1_i386.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux32bits/libccid_1.4.8-1_i386.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux32bits/pcscd_1.8.5-1ubuntu1_i386.deb

Dependências para 64 bits:

# wget http://www.validcertificadora.com.br/upload/downloads/linux64bits/libjbig0_2.0-2_amd64.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux64bits/Libtiff4_3.9.6-6ubuntu1_amd64.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux64bits/Fontconfig-config_2.9.0-7_all.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux64bits/Libfontconfig1_2.9.0-7_amd64.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux64bits/libwxbase2.8-0_2.8.12.1-6ubuntu2_amd64.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux64bits/libwxgtk2.8-0_2.8.12.1-6ubuntu2_amd64.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux64bits/libpcsclite1_1.8.5-1ubuntu1_amd64.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux64bits/libccid_1.4.7-1_amd64.deb
# wget http://www.validcertificadora.com.br/upload/downloads/linux64bits/pcscd_1.8.5-1ubuntu1_amd64.deb

Instalando com dpkg:

# dpkg -i *.deb

Instalando SafeSign 3.0.77:

Para 32 bits:

# wget http://www.validcertificadora.com.br/upload/downloads/linux32bits/safesignidentityclient_3.0.77-Ubuntu_i386.deb

Para 64 bits:

# wget http://www.validcertificadora.com.br/upload/downloads/linux64bits/safesignidentityclient_3.0.77-Ubuntu_amd64.deb

Rode o dpkg:

# dpkg -i safesignidentityclient_3.0.77-Ubuntu_*.deb

Abra o programa tokenadmin:

# tokenadmim

Já com seu certificado conectado no USB, aparecerá ele na lista do programa.

No caso do Ubuntu, para habilitar como um módulo de segurança no Firefox, acesse o menu "Integração" e execute a opção "Instalar o SafeSign no Firefox". Vai aparecer uma nova tela, selecione "Firefox" e clique no botão "Instalar".

No caso do Debian, abra o Firefox em: Editar → Preferências → Avançado → Criptografia
  • Na guia: "Dispositivos de segurança" → "Carregar"
  • Em: "Nome do módulo", coloque: ePass2000
  • E, em: "Nome do aquivo do módulo", coloque o caminho: /usr/lib/libaetpkss.so.3.0.2528

Outras dicas deste autor

Placa de Vídeo Intel no Fedora MATE 20 Heisenbug

Instalando o Xen facilmente no Debian Squeeze

Leitura recomendada

LVM vs Mount

Teclas de atalho do Windows no ambiente GNOME

Ubuntu - Destacando Aba Ativa no Gnome-Terminal

Ubuntu 14.04 - Como remover películas do Unity

Teclado multilíngue (exemplo: português/polonês)

  

Comentários
[1] Comentário enviado por pinduvoz em 15/08/2013 - 18:58h

Muito obrigado pela dica.

Mesmo que eu tenha chegado aqui após ter baixado o programa da Valid (li sobre ele no Fórum do Ubuntu), agradeço e confirmo que funciona.

[2] Comentário enviado por Alex Resende em 16/08/2013 - 08:22h

Que isso eu vi que realmente não tem muita coisa a respeito desse método na internet . Fico muito feliz em saber que ajudei !

[3] Comentário enviado por dllongo em 17/02/2014 - 09:31h

Vlw pela dica, dificil achar algo na net. Parabéns!

[4] Comentário enviado por xsara em 07/06/2014 - 22:29h

Quando eu quero assinar um laudo aparece assim
A senha do repositório pode estár incorreta ou
houve problemas com o acesso físico ao repositório

:-(

Sniff

[5] Comentário enviado por yuichiro em 11/10/2015 - 09:50h

Muito obrigado pela matéria! Funcionou com Lubuntu 12.04 Trusty. Mas com Ubuntu 14.04LTS não funcionou. Na hora de conferir o PIN dá erro e não reconhece. Me parece que varias pessoas estão na mesma. Tem haver com a versão do pacote?
Por enquanto trabalho com 12.04 no VirtualBox host Ubuntu 14.04

[6] Comentário enviado por mebelin em 09/11/2015 - 10:30h

Pessoal, alguém tem os arquivos? os links estão todos quebrados.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
{BANNER_MODEL1}
{BANNER_MODEL2}
{BANNER_MODEL3}

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts