Configurando a placa de vídeo ATI Radeon HD 2400 XT no Ubuntu e Debian

Publicado por andre uebe em 28/01/2009

[ Hits: 16.297 ]

Blog: http://resa.net.br

 


Configurando a placa de vídeo ATI Radeon HD 2400 XT no Ubuntu e Debian



Como tive a necessidade de fazer a configuração da placa aceleradora de vídeo ATI Radeon 2400 XT manualmente, uma vez que o Ubuntu 8.10 não a fez automaticamente, tentei localizar artigos em português que me orientassem. Como achei um artigo muito interessante na língua inglesa (sem similar em português), resolvi apresentar um texto de orientação baseado no mesmo.

1.1) VERIFICAÇÕES INICIAIS

A primeira constatação de que a placa não estava corretamente instalada foi quando tentei aplicar os efeitos extras (ex.: Janela "pegando fogo") do Compiz e o sistema retornou-me que não conseguia instalar o driver (conforme artigo Compiz Fusion: Ativando o efeito de "janela pegando fogo" e outros efeitos 3D).

Outra constatação que pude fazer foi a lentidão no momento de executar o jogo 3D "Neverball".

Em geral as placas nVidia GeForce tem sido instaladas automaticamente pelo Ubuntu, mas no caso da ATI Radeon em questão isto no aconteceu, obrigando-me a adotar os procedimentos descritos neste tutorial.

1.2) CONFERINDO O MODELO DA PLACA ACELERADORA DE VÍDEO

Antes de prosseguir você deve conferir qual o exato modelo da sua placa de vídeo. Não que as orientações aqui apresentadas não funcionem necessariamente em outra versão de Ubuntu (ex.:8.04) ou em outro modelo de placa ATI Radeon, mas sim pelo fato de que para outras configurações não foram feitos testes que atestem o pleno funcionamento. A expectativa é de que não haja problemas em outros modelos.

Vá ao shell, através do menu Aplicações --> Acessórios --> Consola e digite:

lspci

Na listagem que aparece, deve surgir a seguinte descrição da placa:

01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 2400

Realizando as configurações

Ainda no shell, deve-se seguir os passos, digitando os comandos descritos a seguir:

1) Removendo os drivers antigos:

sudo apt-get remove xorg-driver-fglrx fglrx-kernel-source

2) Instalando os drivers ATI:

sudo apt-get install xorg-driver-fglrx fglrx-kernel-source jockey-gtk xserver-xorg-video-radeon

3) Efetuando as configurações do sistema automaticamente:

sudo aticonfig --initial

4) Ativando as novas configurações:

Tecle Control + Alt + Backspace

Isto reinicializará o ambiente gráfico.

Restaurando as antigas configurações

Caso deseje, por algum motivo, restaurar as antigas configurações gráficas, acesse o shell (Menu Aplicações --> Acessórios --> Consola) e restaure o backup do arquivo de configurações gráficas através do seguinte comando:

sudo cp /etc/X11/xorg.conf.original-0 /etc/X11/xorg.conf

Referência: Ubuntu Ibex 8.10 with ATI Radeon hd 2400 xt

Outras dicas deste autor

Corrigindo 'bug' em placa de Vídeo NVIDIA: segundo monitor não aparece disponível no Ubuntu 11.10

Legendas no Avidemux

Conectando celular Nokia via Bluetooth no Debian

Corrigindo erro do VirtualBox no Ubuntu 8.04

MIDI, Timidity e Rosegarden no Kurumin: Solução definitiva

Leitura recomendada

Aumentando LV (Logical Volume) e RS (File System) sem causar indisponibilidade

Configurando um servidor para atender duas ou mais conexões com a internet

Configurando o PHP-Weathermap no Cacti

Usando aMSN com plugin MUSIC com suporte ao JUK

Compartilhamento de Internet 3G no Slackware

  

Comentários
[1] Comentário enviado por eucassiojr em 04/02/2009 - 11:07h

Parabéns, consegui instalar minha placa de video seguindo sua dica. Mas estou com problemas para ver vídeos, eles ficam piscando desde a webcam, totem, todo video. acho que o problema é com a placa de video você sabe como resolver?

[2] Comentário enviado por andreuebe em 07/02/2009 - 17:21h

eucassiojr

Também detectei este problema após algum tempo e instalação (e principalmente ao acessar o googleEarth).

O que pude verificar é que existe um bug ainda não resolvido. Infelizmente.

O jeito é acompanhar uma solução e postar aqui quando conseguirmos.

Abs

Andre

[3] Comentário enviado por eucassiojr em 08/02/2009 - 00:28h

http://www.vivaolinux.com.br/dica/Compiz-Resolvendo-problema-com-videos-piscando
A única maneira q consegui para resolver o problema

[4] Comentário enviado por andreuebe em 10/02/2009 - 12:31h

eucassiojr

Valeu pela dica.

Vou testar.

Abs

Andre

[5] Comentário enviado por eucassiojr em 26/02/2009 - 18:02h

o Problema dos videos piscando foi corrigido agora na nova versão do drive da ati eh so baixar no site da ati( http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.1Z... ) e instalar como root depois "aticonfig --initial -f" e reiniciar, qualquer erro tente novamente o "aticonfig --initial -f" nao esqueca de remover antes os drivers antigos "sudo apt-get remove xorg-driver-fglrx fglrx-kernel-source", aki funcionou muito bem + nau vi ainda outras pessoas testando o novo drive.

vlw





[6] Comentário enviado por andreuebe em 27/02/2009 - 11:50h

Eucassio

Valeu pela dica!

Abs

Andre

[7] Comentário enviado por geraldogof em 30/03/2009 - 18:47h

Olá andreuebe,
A sua dica da Radeon Pro me ajudou muito aconfigurar minha PV, gostaria de perguntar sobre a placa de captura de video PixelView (com chipSet CX2388) será que vc teria conhecimento sobre tal placa?
Geraldo



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts