Compiz Fusion no Ubuntu

Publicado por André Gondim em 29/06/2007

[ Hits: 32.256 ]

Blog: http://andregondim.eti.br

 


Compiz Fusion no Ubuntu



O Compiz Fusion foi o nome concedido ao merge entre Compiz e Beryl, agora ambos são um único produto e pessoalmente acho muito surpreendente a velocidade com que anda a carruagem desse projeto. A seguir dica passo-a-passo para quem quiser conhecê-lo melhor.

1) Dê um alt+f2 e execute:

gksu gedit /etc/apt/sources.list

Abrirá um editor de textos, então cole as seguintes linhas :

# Trevino's Ubuntu feisty EyeCandy Repository (GPG key: 81836EBF - DD800CD9)
# Many eyecandy 3D apps like Beryl, Compiz, Fusion and kiba-dock snapshots
# built using latest available (working) sources from git/svn/cvs...
# wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add -
deb http://download.tuxfamily.org/3v1deb feisty eyecandy
deb-src http://download.tuxfamily.org/3v1deb feisty eyecandy

Salve e saia do editor.

2) Atualize os seus repositórios, vá para a linha de comando (terminal bash) e execute:

$ sudo clear
$ wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add -
$ sudo apt-get update


3) Recomendo remover todas as as referências ao compiz ou beryl que você tiver instalado, o melhor caminho para isso é executar o Synaptic, Menu Sistema > Administração > Gerenciador de Pacotes Synaptic e procurar por tais referências e removê-las. Ou faça:

$ sudo apt-get remove --purge beryl-ubuntu
$ sudo apt-get autoremove


Após isso:

$ sudo apt-get dist-upgrade

No meu caso ele instalou quase tudo, mas ainda foi necessário fazer um:

$ sudo apt-get -f install

4) Instale o compiz:

$ sudo apt-get install compiz compiz-gnome

Ou compiz-kde ao invés do gnome.

5) Para instalar o configurador chamado CompizConfig:

$ sudo apt-get install compizconfig-settings-manager
$ sudo apt-get install compizconfig-backend-gnome


Ou compizconfig-backend-kde.

(no meu caso apareceu a informação abaixo)

$ sudo apt-get install compizconfig-backend-gnome
Lendo Lista de Pacotes... Pronto
Construindo Árvore de Dependências
Lendo informação de estado... Pronto
O pacote compizconfig-backend-gnome não está disponível, mas é referenciado por outro pacote.
Isso pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte
No entanto, os pacotes a seguir o substituem:
libcompizconfig-backend-gconf
E: O pacote compizconfig-backend-gnome não tem candidato para instalação)

6) Para instalar os plugins:

$ sudo apt-get install compiz-fusion-*

7) Para rodar o compiz, na linha de comando:

$ rm -fR ~/.beryl*
$ rm -fR ~/.emerald*
$ rm -fR ~/.compiz*
$ compiz --replace &


7.1) Rodar mais fácil ainda, pode-se criar um script para rodar da seguinte maneira:

$ gedit Compiz

Depois copie para esse arquivo os comandos:

rm -fR ~/.beryl*
rm -fR ~/.emerald*
rm -fR ~/.compiz*
compiz --replace &

Salve e dê permissão para executar:

$ chmod +x Compiz

Agora para rodar é só fazer um:

$ ./Compiz

7.2) Iniciando junto com o Gnome

Vá em Sistema > Preferência > Sessões.

Clique em novo e em nome bote Compiz Fusion e no comando, bote o caminho completo de onde o arquivo Compiz estar no meu caso ficou /home/gondim/Compiz.

Pronto, irá iniciar sempre com o Gnome.

Considerações finais:

A versão acima é fresquinha do repositório GIT (caracteristica desse repositório treviño), não use-a se você não estiver disposto a ter surpresas ruins. No link abaixo você encontra dica para versões anteriores, e provavelmente com menos surpresas.

As dicas acima foram copiadas e modificadas de http://forums.opencompositing.org/viewtopic.php?f=14&t=131. Se algo der errado e você quiser algum suporte poderá acessar este link e postar suas dúvidas (em inglês).

As minhas primeiras impressões é que vale à pena utilizar, é mais rápido, os zoom estão bem "lisos", transparências perfeitas. O compiz-backend-gnome lhe permite configurar as coisas. Ainda falta um programa ao estilo beryl-manager onde eu consiga trocar a WM a bel-prazer ou fazer ajustes. O heliodor e aquamarine permanecem nos repositórios e podem ser utilizados a seu bel-prazer (nem todos gostam do compiz). É muito bom, superou as expectativas.

Post original retirado de hamacker, com alterações minhas em http://andregondim.eti.br/.

Abraços e boa sorte!! ;)
Blog Ubuntu: http://andregondim.eti.br

Outras dicas deste autor

Inserindo um repositório no sources.list

Instalando o Pidgin 2.0.2 no Ubuntu

Ubuntu + Apache2 + MySQL + PHP5

Java x Compiz ou Beryl

Instalando Mercury no Ubuntu Feisty

Leitura recomendada

Kingfisher Quota Manager - Relatórios de impressão do CUPS

Resolvendo problema de fontes "problemáticas" no KDE 3.4

Thunar "empaca" quando aberto [resolvido]

Abiword, a alternativa GTK ao OpenOffice

Visualizar imagens noGwenwiew (separado do konqueror)

  

Comentários
[1] Comentário enviado por tinti em 30/06/2007 - 20:15h

Não é libcompizconfig-backend-kde

É libcompizconfig-backend-kconfig

[2] Comentário enviado por andregondim em 30/06/2007 - 21:13h

Realmente nessa pressa escrevi errado.
Valeu a correção.

Abraços,
André Gondim
http://andregondim.eti.br

[3] Comentário enviado por evil.hunter em 05/07/2007 - 11:51h

Esta acontecendo o seguinte problema comigo ao iniciar o compiz:

Aviso do gerenciador de janelas: “” localizado no banco de dados de configurações não é um valor válido para a tecla de atalho

Alguem sabe como me ajudar a resolver isso????

[4] Comentário enviado por apsantanna em 07/07/2007 - 19:03h

Meu caro,
O configurador do gnome é
libcompizconfig-backend-gconf

[5] Comentário enviado por cleitonsb em 08/07/2007 - 22:12h

Como configuro os efeitos????

[6] Comentário enviado por suissos em 10/07/2007 - 17:55h

Como salvo as minhas configurações de efeitos? sempre q eu reinicio reaparecem as configurações standart e tenho q fazer tudo outra vez.... =/
vlw!

[7] Comentário enviado por rockstore6 em 16/07/2007 - 01:31h

CARAAAAAAAAAAAAAAAAAAAAAAAAAA VC É O CARA NOSSA MANO SEU TUTORIAL FOI O UNICO QUE DEU CERTO SO QUERIA SABER SOBRE O EMERALD THEMAS C PODE BAIXAR E NAO VAI DAR PAL ETC..

[8] Comentário enviado por rafaelo em 18/07/2007 - 14:10h

Deu certo só que eu precisei fazer umas mexidas porque sumiu as bordas das janelas(botão de fechar minimizar,etc).
Se você tiver o mesmo problema faça o seguinte:

1 - Abra o arquivo /etc/X11/xorg.conf como root em um editor de texto de sua preferência.

2 - Localize a secão "Screen" e adicione a seguinte linha dentro dela:
Option "AddARGBGLXVisuals" "True"

3 - Veja se há uma seção "Extensions". Se não houver crie-a. Se houver, acrescente apenas a linha iniciada por "Option":

Section "Extensions"
Option "Composite" "Enable"
EndSection

4 - Salve o arquivo e reinicie o servidor gráfico.

[9] Comentário enviado por rockstore6 em 29/07/2007 - 01:20h

pow fera queria saber pq q uadno eu mando ele instalar o compiz gnome ele da isso


Alguns pacotes não puderam ser instalados. Isso pode significar que
você solicitou uma situação impossível ou se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram tirados do Incoming.
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
compiz: Depende: compiz-decorator mas não está instalável
E: Pacotes quebrados


acho qeu é pq eu uso o 64 bits ne :(

qualquer coisa

rocktore6@hotmail.com

[10] Comentário enviado por itocamargo em 29/07/2007 - 02:38h

cara eh o seguinte, eu e o rockstore passamos uma madrugada fazendo isso

aquela msg continua aparecendo
$ sudo apt-get install compizconfig-backend-gnome
Lendo Lista de Pacotes... Pronto
Construindo Árvore de Dependências
Lendo informação de estado... Pronto
O pacote compizconfig-backend-gnome não está disponível, mas é referenciado por outro pacote.
Isso pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte
No entanto, os pacotes a seguir o substituem:
libcompizconfig-backend-gconf
E: O pacote compizconfig-backend-gnome não tem candidato para instalação)

quanto a msg q ele postou antes, funcinou, achamos no trevino um repositorio pra 64 bits,
no dele foi blza
o meu ta ficando pra traz...

ta dando o seguinte erro na hora de iniciar
Fatal: Failed test: texture_from_pixmap support
Checks indicate that it's impossible to start compiz on your system.

e agora?
adicionei novos repositorios pra tentar baixar aquela lib, mas ainda nao rolou nada....

[11] Comentário enviado por ThiagoFeitosa em 02/08/2007 - 12:42h

meu compiz tah com problemas, não consigo botar uma decoração de janela, pro kde, todas as janleas ficam sem as barrinah em cima, alguem pode me ajudar?

[12] Comentário enviado por yarlos em 14/10/2007 - 08:57h

Isso dá certo no ubuntu 7.10?????????????????
Alguém sabe me dizer?

[13] Comentário enviado por overlock em 20/12/2007 - 11:54h

velho se sabe se o compiz roda em fluxbox??



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts