Compilando o MySQL Workbench no Debian

Publicado por Rodrigo Torres Leme em 27/03/2012

[ Hits: 8.974 ]

 


Compilando o MySQL Workbench no Debian



Ae Galera do VOL!

Venho, na minha primeira publicação, mostrar como compilar o MySQL Workbench no Debian.

Vejo muitos com dificuldade porque não existe a versão para Debian do MySQL Workbench e a versão para o Ubuntu que seria uma boa saída, apresenta muitos problemas com bibliotecas e não consegui resolver (Faz um tempinho já).

E acabei tomando esse desafio de compilar o programa.

Não sou nenhum expert mas consigo me virar.

Eu fiz todo o processo no Debian Squeeze e o MySQL Workbench versão 5.2.38. Ai vai!

1. Acessem o site: E baixem o Generic Linux da opção Source Code.

2. Instale as dependências do Workbench a seguir como root:

# apt-get install libpcre3-dev libctemplate-dev libgl1-mesa-dev python-dev liblua5.1-dev uuid-dev libmysqlclient-dev libboost-dev libsqlite3-dev libgtkmm-2.4-dev libsigc++-2.0-dev libxml2-dev libglib2.0-dev libzip-dev

3. Na pasta que está o arquivo mysql-workbench-gpl-5.2.38-src.tar.gz descompacte e acesso o diretório criado pelo comando:

tar -xzf mysql-workbench-gpl-5.2.38-src.tar.gz
$ cd mysql-workbench-gpl-5.2.38-src/


4. Agora compile o programa:

./configure
$ make


5. Faça a instalação:

# make install

6. Para quem gosta do famoso pacote .deb pode utilizar o CheckInstall para criar o pacote do programa e instalar.

# checkinstall -D

Aqui gerou um pacote de arquitetura AMD64 e instalei no meu netbook, mas tive que instalar as dependências citadas acima.

Valeu Galera, espero ter ajudado!

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Instalando o AssaultCube no Ubuntu Linux (FPS)

Usando o Putty para acessar um micro Linux a partir de um micro Windows

Extrair e comprimir arquivos com o kde4-Extractandcompress

Yed - Diagramas e Fluxogramas no GNU/Linux

Amarok, uma alternativa ao iTunes. Veja como instalar no seu Ubuntu e derivados

  

Comentários
[1] Comentário enviado por re_nobre em 01/04/2012 - 21:41h

Só pra esclarecer, na instalação das dependências faltou o "install" no "apt-get" do texto.

[2] Comentário enviado por hax0r3x em 04/04/2012 - 22:28h

Olá,

Estou tentando instalar o Mysql Workbench de acordo com o tutorial mas está acusando erro.

Segue a descrição do comando configure:

$./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking how to run the C++ preprocessor... g++ -E
checking for g77... no
checking for xlf... no
checking for f77... no
checking for frt... no
checking for pgf77... no
checking for cf77... no
checking for fort77... no
checking for fl32... no
checking for af77... no
checking for xlf90... no
checking for f90... no
checking for pgf90... no
checking for pghpf... no
checking for epcf90... no
checking for gfortran... no
checking for g95... no
checking for xlf95... no
checking for f95... no
checking for fort... no
checking for ifort... no
checking for ifc... no
checking for efc... no
checking for pgf95... no
checking for lf95... no
checking for ftn... no
checking whether we are using the GNU Fortran 77 compiler... no
checking whether accepts -g... no
checking the maximum length of command line arguments... 1572864
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by g++... /usr/bin/ld -m elf_x86_64
checking if the linker (/usr/bin/ld -m elf_x86_64) is GNU ld... yes
checking whether the g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking for g++ option to produce PIC... -fPIC
checking if g++ PIC flag -fPIC works... yes
checking if g++ static flag -static works... yes
checking if g++ supports -c -o file.o... yes
checking whether the g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
(cached) (cached) checking how to hardcode library paths into programs... immediate
appending configuration tag "F77" to libtool
checking whether byte ordering is bigendian... no
checking for pkg-config... pkg-config
checking for strtol... yes
checking for strtoll... yes
checking for strtold... yes
checking for strtoull... yes
checking for strtoimax... yes
checking for strtoumax... yes
checking sys/select.h usability... yes
checking sys/select.h presence... yes
checking for sys/select.h... yes
checking tr1/unordered_set usability... yes
checking tr1/unordered_set presence... yes
checking for tr1/unordered_set... yes
checking tr1/unordered_map usability... yes
checking tr1/unordered_map presence... yes
checking for tr1/unordered_map... yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for LC_MESSAGES... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for ngettext in libc... yes
checking for dgettext in libc... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... no
./configure: line 22312: ./po/POTFILES.in: No such file or directory
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for ZIP... yes
checking for GLIB... yes
checking for SIGC... yes
checking for GNOME_KEYRING... no
checking for GNOME_KEYRING... no
checking for GNOME... configure: error: Package requirements (gtkmm-2.4 >= 2.12) were not met:

No package 'gtkmm-2.4' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GNOME_CFLAGS
and GNOME_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

[3] Comentário enviado por rodcorporation em 04/04/2012 - 22:39h

hax0r3x, isso é biblioteca que está faltando para compilar. Basta dar um apt-cache search "nome do pacote" para ver o nome da biblioteca.
Quando é biblioteca geralmente começa com lib na frente. As bibliotecas que você for instalar sempre são as -dev.

Rode o comando apt-cache para você ver o que aparece.

$apt-cache search gtkmm-2.4
libgtkmm-2.4-1c2a - C++ wrappers for GTK+ (shared libraries)
libgtkmm-2.4-dbg - C++ wrappers for GTK+ (debug symbols)
libgtkmm-2.4-dev - C++ wrappers for GTK+ (development files)
libgtkmm-2.4-doc - C++ wrappers for GTK+ (documentation)

Pra resolver essa biblioteca instala o seguinte pacote.

#apt-get install libgtkmm-2.4-dev

rode de novo o ./configure.

Qualquer dúvida estou disponível =]

ABs

[4] Comentário enviado por hax0r3x em 05/04/2012 - 00:32h

Olá rodcorporation,

Obrigado por me responder.
Mas acontece que ao tentar instalar essa versão do pacote aparece algumas dependências que não podem ser resolvidas...

------------------------------------
$ sudo apt-get install libgtkmm-2.4-dev
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
libgtkmm-2.4-dev : Depende: libgtk2.0-dev (>= 2.20.0) mas não será instalado
Depende: libcairomm-1.0-dev (>= 1.2.2) mas não será instalado
Depende: libpangomm-1.4-dev (>= 2.26.0) mas não será instalado
E: Pacotes quebrados
------------------------------------


Utilizando o aptitude obtive a seguinte resposta:

------------------------------------
$sudo aptitude install libgtkmm-2.4-de
Os NOVOS pacotes a seguir serão instalados:
autopoint{a} debhelper{a} gettext{a} html2text{a} intltool-debian{a}
libatk1.0-dev{a} libcairo2-dev{ab} libcairomm-1.0-dev{a} libexpat1-dev{a}
libfontconfig1-dev{a} libfreetype6-dev{a} libglibmm-2.4-dev{a}
libgtk2.0-dev{a} libgtkmm-2.4-dev libmail-sendmail-perl{a}
libpango1.0-dev{a} libpangomm-1.4-dev{a} libpixman-1-dev{ab}
libpng12-dev{a} libsys-hostname-long-perl{a} libunistring0{a}
libxcb-render-util0{a} libxcb-render-util0-dev{a} libxcb-render0-dev{a}
libxcomposite-dev{a} libxcursor-dev{a} libxdamage-dev{a} libxext-dev{a}
libxfixes-dev{a} libxft-dev{a} libxi-dev{a} libxinerama-dev{a}
libxrandr-dev{a} libxrender-dev{a} po-debconf{a}
x11proto-composite-dev{a} x11proto-damage-dev{a} x11proto-fixes-dev{a}
x11proto-randr-dev{a} x11proto-render-dev{a} x11proto-xext-dev{a}
x11proto-xinerama-dev{a}
0 pacotes atualizados, 42 novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso obter 13,8 MB de arquivos. Depois do desempacotamento, 52,6 MB serão usados.
Os pacotes a seguir possuem dependências não satisfeitas:
libpixman-1-dev: Depende: libpixman-1-0 (= 0.16.4-1) mas 0.24.0-1~bpo60+1 está instalado.
libcairo2-dev: Depende: libcairo2 (= 1.8.10-6) mas 1.10.2-7~bpo60+1 está instalado.
As seguintes ações resolverão estas dependências:

Manter os pacotes a seguir em suas versões atuais:
1) libcairo2-dev [Não Instalado]
2) libcairomm-1.0-dev [Não Instalado]
3) libgtk2.0-dev [Não Instalado]
4) libgtkmm-2.4-dev [Não Instalado]
5) libpango1.0-dev [Não Instalado]
6) libpangomm-1.4-dev [Não Instalado]
7) libpixman-1-dev [Não Instalado]


Aceitar esta solução? [Y/n/q/?] y
Nenhum pacote será instalado, atualizado ou removido.
0 pacotes atualizados, 0 novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso obter 0 B de arquivos. Depois do desempacotamento, 0 B serão usados.
------------------------------------

[5] Comentário enviado por rodcorporation em 05/04/2012 - 06:30h

Oi, você usa Debian ou Ubuntu?

[6] Comentário enviado por hax0r3x em 05/04/2012 - 11:09h

Olá, uso Debian.

$uname -a
Linux hax 2.6.32-5-amd64 #1 SMP Thu Mar 22 17:26:33 UTC 2012 x86_64 GNU/Linux

[7] Comentário enviado por rodcorporation em 09/04/2012 - 20:29h

hax0r3x, tenta instalar o pacote manualmente que está dando conflito.

no caso é libcairo2-dev e o libpixman-1-dev.

#apt-get install libcairo2-dev
#apt-get install libpixman-1-dev

Se apresentar erro, poste aqui.

Abs

[8] Comentário enviado por hax0r3x em 10/04/2012 - 22:35h

Olá,

poisé, não estou com sorte :/

#apt-get install libcairo2-dev
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
libcairo2-dev : Depende: libcairo2 (= 1.8.10-6) mas 1.10.2-7~bpo60+1 está para ser instalado
Depende: libpixman-1-dev (>= 0.12.0) mas não será instalado
E: Pacotes quebrados

[9] Comentário enviado por rodcorporation em 10/04/2012 - 23:19h

To com medo de vc estar usando essa biblioteca por algum outro programa.

O erro é porque ele está tentando instalar a biblioteca libcairo2 porque ele precisa.

Instala a dependencia dele diretamente com:

#apt-get install libcairo2

se der erro posta o resultado do comando

#dpkg -s libcairo2

abs!

[10] Comentário enviado por hax0r3x em 12/04/2012 - 22:06h

Então meu caro, fiz conforme informou e da o seguinte resultado:


--------------------------------------

$ sudo apt-get install libcairo2
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
libcairo2 já é a versão mais nova.
libcairo2 configurado para instalar manualmente.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

$ dpkg -s libcairo2
Package: libcairo2
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 1396
Maintainer: Dave Beckett <dajobe@debian.org>
Architecture: amd64
Source: cairo
Version: 1.10.2-7~bpo60+1
Depends: libc6 (>= 2.11), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.3.5), libpixman-1-0 (>= 0.18.0), libpng12-0 (>= 1.2.13-4), libx11-6, libxcb-render0, libxcb-shm0, libxcb1 (>= 1.2), libxrender1, zlib1g (>= 1:1.1.4)
Breaks: iceape-browser (<= 2.0.3-3), libgtk-directfb-2.0-0, xulrunner-1.9, xulrunner-1.9.1 (<= 1.9.1.8-3)
Description: The Cairo 2D vector graphics library
Cairo is a multi-platform library providing anti-aliased
vector-based rendering for multiple target backends. Paths consist
of line segments and cubic splines and can be rendered at any width
with various join and cap styles. All colors may be specified with
optional translucence (opacity/alpha) and combined using the
extended Porter/Duff compositing algebra as found in the X Render
Extension.
.
Cairo exports a stateful rendering API similar in spirit to the path
construction, text, and painting operators of PostScript, (with the
significant addition of translucence in the imaging model). When
complete, the API is intended to support the complete imaging model of
PDF 1.4.
.
This package contains the shared libraries.
Multi-Arch: same
Homepage: http://cairographics.org/

--------------------------------------

abs



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts