Compilando o Mplayer com suporte a formatos do Windows + rádio no Firefox

Publicado por Fredericco Gomes Ferraz em 09/11/2006

[ Hits: 12.917 ]

 


Compilando o Mplayer com suporte a formatos do Windows + rádio no Firefox



1. Baixando o Mplayer e os codecs para dar suporte a execução de formatos de vídeos fechados como os do Windows e etc.

Baixe a nova versão do Mplayer:
Baixe os codecs (baixe a versão all-********.tar.bz2):
Baixe o skin que mais lhe agradar (no tutorial usaremos o Terminator3):
Baixa as fontes para da suporte gráfico ao Mplayer:
2. Instalando

Descompacte os arquivos:

$ tar -xvjf MPlayer-1.0pre8.tar.bz2
$ tar -xvjf all-20060501.tar.bz2
$ tar -xvjf font-arial-iso-8859-1.tar.bz2
$ tar -xvjf Terminator3-1.1.tar.bz2


Agora criaremos a pasta para a hospedagem dos codecs:

# mkdir /usr/lib/win32

Feito isso copiaremos os arquivos descompactados:

# cd ~/all-20060501
# cp * /usr/lib/win32


Agora compilaremos o Mplayer, não se assuste, esse procedimento demora no máximo 10 minutos:

# cd ~/MPlayer-1.0pre8

A compilação será feita com o suporte ao Mplayer gráfico, o gmplayer, e com o idioma padrão português.

# ./configure --language=pt_BR --enable-gui --withcodecsdir=/usr/lib/win32 --with-win32libdir=/usr/lib/win32

Logo após a checagem de dependências, execute os seguintes passos:

# make && make install

Agora o comando:

# ldconfig

Configurado o Mplayer com suporte gráfico gmplayer:

Com o usuário root crie as pastas:

# mkdir /usr/local/share/mplayer
# mkdir /usr/local/share/mplayer/Skin/


Agora copie a pasta do skin, que no meu caso estava na pasta /home/fred:

# cp /home/fred/Terminator3 /usr/local/share/mplayer/Skin/
# cd /usr/local/share/mplayer/Skin/
# mv Terminator3 default


Vamos arrumar as fontes, escolha a fonte que mais lhe agrada (no meu caso estavam na pasta /usr/X11R6/lib/X11/fonts/TTF/). Como usuário root crie um link simbólico para a fonte usada (no meu caso usei a DejaVuSans.ttf):

# ln -s /usr/X11R6/lib/X11/fonts/TTF/ DejaVuSans.ttf ~/.mplayer/subfont.ttf

Pronto, agora é só executar o mplayer:

$ gmplayer

Para a instalação do plugin para escutar rádio no Firefox:

Para slackers:
Escolha o servidor para download.

E como root instale:

# installpkg mplayerplug-in-3.31-i486-1kjz.tgz

Pronto!

E para pacotes rpm:
Baixe o pacote rpm e o instale.

Eu não sei instalar pacotes RPM porque desde que uso Linux, sempre usei o Slack, então nunca utilizei o utilitário para instalação de RPMs.

Depois de tudo isso você consegue abrir arquivos com formatos do Windows e assistir vídeos pelo Firefox.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Instalando placa de rede onboard P5gc-mx/1333 Atheros Attansic (Atl2) no Fedora 8

ThinStation 2.2d

Configuração do VMware no Fedora Core 5

Usando o tar.xz + várias threads e compactação extrema

Instale Arch Linux em 10 minutos

  

Comentários
[1] Comentário enviado por pedemesa em 09/11/2006 - 09:46h

E onde eu uso o pacote: "font-arial-iso-8859-1.tar.bz2"???

[2] Comentário enviado por fredericco em 09/11/2006 - 20:04h

e pq eu peguei e usei uma font aqui do meu HD mais essa era a que eu ia usar tanto fais !
^^

[3] Comentário enviado por removido em 12/11/2006 - 16:08h

Excelente dica, muito oportuna. Fazia tempo que estava querendo mudar as Skins do Mplayer, porque a que vem por default é horrível.

E respondendo ao colega "Pé", a fonte deve ficar no diretório onde está o subdiretório "skins". No meu caso - uso kurumin - o local é "/usr/share/mplayer".

Abraço,

Caiapó

[4] Comentário enviado por fredericco em 12/11/2006 - 19:21h

vlw

[5] Comentário enviado por rodhash em 19/12/2006 - 11:21h

Erro no comando ./configure

A especificação do diretório de codecs não funciona no Debian (não sei se em outra distribuição funcionou)

Ao invés de
# ./configure --language=pt_BR --enable-gui --withcodecsdir=/usr/lib/win32 --with-win32libdir=/usr/lib/win32

Funcionou
# ./configure --language=pt_BR --enable-gui --with-codecsdir=/usr/lib/win32 --with-win32libdir=/usr/lib/win32

A diferença é um hifen (...with-codecsdir=...)

[6] Comentário enviado por removido em 19/12/2006 - 19:04h

Na linha do ./configure da o seguinte erro:

Error: X11 suport required for GUI compilation.

O que está faltando ? é algum dependencia ?

[7] Comentário enviado por fredericco em 20/12/2006 - 13:58h

VLW rodhash!

elieser_topassi -> esse problema eu nao sei resolver não, vai em /var/log
de uma fuçada nos arquivos e verifica o erro!

aqui no meu pc rolow tudo direitinho!

slack user!


[8] Comentário enviado por Gilardo em 03/09/2007 - 12:29h

Aqui não está rolando, uso madriva 2004, qnd ele está para terminar o ./configure aparece o seguinte erro. Error: The GUI requires GTK devel packages (which were not found). ja busquei esses pacotes, mas continuo não conseguindo instala-los cada vez q vou instalar um pede outro e está bem complicado.

Alguem poderia me ajudar?

[9] Comentário enviado por luisbulek em 14/09/2007 - 12:20h

Instalei legal no Slackware 12, mas perde feio para o Power DVD do windows...além de ter um bug estranho, quando movo a tela do player, o a imagem só fica enquadrada na janela até pouco mais da metade do monitor ? Alguém teve este problema ?



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts