Como instalar o xten-xlite no Linux

Publicado por José Edes Neves em 08/06/2008

[ Hits: 25.891 ]

 


Como instalar o xten-xlite no Linux



Instale e use o xten-xlite no Linux sem precisar chamá-lo pelo terminal com o comando "./xtensoftphone".

Para começar, vamos fazer o download do xten no link:
Obs: O download é gratuito, mas você precisa entrar com seu nome e e-mail. Baixe o arquivo para Linux que está em tar.gz e, para facilitar, salve no home de seu usuário.

Vamos descompactá-lo; abra o terminal de comando e digite "tar -zxvf X-Lite_Install.tar.gz". Agora como root (sudo su) vamos movê-lo para /var/opt com o comando

# mv xten-xlite /var/opt

Vamos criar um executável para ele que aponta para /var/opt/xten-xlite/xtensoftphone.

Digite no terminal:

# gedit

ou qualquer outro editor de sua preferência, copie e cole o conteúdo abaixo; depois salve com o nome de "xten" sem aspas.

#!/bin/sh

cd /var/opt/xten-xlite
./xtensoftphone

Dê permissão de execução com o comando:

# chmod +x xten

Agora vamos movê-lo para /usr/local/bin:

# mv xten /usr/local/bin

Agora é só digitar no terminal:

# xten

Pronto! Para ficar melhor crie um atalho para o menu "Aplicações" ou menu "K" (caso usem KDE). No GNOME usamos o "alacarte" e no KDE o "KDE Menu Editor". Assim:

Alt + F2
alacarte (GNOME)
kmenuedit (KDE)

Alacarte:
  • "Novo item"
  • Tipo: Aplicação
  • Nome: Xten-Xlite
  • Comando: xten
  • Comentário: "o que você quiser".

Se precisar removê-lo, faça no terminal:

# rm -rf /var/opt/xten-xlite
e
# rm /usr/local/bin/xten

Outras dicas deste autor

Webcam no Linux de forma simples

Como instalar o aMSN 0.98 de forma simples no Debian

Como instalar a última versão do jSMS no Linux

Como instalar o StarOffice 8 no Linux

Instalação do navegador Flock no Linux, substituto do Netscape

Leitura recomendada

Montando uma distribuição Linux do zero

Resolvendo problemas com adaptador bluetooth no Ubuntu 9.10

Instalando placa wireless Broadcom BCM4328 no Slackware 12.2

Conecte seu celular Nokia N70 ao OpenSuSE

Baixar e instalar o RAR no Ecth e Gutsy

  

Comentários
[1] Comentário enviado por edes.neves em 15/06/2008 - 22:36h

Se precisar configurar o vono, é o meu caso, aqui está o link http://www.dicas-l.com.br/dicas-l/20060221.php

[2] Comentário enviado por ewlucena em 30/06/2008 - 20:46h

Ola Jose, eu estou tentando instalar o x-lite no ubuntu 8.04, e da um erro quando executo o arquivo xten no terminal, ele procura pela biblioteca - libstdc++.so.5, e não acha, no gerenciador de pacotes também não possui essa biblioteca, vc ou alguem sabe onde achá-la. Obrigado.

[3] Comentário enviado por ewlucena em 30/06/2008 - 23:02h

Ola Pessoal, se alguem tiver problemas para usar o x-lite no ubuntu 8.04, com a biblioteca - libstdc++.so.5, vcs podem instalar via terminal uma biblioteca equivalente para rodar o programa, com esse comando:
# sudo apt-get install libstdc++5

Pelo menos, comigo funcionou.
Fonte: http://www.adrenaline.com.br/forum/showthread.php?t=166347


[4] Comentário enviado por edes.neves em 01/07/2008 - 22:49h

Eudes, se vc ta usando debian e não ta encontrando o libstdc++5 vc tem q adicionar repositório. Eu instalaei no debian, Ubuntu e Kurumim 7 e deu td certo.

[5] Comentário enviado por makicesar em 21/10/2008 - 17:25h

como inciante estou tendo difculdades de instalar o xlite no ubuntu, como varios o tiveram, bom, sendo assim o erro que ocorre e esseE: /var/cache/apt/archives/linux-image-2.6.24-19-generic_2.6.24-19.41_amd64.deb: não foi possível criar link de backup de `./boot/vmlinuz-2.6.24-19-generic' antes de instalar nova versão...


se puderem me ajudar eu agradeço.
obrigado
makicesar

[6] Comentário enviado por victordematos em 03/08/2009 - 22:11h

eu tive o mesmo problema depois de instalado ele dava a seguinte mensagem
./xtensoftphone: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory
então é só colocar os seguintes comandos
sudo apt-get install libstdc++5
e
sudo apt-get install alsa-oss

[7] Comentário enviado por edes.neves em 12/10/2009 - 12:06h

Um jeito + fácil de Criar um atalho.

# gedit /usr/share/applications/xten-xlite.desktop

Na janela q abrir copiar e colar o texto abaixo:

[Desktop Entry]
Comment=Xten-Xlite Voip
Exec=xten
GenericName=Xten-Xlite Voip
Icon=/usr/share/icons/hicolor/scalable/apps/gnome-modem-monitor-applet.svg
Name=Xten-Xlite
Path=
StartupNotify=true
Terminal=0
TerminalOptions=
Type=Application
X-KDE-SubstituteUID=false
X-KDE-Username=
Categories=Network;Application;


Save e feche depois é só encontra-lo em Aplicações, internet... Iso no gnome no kde não sei onde aparece não gosto dele.

[8] Comentário enviado por delete em 28/10/2010 - 18:50h

Ola
coloquei no meu blog um post com o mesmo objetivo, soh abordei de uma forma diferente, vale a pena dar uma olhadinha
la também resolvo o problema da libstdc++5 no ubuntu 10.04
o link para o post é http://www.delete.com.br/instalando-softfone-x-lite-ubuntu/
espero que ajude!



Contribuir com comentário