Como instalar o Oracle Java 7 no Debian via repositório PPA

Publicado por Joao Augusto em 30/06/2012

[ Hits: 49.124 ]

Blog: http://blognu.wordpress.com

 


Como instalar o Oracle Java 7 no Debian via repositório PPA



Boa tarde a todos.

Como todos sabem, o Debian e algumas outras distribuições GNU/Linux não oferecem mais suporte oficial ao Java da Oracle por questões de licenciamento. Pois bem, esta dica vem para ajudar àqueles que estão tendo problemas com Internet banking etc.

Essa dica destina-se à usuários do Debian que desejam instalar e manterem-se atualizados com as últimas versões do Oracle Java 7 (JDK7): o WebUpd8 Java 7 PPA funciona no Debian também, já que o pacote é apenas um instalador e tudo que você tem a fazer é adicionar manualmente o repositório PPA em Fontes de Aplicativos.

Para adicionar o repositório PPA do WebUpd8 Oracle Java para as fontes de aplicativos no Debian (testado em Debian Squeeze 64 bits, mas deve funcionar com qualquer versão do Debian), use os seguintes comandos:

# echo "deb http://ppa.launchpad.net/webupd8team/java/ubuntu precise main" > /etc/apt/sources.list.d/webupd8team-java.list
# echo "deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu precise main" >> /etc/apt/sources.list.d/webupd8team-java.list
# apt-key adv --keyserver keyserver.ubuntu.com --recv-keys EEA14886
# apt-get update
# apt-get install oracle-java7-installer
E é isso, o Oracle Java 7 (ambos JDK7 e JRE7) agora deve está instalado e você deve receber atualizações automáticas com futuras versões do Oracle Java 7, no Debian.

Dica previamente publicada em meu blog:
Até mais.

Outras dicas deste autor

Configurando o sudo no Debian 6 Squeeze

Leitura recomendada

Instalação do Webmin no Debian

Problema no gnome-control-center no Fedora 24

Compartilhamento de pastas no VirtualBox

Jogo Educacional Memória 10

Instalando pacotes .deb no openSUSE Leap 15 via Alien

  

Comentários
[1] Comentário enviado por albertguedes em 30/06/2012 - 16:44h

Blz de dica cara. Valeu :D

[2] Comentário enviado por serph em 04/08/2012 - 19:21h

rapaz, muito obrigado por essa contribuição!
se possível, da uma dica desse tipo pro CentOS também! ;)

[3] Comentário enviado por virtualhjs em 19/09/2012 - 13:33h

Excelente!
Zilhões de procedimentos após o internet banking do meu bando obrigar atualizar o java e nenhum funcionou. Esse resolveu o problema. Filas de banco não me esperem!

[4] Comentário enviado por arimacedo em 20/10/2012 - 07:50h

Muito Bom ...

[5] Comentário enviado por dejalmojardim em 22/10/2012 - 18:45h

Funciona no Debian 7 Wheezy também, alias é a única dica que eu consegui fazer funcionar.

Obrigado.

[6] Comentário enviado por celso.lom em 15/11/2012 - 23:38h

Dica show, funcionou perfeito no Wheezy também. Valeu!

[7] Comentário enviado por marcobage em 14/01/2013 - 23:39h

Muito bom, obrigado!

[8] Comentário enviado por marcobage em 06/02/2013 - 18:57h

Excelente. Obrigado!

[9] Comentário enviado por Hank em 01/03/2013 - 23:07h

Grande dica! Funcionando no Wheezy perfeitamente.

[10] Comentário enviado por andersonsobrado em 05/03/2013 - 10:45h

Show... depois é só digitar no navegador também, para quem usa firefox https://www.mozilla.org/pt-BR/plugincheck/ ,ou http://www.java.com/pt_BR/download/installed.jsp?detect=jre e verá que o plugin atualizou direitinho. Fiz no Debian Wheezy 32 Bits e não ocorreu nenhum erro. Obrigado!

[11] Comentário enviado por edilsonnssilva em 05/06/2013 - 17:32h

até eu quen nuca vi um linux na minha frente consegui essa parabens..........

Edilson Silva

[12] Comentário enviado por jukinha em 10/06/2013 - 09:38h

Fiz o procedimento, nao deu nenhum erro, mas meu chromium ainda n pega o java!

[13] Comentário enviado por pakitao em 10/07/2013 - 17:21h


[12] Comentário enviado por jukinha em 10/06/2013 - 09:38h:

Fiz o procedimento, nao deu nenhum erro, mas meu chromium ainda n pega o java!


Você testou no site do java http://www.java.com/pt_BR/download/installed.jsp, se está funcionando normalmente?

[14] Comentário enviado por Marcus.Macedo em 05/08/2013 - 22:14h


[12] Comentário enviado por jukinha em 10/06/2013 - 09:38h:

Fiz o procedimento, nao deu nenhum erro, mas meu chromium ainda n pega o java!


Verifique se o arquivo libjavaplugin.so está dentro da pasta plugin do chromium. Para localizar a pasta plugins execute o seguinte comando
#find / -name plugins

Ou acesse o diretorio no qual está instalado o Chromium, crie a pasta plugins e copie o arquivo libjavaplugin.so para dentro dela.

[15] Comentário enviado por netstryker em 22/10/2013 - 14:58h

Valeu Joao Augusto!

Sua dica foi de grande utilidade. Fiz aqui no meu Debian Wheezy 7.1 e funcionou perfeitamente!

Parabéns pela valiosa dica!

[16] Comentário enviado por pakitao em 22/10/2013 - 15:51h


[15] Comentário enviado por netstryker em 22/10/2013 - 14:58h:

Valeu Joao Augusto!

Sua dica foi de grande utilidade. Fiz aqui no meu Debian Wheezy 7.1 e funcionou perfeitamente!

Parabéns pela valiosa dica!


Valeu, e obrigado. No meu também funcionou normalmente.

[17] Comentário enviado por eliel.pires em 30/10/2013 - 18:46h

MEU CARO FIZ OS PROCEDIMENTOS E TIVE UM ERRO ACHO QUE FUI O ÚNICO MAS SE VOCÊ PUDER ME AJUDAR AGRADEÇO MUITO, TENHO O DEBIAN WHEEZY 7.2 E ABAIXO ESTÁ O ERRO

root@Engenharia2:/etc/apt# echo "deb http://ppa.launchpad.net/webupd8team/java/ubuntu precise main" > /etc/apt/sources.list.d/webupd8team-java.list
root@Engenharia2:/etc/apt# echo "deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu precise main" >> /etc/apt/sources.list.d/webupd8team-java.list
root@Engenharia2:/etc/apt# apt-key adv --keyserver keyserver.ubuntu.com --recv-keys EEA14886
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.ygEn7WAPgj --trustdb-name /etc/apt//trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-wheezy-stable.gpg --keyserver keyserver.ubuntu.com --recv-keys EEA14886
gpg: requesting key EEA14886 from hkp server keyserver.ubuntu.com
gpg: key EEA14886: public key "Launchpad VLC" imported
gpg: Número total processado: 1
gpg: importados: 1 (RSA: 1)
root@Engenharia2:/etc/apt# apt-get update
E: Tipo '' não é conhecido na linha 1 na lista de fontes /etc/apt/sources.list
E: A lista de fontes não pode ser lida.
root@Engenharia2:/etc/apt# apt-get install oracle-java7-installer
Lendo listas de pacotes... Erro!
E: Tipo '' não é conhecido na linha 1 na lista de fontes /etc/apt/sources.list
E: A lista de fontes não pode ser lida.
E: As listas de pacotes ou os arquivos de estado não puderam ser analisados ou abertos.
root@Engenharia2:/etc/apt#

POR FAVOR PRECISO DE AJUDA. OBRIGADO

[18] Comentário enviado por pakitao em 30/10/2013 - 19:03h


[17] Comentário enviado por eliel.pires em 30/10/2013 - 18:46h:

MEU CARO FIZ OS PROCEDIMENTOS E TIVE UM ERRO ACHO QUE FUI O ÚNICO MAS SE VOCÊ PUDER ME AJUDAR AGRADEÇO MUITO, TENHO O DEBIAN WHEEZY 7.2 E ABAIXO ESTÁ O ERRO

root@Engenharia2:/etc/apt# echo "deb http://ppa.launchpad.net/webupd8team/java/ubuntu precise main" > /etc/apt/sources.list.d/webupd8team-java.list
root@Engenharia2:/etc/apt# echo "deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu precise main" >> /etc/apt/sources.list.d/webupd8team-java.list
root@Engenharia2:/etc/apt# apt-key adv --keyserver keyserver.ubuntu.com --recv-keys EEA14886
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.ygEn7WAPgj --trustdb-name /etc/apt//trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d//debian-archive-wheezy-stable.gpg --keyserver keyserver.ubuntu.com --recv-keys EEA14886
gpg: requesting key EEA14886 from hkp server keyserver.ubuntu.com
gpg: key EEA14886: public key "Launchpad VLC" imported
gpg: Número total processado: 1
gpg: importados: 1 (RSA: 1)
root@Engenharia2:/etc/apt# apt-get update
E: Tipo '' não é conhecido na linha 1 na lista de fontes /etc/apt/sources.list
E: A lista de fontes não pode ser lida.
root@Engenharia2:/etc/apt# apt-get install oracle-java7-installer
Lendo listas de pacotes... Erro!
E: Tipo '' não é conhecido na linha 1 na lista de fontes /etc/apt/sources.list
E: A lista de fontes não pode ser lida.
E: As listas de pacotes ou os arquivos de estado não puderam ser analisados ou abertos.
root@Engenharia2:/etc/apt#

POR FAVOR PRECISO DE AJUDA. OBRIGADO


Já tentou abrir o arquivo /etc/apt/sources.list e vê essa '' na linha 1?

[19] Comentário enviado por oliviofarias em 31/10/2013 - 11:59h

Muito obrigado pela dica. Funcionou perfeitamente.
Não estava conseguindo abrir a minha página do banco do brasil por causa do java.
Agora está tudo redondinho. Valeu parceiro. Vou favoritar pro senhor ganhar 100pts. (y)

[20] Comentário enviado por sonny em 29/01/2014 - 17:12h

Valeu companheiro muito obrigado

[21] Comentário enviado por smallboy em 06/04/2014 - 11:56h

NO meu Linux Mint Debian Edition instalou sem problemas, sem erros.

Não mudei nada, so adicionei nos repositorios os links sem usar o echo pra enviar, adicionei manualmente.

lmde-540 ~ # java -version
java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)
lmde-540 ~ #


Valeu, hugs

[22] Comentário enviado por marcobage em 28/05/2014 - 12:37h

Muito bom, obrigado...

[23] Comentário enviado por ramcorreio em 26/10/2014 - 02:30h

Muito bom!!!!
Para ficar como default eu coloco o seguinte comando ainda: apt-get install oracle-java7-set-default



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts