C compiler Cannot create executable?

Publicado por Frederico Costa em 08/07/2004

[ Hits: 44.090 ]

 


C compiler Cannot create executable?



Uma dica rápida:

Se, ao tentar compilar um programa no Kurumin, Knoppix ou Debian receber a mensagem:

"checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
make: *** [configure-stamp] Error 77"

Basta instalar o compilador g++ com o comando:

# apt-get install g++

e o problema está resolvido...

Have Phun!
Outras dicas deste autor

Substituto do dreamweaver

Leitura recomendada

MDK (Mix Development Kit) no Projeto GNU

Compilar programas em C no Ubuntu com o gcc

Compilando no Debian Wheezy 7.5

Autoestudo e certificação C/C++

Inserindo e removendo comentários em C/C++ de forma rápida no VIM

  

Comentários
[1] Comentário enviado por removido em 08/07/2004 - 19:53h

Obrigado pela dica!!!

[2] Comentário enviado por lucnog em 23/02/2005 - 17:30h

Outra possivel saida eh :

Apt-get install lib6c-devel

dai tente a compilacao novamente.

[3] Comentário enviado por _matchbox_ em 24/01/2006 - 22:16h

muito boa a dica.. deu certo aqui... ;)

[4] Comentário enviado por binoS em 06/04/2006 - 10:31h

como faço para instalar automaticamente as dependencias ?

[5] Comentário enviado por rafaeliga em 15/05/2006 - 08:49h

corrigindo o comentário do lucnog, o pacote(pelo menos no meu Ubuntu) é:
libc6-dev

[6] Comentário enviado por santoskywalker em 07/06/2006 - 17:52h

E se for rpm????

To usando um blag uma distro recomendada no site da fsf, mas que ta me dando trabalho por não ter prática com rpm.

Abraços.

santo

[7] Comentário enviado por anasofiapaixao em 17/06/2006 - 15:08h

Registei so para te dizer: OBRIGADÃO! Isto salvou-me de uma séria dor de cabeça..

[8] Comentário enviado por nosbor84 em 29/06/2006 - 17:19h

aaaaa... eu já p da vida com meu ubutun... essa sua dica foi simplesmente providencial viu... valeu garoto!

[9] Comentário enviado por eduveks em 19/08/2006 - 10:34h

Valew... esta dica acabou de me dar mais esperanças!!!

Este erro podia ser bem mais intuitivo... mas erro é erro e não é pra ser intuitivo né!?

Pra que facilitar se pode complicar...

[10] Comentário enviado por fredy10 em 12/03/2007 - 10:38h

Excelente! funcionou perfeitamente aqui no ubuntu. Obrigado pela dica!

[11] Comentário enviado por alyssonmarques em 18/03/2007 - 18:39h

Obrigado!

[12] Comentário enviado por anselmoborges em 21/03/2007 - 00:29h

Meuuu!!!

Deus abençõe vc e toda sua familia!!!
hauhauhauhauha

Obrigado!!!

[13] Comentário enviado por anselmoborges em 21/03/2007 - 00:30h

ih num eh q foi mesmo!!!
hauhauhauhuahuahuha

[14] Comentário enviado por deveras em 26/03/2007 - 13:41h

Essa dica foi ótima, pois me ajudou com o problema citado no mesmo. vlw!

[15] Comentário enviado por lucas.suporte em 16/05/2007 - 16:26h

Cara valeu estava com esse problema aqui e eu tentei compila o gcc de novo para corrigir esse erro e a mensagem foi a mesmo [*****] né!!!!
A sua dica me ajudou muito obrigado brother!!
Abraços

[16] Comentário enviado por a.gustavo em 24/05/2007 - 14:06h

Tb consegui, valeu a dica...

[17] Comentário enviado por fabiobenevides em 19/09/2007 - 01:58h

Vle Kara Funcionou mesmo!

[18] Comentário enviado por lazaro91 em 29/09/2007 - 09:59h

Galera pra quem usa Ubuntu é mais fácil usar o cd

é só depois de abrir o cd ir na pasta pool do cd e procurar que lá tem os packages necessários para deixar o gcc tinindo

Vlw

[19] Comentário enviado por dnrcosta em 01/10/2007 - 22:14h

É meu brother esta sua dica realmente salvou a parada de muita gente, inclusive a minha. Valeu!!!

[20] Comentário enviado por cassimirinho em 02/11/2007 - 01:00h

?comentario=Valeu, estava queimando neurônios atrás dessa solução e deu certo no meu ubuntu.

[21] Comentário enviado por cassimirinho em 09/11/2007 - 15:51h

Valeu, já aconteceu comigo várias vezes esse erro ao fazer um ./configure pra instalar sw.

[22] Comentário enviado por luizrosalba em 11/11/2007 - 02:08h

nas coisas mais simples as maiores dificuldades hehehe valeu mesmo !

[23] Comentário enviado por madurinho em 20/12/2007 - 16:07h

?comentario=Brother resolveu meu problema, muito obrigado

[24] Comentário enviado por removido em 30/12/2007 - 22:07h

Hm, problema resolvido!
Muito obrigado!

[25] Comentário enviado por maninhx em 18/01/2008 - 14:21h

pra mim não resolveu. continua o erro.

[26] Comentário enviado por winchester em 25/01/2008 - 16:42h

VALEU!!!

[27] Comentário enviado por maikellt em 03/03/2008 - 09:55h

Resolveu o meu problema, valeu!!!!

[28] Comentário enviado por danfox10 em 16/03/2008 - 07:37h

Obrigado pela Dica.

[29] Comentário enviado por vinidog em 13/04/2008 - 23:44h

Valew Mano!

[30] Comentário enviado por maupos em 15/04/2008 - 14:06h

VALEU!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

[31] Comentário enviado por g0han em 18/07/2008 - 11:17h

se voce estiver no Conectiva vai uma boa dica para solucionar este mesmo problema:

# apt-get install glibc glibc-devel

(;

[32] Comentário enviado por thas em 03/10/2008 - 20:59h

Obrigado pela dica..

[33] Comentário enviado por osmano807 em 22/10/2008 - 10:37h

Prefiro no Arch Linux

pacman -S base-devel

[34] Comentário enviado por overlock em 05/11/2008 - 08:39h

kra VALEW

finalmente consegui usa o ./configure make make install

abraços!!!

[35] Comentário enviado por removido em 10/11/2008 - 12:12h

obrigado pela ajuda.

[36] Comentário enviado por d.benette em 10/11/2008 - 17:20h

Muito Obrigadoooo

[37] Comentário enviado por mmacoli em 19/11/2008 - 19:52h

Cara vlw mesmo, me poupou muito tempo!!!
Obrigado e continue sendo sólidario assim!!! parabéns

[38] Comentário enviado por ricardotecinfor em 27/01/2009 - 17:41h

Cara vlw mesmo, me poupou muito tempo!!!
Obrigado e continue sendo sólidario assim!!! parabéns

[39] Comentário enviado por Johnnydsa em 22/01/2011 - 21:21h

root@johnny-desktop:/home/johnny/Área de Trabalho/foobillard-3.0a# apt-get install g++
Lendo lista de pacotes... Pronto
Construindo árvore de dependências
Reading state information... Pronto
Os pacotes extra a seguir serão instalados:
g++-4.1 libc6-dev libstdc++6-4.1-dev linux-libc-dev
Pacotes sugeridos:
g++-multilib g++-4.1-multilib gcc-4.1-doc glibc-doc manpages-dev
libstdc++6-4.1-doc
Os NOVOS pacotes a seguir serão instalados:
g++ g++-4.1 libc6-dev libstdc++6-4.1-dev linux-libc-dev
0 pacotes atualizados, 5 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso fazer o download de 0B/7669kB de arquivos.
Depois de desempacotar, 31,0MB adicionais de espaço em disco serão usados.
Quer continuar [S/n]? S
Troca de mídia: por favor insira o disco nomeado
'Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)'
no drive '/cdrom/' e pressione enter

[40] Comentário enviado por maiconpsb em 03/04/2013 - 10:20h

ola alguem pode me ajudar com esse erro to tentando instalar o gcompris 12.11. td ocorre bem até a parte de ./configure que ocorre o seguinte erro.


error: Package requirements ( gtk+-2.0 >= 2.12.0 librsvg-2.0 >= 2.26.0 libxml-2.0 >= 2.6.16 gthread-2.0 ) were not met:

Requested 'librsvg-2.0 >= 2.26.0' but version of librsvg is 2.22.2



ja pesquisei mais não tive sucesso se alguem puder me ajudar agradeço obrigado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts