Atualizar para Windows 10 com GNU/Linux instalado (dual boot)

Publicado por Francisco Junior em 10/08/2015

[ Hits: 27.250 ]

 


Atualizar para Windows 10 com GNU/Linux instalado (dual boot)



Galera,

Estou postando essa dica pois, assim como grande parte de vocês, possuo GNU/Linux e Windows em dual boot, porém eu estava com dúvidas se com a atualização para o Windows 10 ia "ferrar" com meu Linux, já que vi alguns artigos dizendo que o Windows 10 não aceita dual boot...

Enfim, acabei arriscando, atualizei do Windows 8.1 para o 10 e o GRUB e o Linux funcionaram normalmente.

Então se alguém estava pesquisando isso e não achou, aqui dou essa dica. Podem atualizar sem medo. Uso Linux Mint.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Instalando pacotes no sidux

Instalando Java no Ubuntu 8.04 para desktops

Instalando o Gnome 2.26 no Slackware 13.0 com 4 comandos

Como instalar e desinstalar o VMWare Player no Linux

Instalando o Visual Studio Code no Fedora 27

  

Comentários
[1] Comentário enviado por alevian em 10/08/2015 - 15:13h


Olá, amigo!

Sem dúvida, muitas pessoas utilizam "dual boot" ou até "boot" múltiplo.
Eu mesmo acho conveniente manter o outro $istema, para "casos emergenciais". Recentemente comprei um simples aparelho LG (L35) - "smartphone". Não tivesse eu o outro $istema ficaria bastante apreensivo na procura das respostas que eu precisava, no mundo GNU Linux.

Não sei se vou atualizar para o W10. E também fiquei com essa dúvida.

Até imaginei que, pelo fato de haver versões preliminares já há algum tempo, o pessoal da distribuição deveria ter feito o acerto.

Mas ainda tenho algumas dúvidas.

Você disse ter feito o ajuste no W8. Provavelmente em uma máquina com UEFI/EFI.
Será que funciona da mesma forma com a velha bios?

E, além disso, não foi preciso dar nem um "update-grub" para o grub reconhecer o 10?
(será que prepararam o grub para interpretar 7 e 8 como se fosse um 10?)

Vou tentar fazer em minha máquina com bios.
Na outra, com UEFI, pra ser sincero, ainda faço o dual boot teclando F2 e escolhendo Ubuntu ou Windows. É meio trabalhoso, mas como raramente uso Windows...

Grato pela dica!

[2] Comentário enviado por ramonfontes em 10/08/2015 - 22:10h

Fiz atualização em notebook de minha esposa e tive problemas. O primeiro foi que em um dos momentos da reinicialização durante a atualização, nem o próprio windows iniciava para concluir o processo de atualização (tive que utilizar o bootrepair). Após utilizar o bootrepair o Windows foi atualizado, mas até o momento não consegui recuperar o grub. Ouvi falar que o testdisk resolveria o problema no Windows, mas ainda não tive sucesso. O bootrepair não consegue identificar a partição do Linux e o testdisk até consegue, mas sem êxito ainda na recuperação da partição. :( (e falar que quase atualizo a minha máquina dias antes. Estaria ferrado!!)

[3] Comentário enviado por xikko em 10/08/2015 - 22:20h

Alevian, Na verdade no grub aparece o antigo w8 mas o w10 foi instalado corretamente. Minha máquina tem UEFI. Não tentei ainda na bios antiga. Ramonfontes, você possuía Windows 7? Sua bios é UEFI? No meu caso o Windows ficou algum tempo em tela preta, mas depois de um bom tempo voltou ao normal. Como foi o processo?

[4] Comentário enviado por alevian em 10/08/2015 - 23:44h


Realmente, a questão não parece simples.

O Windows tem essa questão de ligar e desligar na hora de atualizações. Então, é preciso que o grub esteja preparado para fazer voltar no último sistema operacional acessado (ou distribuição).

Faço isso da seguinte forma:
1 - acessar, como root e com um editor como o Gedit, o arquivo etc/default/grub;
2 - alterar, neste arquivo, a entrada - de GRUB_DEFAULT=0 para GRUB_DEFAULT=saved;
3 - inserir, abaixo desta linha alterada, a entrada GRUB_SAVEDEFAULT=true;
4 - salvar o arquivo;
5 - mandar um update-grub;

Copiei a ideia de um site nacional
(http://www.prminformatica.com.br/2013/02/configurando-o-grub2-no-debian-squeeze.html)

Só que não funcionava, até eu inserir a linha indicada no "item 4", acima mencionado, que peguei em um site gringo.

(Na ocasição, cheguei até a botar o comentário, no site prminformatica, mas depois eles mudaram a estrutura do site e não trouxeram os comentários.

Ainda fiquei com duas dúvidas:
1 - No grub continua w8, mas ele consegue fazer subir o w10?
2 - Não foi preciso dar update-grub?

(curioso!)

[5] Comentário enviado por xikko em 10/08/2015 - 23:57h

Bacana essa sua dica!
Respondendo suas perguntas, sim, aparece Windows 8 no grub porém inicia w10 normalmente. Ainda não executei um update-grub, porém não foi preciso. Não quis faze-lo com medo de quando atualizasse o grub desse bug, mas talvez quando atualizar apareça w10, mas isso não me incomoda muito rsrss

[6] Comentário enviado por Z3R0-2020 em 12/08/2015 - 15:19h

Sou novo no uso do dual boot, comprei um novo hd pro meu note e aproveitei para instalar os dois SOs. Porém após a atualização permaneceu o dual boot. O problema que verifiquei é que ao dar boot pelo Ubuntu não consigo acessar a partição Win7 e a partição dados (usadas para compartilhar os arquivos entres os dois sistemas.

Um abraço.



[7] Comentário enviado por rkaiber em 12/08/2015 - 17:59h


Olá, acabo de tentar atualizar para o windows 10 o note, mas deu pane no grub.

agora só inicia e fica com o grub rescue>

alguma dica dica de como sair daqui?

ja usei ls (hd0) e em todas partições dá a msg (unknow system)

[8] Comentário enviado por megasirius em 13/08/2015 - 01:42h

Bom dia rkaiber! Conseguir resolver esse mesmo problema que você citou no comentário acima, seguindo os passos que estão nesse linkin que segue logo abaixo: " http://www.vivaolinux.com.br/dica/Como-recuperar-o-GRUB-em-3-comandos-Esse-funciona ". Aqui deu certo quando usava outras distribuições dual boot e agora também resolveu, Boa sorte!


[9] Comentário enviado por rkaiber em 13/08/2015 - 15:59h

Acabo de tentar megasirius! Mas também não deu certo da uma msg alredy monted ou /mnt busy. acredito que seja porque eu havia mexido no grub para deixar o windows como padrão de inicialização, mas acho que terei que formatar e vou perder todos os dados que tinha. Muito Obrigado

[10] Comentário enviado por lula_molusco em 14/08/2015 - 18:43h

Fiz o update do grub aqui e aparentemente não tive problemas. Ainda aparece win7 no GRUB mas o Win10 inicia normalmente. Fui ter problemas ao tentar acessar os dados do Windows 10 pelo Linux, que antes fazia normalmente, mas agora aparece a seguinte mensagem de erro:

Error mounting /dev/sda1 at /media/daniel/D226FAAA26FA8F2B: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda1" "/media/daniel/D226FAAA26FA8F2B"' exited with non-zero exit status 14: Windows is hibernated, refused to mount.
Failed to mount '/dev/sda1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Pedindo para eu montar de novo, mas fiz isso e ainda continua esse erro :/

[11] Comentário enviado por Jbaf em 30/08/2015 - 05:02h

Bom dia,

Também atualizei aqui e foi sem erros. Só funciona bem com micros novos. Os antigos darão problemas. Win7 para win10 + linux.

Att,
Jbaf 2015
Mageia 5(KDE), Fedora 21(GNOME)
http://www.mageia.org/pt-br/5/

[12] Comentário enviado por Fleet em 25/09/2015 - 01:25h


Deu certo aqui em um netbook EeePC, Atom dual core 2GB de ram com Windows 7 e bios, dual boot com Linux Mint Xfce. O Grub se manteve nas 4 reinicializações, uma de boot outra dos arquivos, outra de drives e na última configurações. O Grub identifica como Windows 7 a partição atualizada com o 10.

[13] Comentário enviado por HugoCastelani em 16/11/2015 - 19:38h

Testaram do Windows 7 para o 10? Estou usando o Grub e Ubuntu.

[14] Comentário enviado por rjsamir em 22/11/2015 - 14:49h

Tive exatamente o mesmo problema que "lula_molusco":

Error mounting /dev/sda5 at /media/samir/Arquivos: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda5" "/media/samir/Arquivos"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda5': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Já tentei várias dicas de montagem, mas ainda não consegui.

resuntado do comando fdisk -l

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
/dev/sda2 206848 204853247 102323200 7 HPFS/NTFS/exFAT
/dev/sda3 204853248 409704447 102425600 7 HPFS/NTFS/exFAT
/dev/sda4 409708542 976771071 283531265 f Win95 (LBA) Partição Extendida
/dev/sda5 409708544 700468650 145380053+ 7 HPFS/NTFS/exFAT
/dev/sda6 960000000 976771071 8385536 82 Linux swap / Solaris
/dev/sda7 700469248 959995903 129763328 83 Linux

Se alguém souber, agradeceria muuuito!


[15] Comentário enviado por camposvet em 03/12/2015 - 11:02h


Olá Francisco Junior, Obrigado pelo post, eu estava com estava dúvida, mas depois que vi teu post tomei coragem e atualizei para o Windows 10 hehe. Tenho um i5 4a geração com 16Gb e nele estava instalado o Windows 8.1 com Windows Media Center, a instalação ocorreu normalmente para o Windows 10 Pro e o computador deve ter reinicializado umas 4 ou 5 vezes. O medo inicial era perder o dual-boot e ter que fazer/usar o grub-rescue. Mas logo na primeira reinicialização já ocorreu tudo bem. O tempo total de instalação foi cerca de duas horas e todos os arquivos antigos estavam presentes após a instalação. Ah, ainda tem a opção de retornar para o Windowns 8.1 caso o usuário não goste do Windows 10. Sobre este último, confesso que esperava mais, demora para carregar e desligar e ainda fica muito lento nas atualizações...qdo será que a Microsoft vai apreender a fazer um sistema descente...bom, neste caso temos o Linux e Viva o linux hehe

[16] Comentário enviado por mbaal em 12/01/2016 - 14:59h

Olá lula_molusco, tive o mesmo problema por aqui ao tentar acessar os arquivos no Windows.

Resolvi no Painel de Controle:
"Painel de Controle\Hardware e Sons\Opções de Energia"
Clique em "Escolher a função dos botões de energia"

Desativei a opção (quase no final da tela):
"Ligar a inicialização rápida (recomendado)"
(Para acessar essa opção em alguns casos é necessário autorizar, na própria tela,
as atualizações clicando em "Alterar as configurações não disponíveis no momento"

Repetindo, desmarquei o checkbox da opção acima. Fazendo essa modificação parece
que o Windows encerra completamente o sistema (operacional e de arquivos).
Isso me permitiu ver o sistema de arquivos do Windows10 a partir do Ubuntu.

Valeu

[17] Comentário enviado por mikaelmessias em 15/01/2016 - 04:13h

O que funcionou pra mim, na verdade foi algo bem simples: inicie o Windows, abra o cmd com direitos de admnistrador e digite shutdown /s. Depois inicie o Ubuntu e você já vai conseguir acessar os arquivos da partição Windows. \o/

[18] Comentário enviado por luismail em 27/05/2016 - 10:57h

Galera,
vou referir o que me aconteceu:
cansei de apagar os arquivos de atualização do win 10 e resolvi tentar ; possuo um note samsung RV411 com 3 SO instalados: Mint , Debian e Win 7.
Fiz a atualização , para a minha surpresa o GRUB ficou e reconhecia o win 10 como o seven.
mas qdo logava no win10 a tela ficava na janelinha ( agora e a janelinha...)e nao continuava a instalaçao , apos duas tentativas , pesquisei e dei de cara com problemas do meu modelo e a placa do wifi , nao acreditando retirei a placa e pasmem a instalação continuou normarrr e o GRUB presente , terminou dei boot e me loguei em cada SO sem problemas , feliz ate que fui atualizar os dados do avast nesse momento ao reinicializar ,Bill de janela , nem baixando duas vezes o ISO da propria MS consegui recuperar a instalação e assim parti pra reinstalar o win7 e tudo voltou ao normal ( creio) . nao sei se fiz algum procedimento errado mas alguma bruxaria gatesiana foi presente . Por enquanto nada de MS, fiquei desconfiado e irritado com tudo isto

[19] Comentário enviado por katiusca em 17/06/2016 - 02:46h

Gente eu atualizei, não tive problema nenhum.
Só tem um detalhe, você tem que acompanhar a atualização para que toda vez que o computador reiniciar seja feito a escolha manualmente do sistema windows. No meu funcionou perfeitamente.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts