Athansic Ethernet L2 Mbit no Linux

Publicado por Pedro Fernandes Steimbruch em 17/10/2008

[ Hits: 7.158 ]

 


Athansic Ethernet L2 Mbit no Linux



Resolvi escrever essa dica depois de notar, nas comunidades aqui do VOL, a quantia de pessoas que estão com dificuldade para a configuração dessa placa.

São pequenos e poucos passos para você conseguir colocar essa placa funcionando de maneira perfeita.

Primeiro, baixe o módulo da placa:

Download atl2-2.0.5.tar.bz2

Depois de baixar, descompacte-o e compile:

# tar jvxf atl2-2.0.5.tar.bz2
# cd atl2-2.0.5
# make all


Copie o módulo para o diretório dos módulos do kernel:

# cp atl2.ko /lib/modules/`uname -r`/kernel/drivers/net

Depois de copiar execute o depmod e depois carregue o módulo:

# depmod -a
# modprobe atl2


Simples, rápido e eficaz.

Agora sua placa funciona. ;)

[]'s Pedro Fernandes Steimbruch.

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Instalei o FreeBSD e esqueci a senha de root

Definindo um wallpaper no Fluxbox

Samba 4 - Desabilitando suporte a impressoras (CUPS)

Atualizando Linux Mint 18.1 para Linux Mint 18.2

Tela gráfica de configuração do Samba

  

Comentários
[1] Comentário enviado por virusvoador em 08/12/2008 - 18:45h

fiz conforme mostra, porem qdo procuro o arquivo atl2.ko , nao encontro ele na pasta atl2, nem na pasta src,
e sem achar ele, qdo dou o comando:
#make all
#make -C /lib/modules2.6.24-etchnhalf.1-686/build SUBBDIRS=/home/samba/drivers/atl2-2.0.5 modules
make: *** /lib//modules/2.6.24-etchnhalf.1-686/build: arquivo ou diretorio nao encontrado. Pare.
make: ** [all] erro2

o q será q falta?!!

agradeço desde ja...

[2] Comentário enviado por virusvoador em 10/12/2008 - 14:01h

ENTAO... agora funcionou conforme esta descrito no tutorial,
qdo dou os comandos
# depmod -a
# modprobe atl2
Atheros (R) L2 Ethernet Driver - version 2.0.5
Copyright (c) 2007 Atheros corporation

aparentemente tudo 100%

mas qdo dou um ifconfig eth1, me retorna
eth1: erro obtendo informacoes da interface: %s: dispositivo nao encontrado.

-----

Para poder atualizar a maq, eu instalei uma placa de rede off, enl832 tx-rent que esta na eht0

-----

QUERO QUE:
A PLACA ON BOARD, FIQUE COMO ETH0, e a off board como ETH 1..

COMO ALTERAR?!!
E COMO FAZER PARA QUE ESTE MICRO RECONHECA AS DUAS?!!!

sem mais,

agradeco desde ja,...

[3] Comentário enviado por removido em 07/12/2009 - 11:51h

quando executo o make clean modules, me apresenta este erro.

make -C src/ clean
make[1]: Entering directory `/usr/home/admin/r8101-1.007.00/src'
rm -rf *.o *.ko *~ core* .dep* .*.d .*.cmd *.mod.c *.a *.s .*.flags .tmp_versions Module.symvers Modules.symvers rset
make[1]: Leaving directory `/usr/home/admin/r8101-1.007.00/src'
make -C src/ modules
make[1]: Entering directory `/usr/home/admin/r8101-1.007.00/src'
make -C /lib/modules/2.6.25.9-smart/build SUBDIRS=/home/admin/r8101-1.007.00/src modules
make: *** /lib/modules/2.6.25.9-smart/build: No such file or directory. Stop.
make: Entering an unknown directorymake: Leaving an unknown directorymake[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/home/admin/r8101-1.007.00/src'
make: *** [modules] Error 2


Alguém pode me ajudar?



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts