Arch Linux - Erro: PulseAudio não carrega, mas drivers e ALSA estão funcionando [Resolvido]

Publicado por Rogério M. de Queiroz em 12/02/2015

[ Hits: 5.321 ]

 


Arch Linux - Erro: PulseAudio não carrega, mas drivers e ALSA estão funcionando [Resolvido]



Recentemente tive uma crise nostálgica dos meus tempos de faculdade, então decidi instalar uma distro voltada para "experts". Desde o momento da instalação, até a configuração da mesma (na facul, o Slackware e o FreeBSD eram as distros preferidas).

Então resolvi instalar o Arch Linux.

Em modo texto, o som funciona normalmente, mas o PulseAudio não iniciava. Aí já viu né, quando se instala um ambiente gráfico, no meu caso o GNOME Shell 3.14.3, o configurador de saída/entrada de áudio/atalhos do teclado de volume não funcionaram.

Possível solução: ao executar o comando:

pulseaudio -v

E obtiver algo como:

E: [pulseaudio] module.c: Module "module-switch-on-connect" should be loaded once at most. Refusing to load.

Basta abrir o arquivo /etc/pulse/default.pa e comentar a(s) linha(s) que contiver(em) o seguinte texto, ficando como abaixo:

# load-module module-switch-on-connect

Salve o arquivo, reinicie o computador/notebook e os controles de som do GNOME 3 funcionarão.

Fonte de inspiração:
Outras dicas deste autor

Instalando Dropbox no ElemenaryOS 0.4 (LOKI)

Fedora não disponibiliza resoluções 16:9 (ex.: 1900x1080) [Resolvido]

Limpou logs, limpou apt, limpou tudo que podia e o espaço em disco está pouco?

Teclado ABNT2 em modo texto no Slackware 10

Leitura recomendada

Traduzir Firefox 12 no Linux

Baixando músicas com o gSharkDown

Onde está o autopackage?

Vídeo aula: Como converter vídeo (.ogg) para (.flv) com Kino

Configurar aMSN para minimizar na bandeja no Linux

  

Comentários

Nenhum comentário foi encontrado.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts