Após instalação do Windows o Grub some?

Publicado por Renato César Néspoli de Almeida em 02/02/2009

[ Hits: 8.370 ]

 


Após instalação do Windows o Grub some?



Bom, me deparei com este problema pois uso dual-boot. Houve a necessidade de formatar o Windows e já tinha instalado o Ubuntu 8.10. Assim o Grub some da MBR e não pode fazer boot no Linux.

Para solução usei o CD de instalação do Ubuntu 8.10, pois ele permite boot sem modificar o hd. Assim abri um terminal e usei seguintes comandos:

sudo grub
> find /boot/grub/menu.lst
> root (hdx,y)
> setup (hdx)
> setup (hdx,y)

Até mais!
;)

Outras dicas deste autor
Nenhuma dica encontrada.
Leitura recomendada

Script para instalação do Fluxbox no Void Linux

Efetuando varreduras de rede com o nmap

Unity - Atalhos para captura de tela

Copiando arquivos usando netcat e tar

Autostart no GNOME

  

Comentários
[1] Comentário enviado por fulllinux em 03/02/2009 - 00:16h

Simpler e eficiente, muito bom...

[2] Comentário enviado por removido em 03/02/2009 - 11:16h

O comando gub-install também quebra um galho nesta ;)
Muito bom...

[3] Comentário enviado por nukelinux em 03/02/2009 - 19:22h

eu costumo usar a seguinte sequencia:

# grub-install hd0
# update-grub

ele auto-detecta os sistemas instalados e gera o menu.lst; bem prático....

uso ele pq sempre faço mudanças no hd e o grub antigo "perde a validade"

[4] Comentário enviado por Rafaell em 03/02/2009 - 20:28h

Também uso o Ubuntu 8.10 e uma vez tive que formatar o Windows. Usei essa dica e também deu certo!

"Com um LiveCD do Ubuntu abra um terminal (Aplicações -> Acessórios -> Terminal) e digite:
1 - sudo fdisk -l
Você verá com este comando todas as partições disponíveis no seu computador.
Agora monte a partição que possui o seu Ubuntu.
2 - sudo mount -t ext3 /dev/sda5 /mnt
NÃO esqueça de trocar ext3 pelo tipo de partição (reiserfs, ext2, ext3, xfs) e sda5 pela
partição onde você instalou o Ubuntu!
Com a partição montada, chega a hora de recuperar o Grub
3 - sudo grub-install --root-directory=/mnt /dev/sda "

[5] Comentário enviado por JulioCD em 12/02/2009 - 03:25h

Uso Ubuntu e tive problemas com o grub. Usei esta mesma sequência, mostrada também pelo Morimoto. É a única que funcionou. As outras dicas dadas nos comentários não funcionaram.

[6] Comentário enviado por removido em 20/08/2011 - 15:52h

Parabens pelo post Rafaell funcionou seguindo exatatamente na ordem como especificou!



Contribuir com comentário