3DSP Wireless Driver no notebook Microboard Ultimate Black - 64bits

Publicado por Diego Alves em 08/02/2010

[ Hits: 42.433 ]

 


3DSP Wireless Driver no notebook Microboard Ultimate Black - 64bits



Bom, estava procurando o driver de rede sem fio da placa 3DSP para uma plataforma 64 bits e, como sempre ,quem muito procura... acha!

Então, como na minha pesquisa não encontrei nada postado, aqui vai a dica: para aqueles que possuem um Ultimate Microboard com placa de rede 3DSP Wireless, é possível baixar diretamente do fabricante a versão para plataformas 64 bits, mais precisamente a versão Ubuntu9.10 Beta(2.6.31-14-generic)(64bit).

Aqui vai o link do fabricante:
Espero ter ajudado!

Outras dicas deste autor

Como ver o que tem no CD antes de gravar no K3b?

Problemas com seu som?

Leitura recomendada

Acelerando o Firefox

Wireless conecta, mas não navega no Ubuntu

Wi-Fi no liveCD do Arch Linux

Melhorando a navegação no Firefox com o Adblock

Como controlar acesso a internet na sua rede?

  

Comentários
[1] Comentário enviado por baza em 08/02/2010 - 10:20h

Eu comprei idêntico notebook só que de 32bits há 7 meses. Uso Mandriva 2010.0 e até agora não consegui usar a placa wirelles ( a minha é uma AW-GU700 e usa este driver). Felizmente nesses casos a gente sempre tem a opção de usar um adaptador USB wifi.

A Microboard foge de usuários do LINUX assim como a Dilma do FHC. Esse é o grande mal das empresas nacionais: atendimento aos usuários é visto apenas como custo.

O seu comentário, caro Diego Alves, me fornece a esperança de fazer esta placa funcionar. Já estava procurando uma oficina de notebooks para substituir a wifi instalada por uma INTEL.

Abraço!

[2] Comentário enviado por baza em 08/02/2010 - 21:36h

Fui instalar e verifiquei que a coisa é mais complexa do que eu pensava. Meu kernel é 2.6.31.12-server-1mnb que é # do 2.6.31.14-generic. Portanto, acredito que seja necessário compilar o kernel para que a instalação tenha sucesso. O drive foi feito realmente para o UBUNTU e com o kernel referido.

[3] Comentário enviado por alves em 09/02/2010 - 10:05h

Caro Baza, no site do fabricante há várias opções a escolher, acredito que vc tenha escolhido a verção para 32 bits, apos baixar o arquivo vc deve encontrar um arquivo texto READ, que fala como fazer a instalação. No meu caso, estou usando o ubunto na msm verção que ele pede, então não tive problemas...funfo legal.

[4] Comentário enviado por baza em 09/02/2010 - 11:30h

Sim, Alves, obrigado pela atenção. Na verdade, estive analisando com mais profundidade e verifiquei que a única opção para aqueles que não usam o UBUNTU é mesmo compilar o kernel. Mas, para tal, é necessário o código fonte. Descobri que existem pessoas em situação idêntica a minha e que devem pelo email <[email protected]> solicitar este código do fabricante.

[5] Comentário enviado por danielmaiahist em 30/04/2010 - 08:26h

Amigos, será que alguém poderia me dar uma solução para a seguinte situação?
- Eu estou usando o novo Ubuntu 10.04, com o kernel 2.6.32-21, tenho o drive do 3DSP para o kernel antigo que funcionava legal...
Agora pergunto, é possível recompilar esse drive, ou módulo do drive, não sei...para esse novo kernel??
Aguardo resposta..
Obrigado.

[6] Comentário enviado por brunowck em 30/04/2010 - 21:45h

Estou com a mesma dúvida do usuário danielmaiabr

será que ninguem ai tem uma solução?

[7] Comentário enviado por aalexpvh em 03/05/2010 - 19:29h

Também instalei o 10.04 e deu erro por causa do Kernel. O drive do fabricante é para o kernel 2.6.31.14 generic e não consegui resolver esse problema. Todo o resto funciona perfeitamente. Essas placas esquisitas que os fabricantes colocam nos notebooks realmente são complicadas de resolver. Meu note é o Ultimate Black da Microboard e para se ter uma idéia, o Linux que veio instalado no note não funcionava. O DVD de restauração também veio errado, uma verdadeira bagunça por parte da Microboard. Agora uso o Ubuntu 9.10. Vou aguardar o drive para o 10.04, já que aqui no escritório toda a rede é wireless.

[8] Comentário enviado por romulogcerqueira em 04/05/2010 - 13:14h

To na mesma situação: Instalei o Ubuntu 10.04 e nao consigo compilar os pacotes =/

[9] Comentário enviado por aalexpvh em 04/05/2010 - 15:18h

Consegui essas instruções, só que ainda não testei. Se alguém puder testar e postar o resultado aqui, agradecemos.

Instalando a placa de rede wireless 3dsp do Notebook Microboard Ultimate Black (MUB) com o código fonte do dispositivo no Ubuntu 10.04
Lucid Lynx.

Baixar o código fonte no link que pode ser de duas formas. Via terminal:

wget http://ftp://3dsp_lpkt_usb:[email protected]/Open%20Source%20Code/BlueW-2310U_2.0.0.rar

$ 7z x BlueW-2310U_2.0.0.rar (utilize o 7-Zip ou unrar para descompactar o arquivo )

Ou download direto:

ftp://3dsp_lpkt_usb:[email protected]/Open%20Source%20Code/BlueW-2310U_2.0.0.rar

BlueW-2310U_2.0.0/
| | |
| | |___driver_src/
| |
| |_______applications/
|
|___________doc/


$ cd BlueW-2310U_2.0.0/

Instalando os Drivers:

#cd driver_src/

#make

#mv new_bluetooth/ bluetooth
#mv private/new_bluetooth_priv/ private/bluetooth_priv

(Depois do comando make, renomear as pastas: new_bluetooth para bluetooth e private/new_bluetooth_priv/ private/bluetooth_priv, pois, caso não mude, ao executar o comando make install irá ocorrer os seguintes erros: “cp: impossível obter estado de `bluetooth/3dspusbbt.ko': Arquivo ou diretório não encontrado e cp: impossível obter estado de `private/bluetooth_priv/3dspusbbtpriv.ko': Arquivo ou diretório não encontrado”)

#make install

Instalando 3DSP-WiFi-Radar

#cd applications/3dsp-wifi-radar/
#make install

Instalando uWB

#cd applications/uwb/
#chmod +x mkinstalldirs
#sh ./configure
#make
#make install

Instalando uwbtool

#cd applications/uwbtool/
#make
#make install

Editar o arquivo "/usr/local/3DSP/usb/wbusb.conf"

Em [WB], na linha 30 do arquivo de configuração, nas opções DEFAULTMODE=3 e ALLOWEDMODES=3, substituir os valores 3 para 2, (opção 3 – Coexist para opção 2 – Wlan), Caso queira utilizar o Bluetooth mudar para opção 1- BT.


[WB]
SYSTEMTRAYTIPS= WLAN/Bluetooth Card
COMPANYID=3DSP
DEFAULTMODE=3
ALLOWEDMODES=3
SHOWWARNING=0
COEXISTWARNING=The Coexist mode is only for testing!;Major.Minor.Reserved.date

Devendo ficar assim:

[WB]
SYSTEMTRAYTIPS= WLAN/Bluetooth Card
COMPANYID=3DSP
DEFAULTMODE=2
ALLOWEDMODES=2
SHOWWARNING=0
COEXISTWARNING=The Coexist mode is only for testing!;Major.Minor.Reserved.date

Observação: Creio que tem um “bug” no aplicativo uWB de conexão do dispositivo wireless, quando na opção Coexist (wireless e Bluetooth), ele desconecta e trava o aplicativo 3DSP-WiFi-Radar. No arquivo BlueW-2310U_2.0.0/README informa que caso o notebook tenha o dispositivo de HotKey, que é o caso do MUB, dever-se-á editar o arquivo de configuração no diretório /usr/local/3DSP/usb/wbusb.conf, mudando na lina 6 a opção em [BUS]
->"HOTKEYFLAG=0" para "HOTKEYFLAG=1". Fiz essa mudança e o problema continuou. O dispositivo ficava conectando e desconectando.


Iniciando o uWB

============



Aplicativos -> Acessórios -> 3DSP uWB





Iniciando o 3DSP WiFi Radar

========================



Aplicativos -> Acessórios -> 3DSP WiFi Radar

[10] Comentário enviado por eritonb em 04/05/2010 - 20:07h

As instuções são minhas. Fiz umas implementações nela, que vou colocar logo abaixo. Estou usando um MUB com Ubuntu 10.04, baixando e instalando, etc..

Antes de tudo nstalar os pacotes:
=======================================
libgnome2-dev, libnotify-dev, dhcpcd, blueman, libpolkit-dev,libpolkit2, libpolkit-dbus2, libpolkit-grant2, policykit, policykit-gnome


=======================================
seguir as instruções acima
=======================================

e

Complementar com a seguinte:

Iniciando os modulos do dispositivo automaticamente
============================
#cd /etc/init.d/
#update-rc.d tdspusbcardinit defaults


Adding system startup for /etc/init.d/tdspusbcardinit ...
/etc/rc0.d/K20tdspusbcardinit -> ../init.d/tdspusbcardinit
/etc/rc1.d/K20tdspusbcardinit -> ../init.d/tdspusbcardinit
/etc/rc6.d/K20tdspusbcardinit -> ../init.d/tdspusbcardinit
/etc/rc2.d/S20tdspusbcardinit -> ../init.d/tdspusbcardinit
/etc/rc3.d/S20tdspusbcardinit -> ../init.d/tdspusbcardinit
/etc/rc4.d/S20tdspusbcardinit -> ../init.d/tdspusbcardinit
/etc/rc5.d/S20tdspusbcardinit -> ../init.d/tdspusbcardinit

Se não conseguir navegar na Internet
================================

#echo "nameserver 208.67.222.222" > /etc/resolv.conf

[11] Comentário enviado por ubunturob em 08/05/2010 - 21:04h

amigo eritonb

este comando da erro acesso negado
#echo "nameserver 208.67.222.222" > /etc/resolv.conf

segui todos os seus posts meu não consegui conectar na internet muito menos no AP
instalei os drivers aparece na barra mas não funciona o radar(no valid wireless device) e o uWB fica inoperante cinza...
preciso de ajuda quero sair da MS.

grato

[12] Comentário enviado por eritonb em 09/05/2010 - 10:49h

....

[13] Comentário enviado por eritonb em 09/05/2010 - 11:16h

....

[14] Comentário enviado por ubunturob em 09/05/2010 - 13:52h

caro amigo eritonb muito obrigado pela sua atenção me desculpe ainda não teste pois estou mechendo no note agora
estou baixando os headers....jaja posto o resultado muito obrigado mesmo...

ps..so mais uma perguta vc ja entrou no site da 3dsp? la tem um driver atualizado 2.3.3 tentei instalar deu falha do kernel...

[15] Comentário enviado por eritonb em 09/05/2010 - 14:40h

Esses drivers não são atuais. Eles são para versão do ubuntu 9.10, kernel 2.6.31.14. Instalei com os códigos fontes, que fica mais fácil quando fizer uma atualização de kernel. Os pacotes que estão ali é somente para o kernel 2.6.31 e variantes, e não no kernel 2.6.32.

[16] Comentário enviado por ubunturob em 09/05/2010 - 15:34h

bom acho que faltou algo...

3dspusbbtpriv 563365 0
3dspusbwlan 26764 0
3dspusbwlanpriv 1353511 1 3dspusbwlan
3dspusbbus 9393 1 3dspusbwlan

deveria estar parecido com isso:

3dspusbbt 873328 0
3dspusbbtpriv 12252 1 3dspusbbt
3dspusbwlan 28616 0
3dspusbwlanpriv 1292576 1 3dspusbwlan
3dspusbbus 10308 2 3dspusbbt,3dspusbwlan

não é? como do arquivo readme

[17] Comentário enviado por ubunturob em 09/05/2010 - 15:56h

sei que ja estou abusando sou novo na aria mas quero aprender...

bom amigo meu problema persistiu o 3dsp inicia no modo off...
quando eu dou o comando para iniciar ele ate liga mas a opção wlan não esta disponivel(não aparece)

oque eu faço? agradeço sua atenção espero que possa me ajudar mas mesmo se não puder te agradeço.

[18] Comentário enviado por eritonb em 09/05/2010 - 16:05h

Está faltando o modulo 3dspusbbt.
Verifique os seguintes procedimentos
1 - instalou todos os pacotes citados no inicio do tutorial, antes de instalar os fontes;
2 - Vc criou a pasta /lib/modules/(seu kernel)/.....3DSP/
3 - copiou a pasta /usr/local/3DSP/usb/ onde estão os modulos, para a pasta criada acima;
4 - executou o comando "sudo update-rc.d tdspusbcardinit defaults" sem aspas na pasta /etc/init.d/
5 - Mudou a linha de inicialização do módulo no arquivo /etc/init.d/tdspusbcardinit, mudando a linha: insmod /usr/local/3DSP/usb/3dspusbbt.ko para insmod /lib/modules/2.6.32-22-generic/kernel/drivers/usb/3DSP/usb/3dspusbbt.ko
6 - reiniciou o sistema.


Por gentileza execute os comandos abaixo e poste os resultados:

$sudo iwconfig

$sudo ifconfig


[19] Comentário enviado por ubunturob em 09/05/2010 - 16:30h

[email protected]:~$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

twifiu0 802.11 g ESSID:"Denise" Nickname:""
NWID:off/any Mode:Managed Frequency=2.437 GHz
Access Point: 00:23:CD:C6:18:D0 Bit Rate:12 Mb/s
Retry:on RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/100
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

[email protected]:~$ $sudo ifconfig
eth0 Link encap:Ethernet Endereço de HW 00:e0:4c:00:c0:bc
inet end.: 192.168.1.102 Bcast:192.168.1.255 Masc:255.255.255.0
endereço inet6: fe80::2e0:4cff:fe00:c0bc/64 Escopo:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Métrica:1
pacotes RX:1224 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:1335 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:1000
RX bytes:975020 (975.0 KB) TX bytes:209334 (209.3 KB)
IRQ:26 Endereço de E/S:0x8000

lo Link encap:Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
endereço inet6: ::1/128 Escopo:Máquina
UP LOOPBACK RUNNING MTU:16436 Métrica:1
pacotes RX:16 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:16 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:0
RX bytes:960 (960.0 B) TX bytes:960 (960.0 B)

twifiu0 Link encap:Ethernet Endereço de HW 00:21:c5:10:e0:6d
inet end.: 192.168.1.103 Bcast:255.255.255.255 Masc:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:576 Métrica:1
pacotes RX:23510 erros:0 descartados:0 excesso:0 quadro:0
Pacotes TX:778 erros:0 descartados:0 excesso:0 portadora:0
colisões:0 txqueuelen:1000
RX bytes:4785585 (4.7 MB) TX bytes:55860 (55.8 KB)

[email protected]:~$

[20] Comentário enviado por ubunturob em 09/05/2010 - 16:34h

comando 4-

[email protected]:~$ cd /etc/init.d/
[email protected]:/etc/init.d$ sudo update-rc.d tdspusbcardinit defaults
System start/stop links for /etc/init.d/tdspusbcardinit already exist.
[email protected]:/etc/init.d$

..

creio que pequei no comando 5..

pois apenas copiei como deveria ficar..

case "$1" in
start)
insmod /usr/local/3DSP/usb/3dspusbbus.ko
sleep 1
insmod /usr/local/3DSP/usb/3dspusbwlanpriv.ko
sleep 1
insmod /usr/local/3DSP/usb/3dspusbwlan.ko
sleep 1
insmod /usr/local/3DSP/usb/3dspusbbtpriv.ko
sleep 1
##insmod /usr/local/3DSP/usb/3dspusbbt.ko
####################################################################
### Mudar aqui: #####
####################################################################
insmod /lib/modules/2.6.32-22-generic/kernel/drivers/usb/3DSP/usb/3dspusbbt.ko
sleep 1
######################################################################
mknod /dev/tdspusbbus c `awk '$2=="3dspusbbus" {print $1}' /proc/devices` 0
;;
stop)


o meu esta assim

[21] Comentário enviado por eritonb em 09/05/2010 - 16:38h

...

[22] Comentário enviado por ubunturob em 09/05/2010 - 16:59h

e

[23] Comentário enviado por ubunturob em 09/05/2010 - 17:01h

o 3dsp vem desligado no iniciar do sistema tenho que executar este comando

sudo /etc/init.d/tdspusbcardinit start para ativalo...

[24] Comentário enviado por eritonb em 09/05/2010 - 17:06h

....

[25] Comentário enviado por ubunturob em 09/05/2010 - 17:07h

e

[26] Comentário enviado por ubunturob em 09/05/2010 - 17:11h


e

[27] Comentário enviado por eritonb em 09/05/2010 - 17:12h

....

[28] Comentário enviado por ubunturob em 09/05/2010 - 17:37h

tem nada mac shild neles...kkkkkkkkkkkk

eu me conecto com o wifi radar mesmo

cara estou quase desistindo ja aff....

meu mais obrigado mesmo ...vc é profº, tem o extinto pelo menos valew mesmo.

mas ainda não funcionou...

[29] Comentário enviado por eritonb em 09/05/2010 - 17:43h

....

[30] Comentário enviado por ubunturob em 09/05/2010 - 17:46h

[email protected]:~$ sudo /etc/init.d/networking
Usage: /etc/init.d/networking {start|stop|restart|force-reload}
[email protected]:~$

[31] Comentário enviado por eritonb em 09/05/2010 - 17:50h

Dê esse último comando:
sudo /etc/init.d/networking restart

coloque restart no final esqueci...

[32] Comentário enviado por rfborgesweb em 09/05/2010 - 22:14h

Ainda sou um pouco leigo no quesito linux, então...... tem muita informação neste post, vi que os dados foram alterados constantemente, vocês poderiam me dizer passo a passo como eu poderia fazer a minha wireless funcionar, pois, com tantas modificações, não estou entendendo o post!!!, se possivel postar desde a ultima modificação, unindo as informações ao texto principal!!!

Desde já um muito obrigado!!!

Atenciosamente,


Rafael Borges!

[33] Comentário enviado por ubunturob em 10/05/2010 - 09:30h

amigo Rafael Borges!
esse é o mais atual...
caso tenha algum problema veja os topicos seguinte logo abaixo deste...

12] Comentário enviado por eritonb em 09/05/2010 - 10:49h:

Caro amigo ubunturob:

Abrir um terminal menu: Aplicativos=> Acessórios=>Terminal

# = usuário root
$ = usuário comum

Eu uso slackware e por mania eu executo sempre todos os comando como root.
No Ubuntu use o comando:
$sudo echo "nameserver 208.67.222.222" > /etc/resolv.conf

Eu reformulei os procedimentos. Siga de acordo com as instruções abaixo que você consiguirá conectar tanto o wireless, quanto o bluetooth:

Instalando a placa de rede wireless 3dsp do Notebook Microboard Ultimate Black (MUB) com o código fonte do dispositivo no Ubuntu 10.04 Lucid

Instalar os pacotes:
=======================================
libgnome2-dev, libnotify-dev, dhcpcd, blueman, libpolkit-dev,libpolkit2, libpolkit-dbus2, libpolkit-grant2, policykit, policykit-gnome, linux-headers-(seu kernel)-generic

Baixar o código fonte no link:
=============================
wget ftp://3dsp_lpkt_usb:[email protected]/Open%20Source%20Code/BlueW-2310U_2.0.0.rar

$ 7z x BlueW-2310U_2.0.0.rar (utilize o 7-Zip ou unrar para descompactar o arquivo )



BlueW-2310U_2.0.0/
| | |
| | |___driver_src/
| |
| |_______applications/
|
|___________doc/


$ cd BlueW-2310U_2.0.0/

Instalando os Drivers:

$sudo cd driver_src/

$sudo make

$sudo mv new_bluetooth/ bluetooth
$sudo mv private/new_bluetooth_priv/ private/bluetooth_priv

(Depois do comando make, renomear as pastas: new_bluetooth para bluetooth e private/new_bluetooth_priv/ private/bluetooth_priv, pois, caso não mude, ao executar o comando make install irá ocorrer os seguintes erros: “cp: impossível obter estado de `bluetooth/3dspusbbt.ko': Arquivo ou diretório não encontrado e cp: impossível obter estado de `private/bluetooth_priv/3dspusbbtpriv.ko': Arquivo ou diretório não encontrado”)

$sudo make install

Instalando 3DSP-WiFi-Radar

$cd applications/3dsp-wifi-radar/
$sudo make install

Instalando uWB

$cd applications/uwb/
$sudo chmod +x mkinstalldirs
$sudo sh ./configure
$sudo make
$sudo make install

Instalando uwbtool

$cd applications/uwbtool/
$sudo make
$sudo make install

===============================================
Editar o arquivo "/usr/local/3DSP/usb/wbusb.conf"
===============================================

Em [BUS], na opção HOTKEYFLAG=0, mudar o valor 0 para 1


[BUS]
MFCARD=3DSP WLAN and Bluetooth Card
HOTKEYFLAG=0

================================================
Devendo ficar assim:
================================================

[BUS]
MFCARD=3DSP WLAN and Bluetooth Card
HOTKEYFLAG=1


=================================================================
Logo após a instalação dos drivers dos dispositivos ocorre o erro abaixo durante o carregamento do módulo
3dspusbbt.ko, do bluetooth:
insmod: error inserting '/usr/local/3DSP/usb/3dspusbbt.ko': -1 Unknown symbol in module
make: [install] Erro 1 (ignorado)
=================================================================

Resolvendo conflito:


1 – Copie os modulos da pasta /usr/local/3DSP/usb/*.ko para uma pasta em que você deverá criar no /lib/modules/`uname --release`/kernel/drivers/usb/3DSP (observação: verifique a versão do seu kernel – uname -r ) conforme instruções logo abaixo:

=============================================================
Criando a pasta 3DSP no diretório /lib/modules/`uname --release`/kernel/drivers/usb/
=============================================================


$sudo mkdir /lib/modules/`uname --release`/kernel/drivers/usb/3DSP

==============================================================
Copiando os módulos da pasta /usr/local/3DSP/usb/ para a pasta /lib/modules/`uname --release`/kernel/drivers/usb/3DSP/
==============================================================

$sudo cp -Rf /usr/local/3DSP/usb/ /lib/modules/`uname --release`/kernel/drivers/usb/3DSP/


2 - Editar o arquivo de inicialização dos módulos: (Observação deverá colocar na linha indicada o caminho correto do kernel, identifique o seu kernel com o comando “uname -r” sem aspas, o meu é 2.6.32-22-generic que deverá ser colocado no caminho - “insmod /lib/modules/2.6.32-22-generic/....” conforme abaixo:


$sudo gedit /etc/init.d/tdspusbcardinit

=======================================================
Comentar a linha: insmod /usr/local/3DSP/usb/3dspusbbt.ko
sleep 1
========================================================
case "$1" in
start)
insmod /usr/local/3DSP/usb/3dspusbbus.ko
sleep 1
insmod /usr/local/3DSP/usb/3dspusbwlanpriv.ko
sleep 1
insmod /usr/local/3DSP/usb/3dspusbwlan.ko
sleep 1
insmod /usr/local/3DSP/usb/3dspusbbtpriv.ko
sleep 1
insmod /usr/local/3DSP/usb/3dspusbbt.ko
sleep 1
mknod /dev/tdspusbbus c `awk '$2=="3dspusbbus" {print $1}' /proc/devices` 0
;;
stop)

==========================================
Devendo ficar da seguinte forma:
==========================================

case "$1" in
start)
insmod /usr/local/3DSP/usb/3dspusbbus.ko
sleep 1
insmod /usr/local/3DSP/usb/3dspusbwlanpriv.ko
sleep 1
insmod /usr/local/3DSP/usb/3dspusbwlan.ko
sleep 1
insmod /usr/local/3DSP/usb/3dspusbbtpriv.ko
sleep 1
##insmod /usr/local/3DSP/usb/3dspusbbt.ko
####################################################################
### Mudar aqui: #####
####################################################################
insmod /lib/modules/2.6.32-22-generic/kernel/drivers/usb/3DSP/usb/3dspusbbt.ko
sleep 1
######################################################################
mknod /dev/tdspusbbus c `awk '$2=="3dspusbbus" {print $1}' /proc/devices` 0
;;
stop)

Iniciando os modulos do dispositivo automaticamente durante a inicialização do sistema
==============================================================
$cd /etc/init.d/
$sudo update-rc.d tdspusbcardinit defaults


Adding system startup for /etc/init.d/tdspusbcardinit ...
/etc/rc0.d/K20tdspusbcardinit -> ../init.d/tdspusbcardinit
/etc/rc1.d/K20tdspusbcardinit -> ../init.d/tdspusbcardinit
/etc/rc6.d/K20tdspusbcardinit -> ../init.d/tdspusbcardinit
/etc/rc2.d/S20tdspusbcardinit -> ../init.d/tdspusbcardinit
/etc/rc3.d/S20tdspusbcardinit -> ../init.d/tdspusbcardinit
/etc/rc4.d/S20tdspusbcardinit -> ../init.d/tdspusbcardinit
/etc/rc5.d/S20tdspusbcardinit -> ../init.d/tdspusbcardinit



Iniciando o uWB automaticamente
========================

Sistema -> Preferências -> Aplicativos de Seção

Na guia Progrmas Iniciais, clicar no botão adicionar
nome: uwb
comando: /usr/bin/uwb
comentário: Conexão wifi 3dsp

clicar em salvar


Iniciando a conexão automaticamente
============================

Editar o arquivo de configuração /etc/network/interfaces e acrescente as opções

$sudo gedit /etc/network/interfaces

auto twifiu0
iface twifiu0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Editar o arquivo de configuração /etc/wpa_supplicant/wpa_supplicant.conf :

$sudo gedit /etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0

network={
ssid="coloque_seu_ssid"
key_mgmt=WPA-PSK #(ou Wep - de acordo com as configurações do AP)
proto=WPA (ou WPA2 # de acordo com as configurações do AP)
pairwise=CCMP # (ou TKIP de acordo com as configurações do AP)
group=CCMP #(ou TKIP de acordo com as configurações do AP)
psk="coloque_sua _chave"

}

Reinicie o dispositivo:
$sudo /etc/init.d/networking restart
Caso não consiga conectar reinicie o Sistema.

Verifique se esses modulos foram carregados:

$sudo lsmod | grep 3dsp
3dspusbwlan 32094 0
3dspusbwlanpriv 1368904 1 3dspusbwlan
3dspusbbt 25501 2
3dspusbbtpriv 606028 1 3dspusbbt
bluetooth 58621 9 rfcomm,sco,bnep,l2cap,3dspusbbt
3dspusbbus 10561 2 3dspusbwlan,3dspusbbt

Caso não consiga navegar dê o seguinte comando:
$sudo echo "nameserver 208.67.222.222" > /etc/resolv.conf (Coloque este DNS ou o que você preferir)

Abraços


ha obs... todos comandos no terminal ok...conectado..falo boa sorte se conseguir me avisa porque o meu não deu =/...

[34] Comentário enviado por danielmaiahist em 11/05/2010 - 11:00h

Pessoal, eu quaaase consegui fazer o Wireless funcionar, cheguei ao ponto de iniciá-lo automaticamente (o ícone ficava verde), mas não conseguia navegar e o comando sudo echo "nameserver"... não funcionava, refiz todos os passos cuidadosamente, e agora o dispositivo inicia desligado.
=================================================================
eu faço o comando -> sudo /etc/init.d/networking start
e ele me passa esse resultado aqui:
=================================================================
[email protected]:~$ sudo /etc/init.d/networking restart
[sudo] password for daniel:
* Reconfiguring network interfaces... ioctl[SIOCGIFFLAGS]: No such device
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

SIOCSIFADDR: No such device
twifiu0: ERROR while getting interface flags: No such device
twifiu0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up twifiu0.
[ OK ]
[email protected]:~$ sudo /etc/init.d/networking start
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service networking start

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the start(8) utility, e.g. start networking
networking stop/waiting
[email protected]:~$
===================================================================

e agoora?? agora que virei usuário linux definitivamente, não quero deixar meu notebook MUB encostado à um cabo de rede... ehehe
minha coluna agradece...
aguardo respostas.

[35] Comentário enviado por danielmaiahist em 11/05/2010 - 12:58h

atualizando as informações...
consegui fazer o wireless funcionar, mas em algum momento ele disconectou, não sei se foi alguma oscilação ou se realmente ele não segura a transmissão dos dados...
vou testar por mais algum tempo...

[36] Comentário enviado por danielmaiahist em 12/05/2010 - 11:28h

Vamos aos relatos: venho testando essa solução para o Wireless 3DSP de ontem pra hoje e vi que não ajuda muito. A conexão não dura tanto tempo, o dispositivo se torna inoperante. Notei uma elevação imediata no uso dos recursos da CPU, talvez seja o sistema tentando manter a conexão, coisa que não acontece. As vezes o uso da CPU é tão alto, que trava a máquina, outras vezes, quando o dispositivo se desconecta, eu consigo simplesmente clicar em WLAN novamente (o ícone verde) e ele se pluga, ai temos que ir no 3DSP Wifi-radar e reconectar, o que as vezes eleva e muito o uso da CPU. Infelismente o site da Syntek Electronics parece que vive num limbo computacional e esquece de atualizar os drivers dos seus produtos para todo e qualquer sistema que seja usado, ainda mais o Linux que é atualizado a cada minuto. Nos resta esperar os desenvolvedores acordarem e vigiarem as atualizações linux ou mesmo encontrarem uma solução para a constante atualização do seu drive.

Se nada disso der certo, eu vou esperar a garantia do meu MUB acabar, comprar uma placa da Intel e meter nele.. ai sim eu vou ficar com um notebook com um ótimo custo/benefício...

Abraços aos mais insistentes ehehe

[37] Comentário enviado por eritonb em 05/06/2010 - 23:14h

Visitando o site do fabricante encontrei os drivers para o kernel 2.6.32 (Ubuntu 10.04)


Baixe o driver do fabricante:

64 bits:
http://ftp://[email protected].cn/Ubuntu/BlueW-2310U_2.4.2_amd64_100604_Ubuntu10.04_withhotkey.tar.gz

32 bits:
http://ftp://[email protected]/Ubuntu/BlueW-2310U_2.4.2_100603_Ubuntu10.04_withhotkey.tar.gz

Escolha o arquivo de acordo com a sua plataforma. Descompacte o arquivo:

$ tar xvf BlueW-2310U_2.4.2_amd64_100604_Ubuntu10.04_withhotkey.tar.gz
$ cd BlueW-2310U_2.4.2_amd64_100604_Ubuntu10.04_withhotkey
$chmod +x Install_3DSPUSB.sh
$sudo ./Install_3DSPUSB.sh
$sudo uwb && 3dsp-wifi-radar

[38] Comentário enviado por danielmaiahist em 10/06/2010 - 11:31h

Rapaz, obrigado pela atualização, baixei o arquivo, fiz a instalação como descrito, MAAAAAAAASSSS...
não estou acessando nenhuma página, dá erro de servidor, algo assim. Por incrível que pareça, eu consegui me conectar ao Skype, sinal de que dados estão sendo transmitidos. Não entendo porque o navegador (Google Chrome) não conecta, bem como o Emesene, o Synaptic também não reconhece a conexão...só o Skype, pode me explicar uma coisa dessa??

vou tentar mandar uns screens das minhas ferramentas de rede aqui pra alguém diagnosticar com o olhômetro..

http://yfrog.com/bfconectp
http://yfrog.com/5cconect2pp

[39] Comentário enviado por eritonb em 24/06/2010 - 16:20h

inicie o dispositivo e faça a conexao e depois tente o seguinte comando:
$sudo echo "nameserver 208.67.222.222" > /etc/resolv.conf

(Coloque este DNS ou o que você preferir)

[40] Comentário enviado por ubunturob em 18/08/2010 - 19:14h

eritonb consegui instala o driver mas não inicia o 3dsp na barra e o wifi radar não executa tbm.
poxa vida esse driver ta dificil. não funfo o comando---> sudo uwb && 3dsp-wifi-radar.
me ajude só mais esta vez.. ja ate desisti do linux mas vou tentar novamente. não quero mais o ruindows. grato

[41] Comentário enviado por larre em 28/09/2010 - 10:43h

Basta de tantos códigos!
Baixe o arquivo http://www.larre.com.br/linux/BlueW.tar.gz
descompacte-o, acesse o terminal, entre na pasta onde você extraiu o arquivo e digite: sudo bash Install_3DSPUSB.sh (ou copie e cole esse comando no terminal).

Não precisa configurar nada!
Abraço.

[42] Comentário enviado por danielmaiahist em 07/10/2010 - 05:21h

Larre, baixei seu arquivo, ele conseguiu ser instalado com o Kernel 2.6.32-25 (Ubuntu 10.04 x64)
mas o uWB inicia desativado. já tentei todos os passos anteriores, mas não deu certo. Como está a configuração dos seus arquivos?
dei um $sudo lsmod | grep 3dsp, mas nada apareceu. Acredito que os módulos não estão sendo carregados. O que posso fazer?

aqui vai um screenshot da situação
http://b.imagehost.org/0945/Captura_de_tela.png

Editado
----------------------
Na inicialização aparece mensagem de que não foi possível inserir os módulos
com o código de -1 Invalid Format..
Alguma idéia??

[43] Comentário enviado por larre em 11/10/2010 - 19:29h

1- Baixe o arquivo da sua plataforma;
--------------------------------
32 -> http://www.larre.com.br/linux/BlueW.tar.gz
64 -> http://www.larre.com.br/linuxBlueW64.tar.gz

2- Executar o comando dentro da pasta onde você extraiu os aquivos;
--------------------------------
~$ sudo bash Install_3DSPUSB.sh

3- Reinicie a máquina;
--------------------------------

4- Acesse o arquivo interfaces (para não conectar/habilitar apenas pelo utilitário 3DSP WiFi Radar);
--------------------------------
~$ sudo gedit /etc/network/interfaces

e acrescente o seguinte:


auto twifiu0
iface twifiu0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

5- Reinicie a máquina;
--------------------------------

6- Abra Sistema/Preferências/Aplicativos de sessão e;
Adicionar +
Nome: 3DSP WiFi Radar
Comando: su-to-root -X -c /usr/sbin/3dsp-wifi-radar
Comentário: Wireless
--------------------------------

7- Reinicie a máquina;
--------------------------------

Observações finais (em caso de ainda não funcionar):
8- Não precisaria chegar até aqui -> acessar o aquivo /etc/wpa_supplicant/wpa_supplicant.conf ,
pois ao acessar pela primeira vez o Acessórios/3DSP WiFi Radar (utilitário para conexão das redes wireless), e conectar a rede escolhida o wpa_supplicant.conf será configurado automaticamente, mas caso queira configurar manualmente, digite:

~$ sudo gedit /etc/wpa_supplicant/wpa_supplicant.conf

acrescente:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0

network={
ssid="nome do SSID"
key_mgmt=WPA-PSK # (ou WEP ou de acordo com suas configurações)
proto=RSN
pairwise=TKIP # (ou CCMP ou de acordo com suas configurações)
group=TKIP # (ou CCMP ou de acordo com suas configurações)
psk="senha de acesso"

}

LEMBRE-SE:
1- Caso o nome da rede contenha caracteres com acentos ou especiais haverá problemas na conexão, podendo ou não conectar ou não segurar o sinal;
2- Sempre que você quiser conectar a outra rede terá que acrescentar uma nova configuração - aconselho abrir o 3DSP WiFi Radar e conectar através dele para criar as configurações automaticamente.
--------------------------------

OBS: Caso a máquina não conecte automaticamente (que eu acho improvável) abra o terminal e digite;
~$ sudo dhcpclient3
~$ sudo init 6 # para reiniciar rápido
--------------------------------

[]Nota: Ao abrir o firefox -> Arquivo -> desmarque a opção Modo offline

Espero ter ajudado.
PS: funciona com kernel 2.6.32-23-generic*, o 2.6.32-25 ainda não testei.
* Conforme observações do amigo Tiago Santana enviado por email.
=======================================
Infelizmente só poderemos contar com suporte 3DSP nativo no ubuntu só no segundo semestre de 2011.

[44] Comentário enviado por eritonb em 06/02/2011 - 19:29h

Perdi a paciência com este dispositivo no linux, aqui vai a minha indignação: http://eritonb.blogspot.com/2011/02/trocando-o-dispositivo-wireless-3dsp.html

[45] Comentário enviado por noturno99 em 08/02/2011 - 22:31h

Pessoal, eu instalei o debian squeeze amd64 e tentei instalar o driver da placa wifi. Estou usando kernel 2.6.32-5-amd64 e consegui compilar tranquilo seguindo o tutorial acima dos amigos, inclusive tiver que renomear a pasta bluetooth como ele informou através do comando mv.
Até agora está funcionando beleza, o único problema que identifiquei foi que quando estou fazendo downloads, através de torrent por exemplo, o dispositivo não suporta a "pressão" e desconecta sozinho. Informa no wireless device e cai a conexão sendo necessário reiniciar e reconectar.
Pelo menos consegue navegar normal e abrir todos os aplicativos de internet.
Espero que eles atualizem o driver e corrijam as falhas.
abraço.

[46] Comentário enviado por noturno99 em 09/02/2011 - 23:16h

Oi, só para testar hoje eu instalei o ubuntu 10.10 64bits e resolvi instalar o driver da ftp que tem para essa versão de ubuntu.
Por incrível que pareça o erro que eu havia relatado usando o debian 6.0 está resolvido para o driver do ubuntu 10.10.
Estou usando normal e ele não fica caindo nem dando aquela mensagem de "no valid wireless device". Então fica aí a dica para que quiser usar o ubuntu, o driver está funcionando, pelo menos por enquanto!
A versão do kernel é a 2.6.35-22-generic.
abraço.

[47] Comentário enviado por noturno99 em 14/04/2011 - 17:22h

Pessoal, saiu uma nova versão dos fontes do driver da placa 3dsp na ftp do desenvolvedores que pode ser encontrada nas postagens acima. Eu tentei compilar, que na verdade há um script que faz todo o trabalho, no ubuntu 10.10 64 bits e funcionou beleza. Não precisou renomear diretórios nem nada. Basta que tenha instalado os headers do kernel e o pacote build-essential com os compiladores. Creio que seria uma boa testar em outras distros para verificar se ele está funcionando correto.
Por enquanto está bem no ubuntu. O processador não fica esquentando nem a conexão fica caindo, muito menos fica dando "no valid wireless device" e trava que não sai no lugar.
Espero que realmente tenha melhorado.
Valeu!

[48] Comentário enviado por prv2001 em 05/09/2011 - 23:08h

Eu comprei um notbook Microboard Ultimate Black e ele veio com esta placa de wireless que me dava muita dor de cabeça para encontrar drivers para ela, acabei perdendo a paciência e trocando a placa de wireless por uma INTEL e hoje eu só tenho a sorrir da vida com este notbook. Ele é espetacular tem me dado muito orgulho no linux, pois é bom em tudo, eu uso o UBUNTU e o DEBIAN instalado particionado. Drivers 3DSP nunca mais XÔ SAI PRA LÁ é dor de cabeça do começo até o fim. Fora que vc nunca irá encontrar eles atualizados com os distros Linux atuais, mesmo no site do desenvolvedor. A unica desvantágem desta troca de placa wireless foi a perda do Bluethoo pois não existe placa INTEL de wireless para notbook com este recurso, mais não tô nem aí, pois eu não usava mesmo. Comprei um USB que acabei resolvendo o meu problema. Hoje eu uso o que tem de mais moderno em termos de LINUX. E VIVA AO LINUX!!!!

[49] Comentário enviado por eritonb em 07/09/2011 - 07:19h

Eu troquei o meu dispositivo Bluew-2310U (da 3DSP) pelo intel 5100, e está funcionando perfeitamente. Fiz um tutorial de como trocá-lo: http://eritonb.blogspot.com/2011/02/trocando-o-dispositivo-wireless-3dsp.html, e também postei um tópico sobre os dispositivos compatíveis com o MUB: http://eritonb.blogspot.com/2011/06/intel-5100-adaptador-compativel-com-o.html

[50] Comentário enviado por d.carreira em 07/10/2011 - 20:39h

Pessoal, desisti de tentar instalar no Ubuntu 11.04 essa placa zoada da 3dsp é um lixo. Tentei uns 3 tutoriais e nada. Sabem como resolvi? Comprei a placa wireless mini pci express intel pro wm3945abg no mercado livre. Pluguei no meu Ultimate Black e foi só alegria. Esta placa não tem bluetooth, estou usando um bluetooth usb que funciona perfeitamente para isto.



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts