[RESOLVIDO] Problem with MergeList (Ubuntu, Mint, Debian, etc)

Publicado por Xerxes Lins em 26/07/2011

[ Hits: 20.972 ]

Blog: https://voidlinux.org/

 


[RESOLVIDO] Problem with MergeList (Ubuntu, Mint, Debian, etc)



Não sei a causa desse problema, mas sem motivo aparente quando realizei um update no Linux Mint me deparei com a seguinte mensagem de erro:

E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_natty-updates_multiverse_i18n_Translation-en

A mesma aparecia também quando eu abria o Synaptic.

Resolvi esse problema executando o comando:

sudo rm -r /var/lib/apt/lists/*

Não sei se há alguma forma melhor, mas essa resolveu. Caso alguém saiba uma forma melhor, favor comentar.

Obrigado.
Outras dicas deste autor

Google Chrome para Linux aqui!

Instalando sua impressora HP no LinuxMint

Instalando Compiz no Debian Jessie

Habilitando Virtualização no BIOS do HP 6005 Pro

Fish e Numix - Temas para alegrar o Desktop

Leitura recomendada

Entendendo o comando scp

ZIP no GNU/Linux

Listar todos os programas instalados no Ubuntu

Como remover permissão de vários arquivos

Substituição de strings no VI

  

Comentários
[1] Comentário enviado por removido em 30/07/2011 - 21:09h

Não tenho certeza, mas acho que a causa seriam os inúmeros processos que rodam em background: update-manager e outros programas de atualizações|notificações, costumo sugerir esses passos no fórum:

$ sudo rm -rf /var/lib/apt/lists/*
$ sudo mkdir -p /var/lib/apt/lists/partial
$ sudo touch /var/lib/apt/lists/lock

[2] Comentário enviado por noctuae em 16/05/2012 - 13:08h

Grandes colegas salvaram a minha lavoura !!!!
Grande dica , funcionou pra mim no ubuntu 12.04lts

Mas com sou iniciante na arte , pediria humildemente que os colegas comentassem esses comando pra que outros iniciantes saibam o que estão fazendo!!!

valeu , obrigado!!!

[3] Comentário enviado por panthokrator em 22/05/2012 - 18:42h

Hhehhehhe! O comando salvou meu Ubuntu também, não estava atualizando e nem instalando nada. Valeu caras, Obrigadíssimo.

[4] Comentário enviado por heldrivabit em 13/10/2012 - 18:07h

Eu estava com este problema de atualização no meu Ubuntu 12.04! Usei a dica do comentário 1 e o problema foi resolvido!
Minha mensagem era:
Lendo listas de pacotes... Erro!
W: Erro GPG: http://archive.canonical.com precise Release: As seguintes assinaturas eram inválidas: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: Erro GPG: http://br.archive.ubuntu.com precise Release: As seguintes assinaturas eram inválidas: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_i18n_Translation-en
E: As listas de pacotes ou os arquivos de estado não puderam ser analisados ou abertos.

Agora, tudo normal!!! Atualizações realizadas!!! Obrigado!!

[5] Comentário enviado por gabrielmancini em 20/10/2012 - 21:55h

aparentemente funcionou mais aconteceu isso:
W: GPG error: http://packages.pulse-eight.net precise Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 557482C280AAED87

[6] Comentário enviado por uilber em 06/08/2013 - 11:39h

Muito bom...resolveu o problema aqui no ubuntu 13.04!!!

[7] Comentário enviado por fabiokalled em 29/08/2013 - 11:06h

Cara vocês são feras mesmo. Usei o que está no comentário 1 e deu certo. Muito bom. Podem fazer.

[8] Comentário enviado por ddavidaniel em 15/05/2016 - 16:56h

no meu o problema continua aparecendo

[9] Comentário enviado por DicoO em 13/01/2019 - 12:26h

vlw kra, resolveu o meu problema do ubuntu server 16.04



Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts