Zimbra 8.0 no CentOS 6.3

Instalando servidor de e-mail usando o Zimbra 8 Open Source Edition no CentOS 6.3 64 bits.

[ Hits: 70.115 ]

Por: Alex Silva em 24/10/2012


Instalação e Configuração



Introdução

Como o objetivo é só a instalação do Zimbra, não fiz a instalação do CentOS por entender que já tenham uma Lab com um máquina instalada.

A instalação foi feita do zero, usando a instalação minimal do CentOS, só com o pacotes básicos, pois o Zimbra já inclui todos os pacotes necessários para o seu funcionamento.

Softwares necessários

Para iniciar o processo de configuração, primeiramente precisamos baixar/instalar alguns pacotes. São eles:
  • bind;
  • nc;
  • sysstat;
  • perl;
  • weget;
  • vim;
  • zimbra.

Ao instalar o CentOS, é instalado por default um servidor de e-mail para envio de mensagens locais, o Postfix. Precisamos, assim, parar e remover o Postfix da inicialização, pois o Zimbra já possui o Postfix e, se deixarmos ele rodando, o Zimbra não vai subir.

Sendo assim, vamos parar e tirar o serviço do boot:

# service postfix stop
# chkconfig --del postfix


Agora, vamos instalar os pacotes para podermos iniciar a instalação:

# yum install bind bind-utils nc sysstat perl wget vim

Pronto, agora estamos com o todos o requisitos necessários para a configuração do DNS e a instalação do Zimbra em si.

Configurando

Bom, agora com o pacotes instalados em seu sistema, vamos para à parte de configuração do named. Execute os comandos:

# cd /etc/
# cp -p named.conf named.conf-original
# > named.conf
# vim named.conf


Adicionaremos o seguinte conteúdo ao arquivo "named.conf":

# vim db.zmexemplo.com.br

$TTL    86400
@       IN      SOA     zmail.zmexemplo.com.br. root.zmail.zmexemplo.com.br. (
                                10118      ; Serial
                                43200      ; Refresh
                                3600       ; Retry
                                3600000    ; Expire
                                2592000 )  ; Minimum
          IN          NS         zmail.zmexemplo.com.br.
          MX         10          zmail.zmexemplo.com.br.
zmail            IN          A          192.168.0.252


Feito isso, agora iremos gerar a chave:

# rndc-confgen -a -c /etc/rndc.key

Obs.: Deve demorar uns minutinhos.

Configurando o /etc/resolv.conf:

# vim /etc/resolv.conf

Edite:

search zmexemplo.com.br
nameserver 192.168.0.252


Testando o serviço DNS

Testando a configuração do named:

# service named configtest

No retorno deste comando, deve vir algo assim:
zone zmexemplo.com.br/IN: loaded serial 10118


Se estiver tudo ok, execute:

# service named restart

Caso dê algum erro, verifique no /var/log/messenges. Se tiver algum erro de permissão, verificar a permissão com:

# ls -l /etc/rndc.key

Ou, faça da seguinte maneira:

# chown root:named /etc/rndc.key
# service named restart [ok] está tudo certo


Se não deu erro, podemos continuar. Agora vamos editar o /etc/hosts:

# vim /etc/hosts

Edite:

127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
192.168.0.252 zmail.zmexemplo.com.br zmail
::1       localhost localhost.localdomain localhost6 localhost6.localdomain6


Feito assim, salve a configuração a partiremos para testar o serviço DNS:

# dig +short zmail.zmexemplo.com.br

No retorno do comando dig, deverá vir o IP do servidor. No meu caso:
192.168.0.252
# dig -x 192.168.0.252 # Numero do servidor


Assim, terminamos essa parte. Agora vamos iniciar a instalação do Zimbra.

    Próxima página

Páginas do artigo
   1. Instalação e Configuração
   2. Baixando e instalando o Zimbra 8
   3. Firewall - Chat - Screenshots
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Como acessar contas do Hotmail no seu cliente de e-mail Linux

Evosign - Adicionar assinatura automática ao Evolution

Tutorial: Como instalar o Openfire (Wildfire) no Kubuntu 7.10 (Gutsy Gibbon) com o "copiar e colar"

Configurar autenticação no Postfix

Alta disponibilidade com Debian Lenny + Heartbeat + DRBD8 + OCFS2 + MONIT + LVS

  
Comentários
[1] Comentário enviado por danniel-lara em 25/10/2012 - 09:36h

Parabéns pelo artigo

[2] Comentário enviado por eduardo em 25/10/2012 - 20:09h

Muito bom o artigo. Parabéns!

[3] Comentário enviado por nelsonjfedalto em 25/10/2012 - 21:29h

Otimo artigo. Ficou bem detalhado e estruturado certinho. Parabéns!

Att

[4] Comentário enviado por cooperbr em 31/10/2012 - 15:38h

Sabes me dizer se e normal, instalei uma vm com vmware

executei
rndc-confgen -a -c /etc/rndc.key

pasou 1 hora que continua sem dar um ok ou algo assim.

sabes o que poderia ter feito errado

obrigado


[5] Comentário enviado por l0g1in em 31/10/2012 - 16:56h

Olá cooperbr, service named stop (CentOS/RedHat) service bind stop (Debian/Ubuntu) verifica as permissões do arquivos ls -l /etc/rndc.key
chown root:named /etc/rndc.key (CentOS/RedHat)
chown root:bind /etc/rndc.key (Debian/Ubuntu)
Caso esteja corretas tente limpar o arquivo e gerar novamente > /etc/rndc.key
rode o comando novamente rndc-confgen -a -c /etc/rndc.key demora realmente mais é muito pouco, se demorar tente olhar os (CentOS/RedHat) /var/log/messenges e se algo, (Debian/Ubuntu) /usr/sbin/named -g bem mais facil encontrar o erro.
Abraços [];

[6] Comentário enviado por ultrazone em 05/03/2013 - 03:05h

No meu caso instalei o zimbra 8 , mas meu DNS esta no 2008 R2, como ficaria os parametros no arquivo "db.zmexemplo.com.br" e "named.conf"

[7] Comentário enviado por l0g1in em 08/03/2013 - 12:06h

ultrazone, o db.zmexemplo e o named.conf não como chama no Windows Server 2008 R2, você tem que criar eles todos no Windows ai no servidor Zimbra /etc/resolv.conf você coloca o IP DNS do seu servidor DNS, no caso windows server, já fiz isso pra teste usando duas distribuição Linux uma como DNS outra só para o servidor de email Windows como DNS eu nunca fiz.

/etc/resolv.conf
search DOMINIO.COM.BR
nameserver IP_DNS_SERVIDOR_WIN_2008

[8] Comentário enviado por rkslinux em 28/04/2013 - 23:56h

Alex,

Preciso de uma grande ajuda sobre o Zimbra, versão 8. Olha só, a minha empresa passou a utilizar o serviço de DNS do UOL. Infelizmente, não pude fazer nada, mas prefiro o BIND 9 sob a minha administração. Vou direto ao assunto:

Configurei o Zimbra 8 na minha empresa, versão Open Source. Agora, preciso usar o bendito DNS do UOL para enviar e receber os e-mails do Zimbra. No entanto, só consigo enviar os e-mails; não consigo receber de forma alguma. Sei que o problema está no DNS UOL, mas mesmo assim estou com alguma dúvidas sobre a configuração diante dessa mudança de DNS.

Por se tratar de um DNS Externo, preciso fazer algum tipo de Relay para o SMTP do UOL, no Zimbra? Se for necessário, preciso configurar só nas configurações globais, ou preciso alterar na Class Of Service(COS), também? Preciso fazer alguma configuração especial sobre o MX, por ser do UOL, também?

SMTP Uol: smtp.clusterxx.whservidor.com
MX Uol: mx.clusterxx.whservidor.com

Fiz os apontamentos da nossa máquina Zimbra, no UOL, mas não consigo receber os e-mails de forma alguma. Por favor, se puder me ajudar, ficarei muito grato!

Um abraço,

Robson

[9] Comentário enviado por youkay em 05/06/2013 - 09:26h

Poderia fazer algum tutorial com o Ubuntu 12.04?

[10] Comentário enviado por juzehh em 10/07/2013 - 11:15h

Olá aletrindadee

Tenho um cliente que usa o zimbra 7 e estamos tentando implantar o zimbra 8 para uma nova filial com um dominio diferente com o ambiente igual.

No caso temos um software pago mensalmente para capturar os emails filtrar virus/spam e reencaminhar para o zimbra, para isso mudamos a porta
do postfix para 10026 e tudo funciona perfeitamente.

Porem no caso do zimbra 8, quando mudamos a porta para 10026, o mta falha na inicialização.

Tem alguma ideia que possa nos ajudar a resolver essa falha?

Parabens pelo artigo.

[11] Comentário enviado por gabrieldsinfo em 08/08/2013 - 16:22h

Ótimo Artigo, Parabéns!

[12] Comentário enviado por gilpires em 29/10/2013 - 02:16h

Pow cara, eu segui os passos todos certos

Mas não passo daqui.

Se estiver tudo ok, execute:

# service named restart

Caso dê algum erro, verifique no /var/log/messenges. Se tiver algum erro de permissão, verificar a permissão com:

# ls -l /etc/rndc.key

Ou, faça da seguinte maneira:

# chown root:named /etc/rndc.key
# service named restart [ok] está tudo certo


o named não levante :/

eu olhei os logs e ele diz que a permissão no rndc.key foi negada. mas eu fiz o chown tudo certo e ainda não vai :/

[13] Comentário enviado por l0g1in em 30/10/2013 - 12:00h

Cara se nos logs está dando erro de permissão é porque tem erro de permissão.

[14] Comentário enviado por jeffersonclaud em 09/03/2014 - 15:49h

Boa tarde


Gostaria de saber de alguém pode me ajudar, instalei o zimbra mas não consigo acessar webmail cliente via https:// IP do servidor ou https://mail.nome do dominio , mas a pagina de Adm do zimbra consigo acessar somente não webmail cliente alguém saber se e necessário fazer alguma configuração ou onde pode estar o erro até desativei o iptables mesmo assim não abre webmail clinete no zimbra

Por favor me ajudem


Jefferson

[15] Comentário enviado por l0g1in em 14/03/2014 - 10:28h

- Esse é o console do Admin:
https://IP_DO_SERVIDOR:7071

- Interface do Webmail:
https://IP_DO_SERVIDOR

Você já chegou a verificar se se todos os serviços estão rodando no zimbra ?

su - zimbra e roda o comando abaixo verifica se está tudo funcionando
zmcontrol status

Posta o erro que dá ai fazendo um favor...

[16] Comentário enviado por rafael001_2 em 11/04/2014 - 09:18h

Ótimo tutorial, muito obrigado, vai me ajudar bastante.

Porém esta acontecendo algo no meu servidor. Consigo enviar emails normalmente, porém não recebo.
Ao tentar enviar uma mensagem para o servidor de algum outro email ele retorna a mensagem dando erro de acesso negado. Gostaria da ajuda de vocês para resolver esta questão, pois já verifiquei toda a configuração do servidor e não achei nada de diferente.

Segue mensagem que o servidor retorna.

"Delivery to the following recipient failed permanently:

[email protected]

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain luce-imperial.com.br by luce-imperial.no-ip.org. [].

The error that the other server returned was:
554 5.7.1 <[email protected]>: Relay access denied"

Desde já obrigado!

[17] Comentário enviado por l0g1in em 11/04/2014 - 10:41h

Caro rafael001_2, pelo que deu pra entender seu servidor está em uma BlackList de Spam, teria que verificar essa situação e fazer a remoção do mesmo.

[18] Comentário enviado por rafael001_2 em 11/04/2014 - 10:44h

Olá Root360,

Acabei de criar o servidor, nem cheguei a utilizar este domínio ainda para nada, só usei para o servidor de email que criei agora.
Será q foi bloqueado sem mesmo enviar emails?

Obrigado pela resposta.

[19] Comentário enviado por l0g1in em 11/04/2014 - 10:53h

dá uma consultada nesses site:

http://mxtoolbox.com/blacklists.aspx

http://www.spamhaus.org/lookup/

[20] Comentário enviado por rafael001_2 em 11/04/2014 - 11:02h

Parece q obtive 3 bloqueios no site mxtoolbox.
Segue retorno do site.

Blacklist Razão TTL ResponseTime
ABERTA BARRACUDA 189.3.58.98 foi listado Detalhe 29770 187 Ignorar
ABERTA RATOS NoPtr 189.3.58.98 foi listado Detalhe 3369 94 Ignorar
ABERTA SPAM SORBS 189.3.58.98 foi listado Detalhe 3600 94 Ignorar

Como posso proceder neste caso?

Obrigado!

[21] Comentário enviado por l0g1in em 11/04/2014 - 11:09h

Pedir a retirada pelo site mesmo.

[22] Comentário enviado por rafael001_2 em 11/04/2014 - 11:30h

Obrigado, vou ver se acho a opção de pedir a remoção no site.

[23] Comentário enviado por rafael001_2 em 29/04/2014 - 14:51h

Olá,

Desculpe a insistência, mas agora está ocorrendo um outro erro.
Consegui implantar o servidor, estava enviando e recebendo corretamente em uma conta de teste que criei, porém parou de enviar e receber repentinamente, procurando o que poderia ser achei algo meio estranho, percebi que a fila de e-mail esta crescendo descontroladamente no servidor.
Segue abaixo link da imagem de um print que tirei.

http://www.imagebam.com/image/948c81323625479

Será que tem algo configurado errado no servidor?

[24] Comentário enviado por l0g1in em 30/04/2014 - 10:48h


[23] Comentário enviado por rafael001_2 em 29/04/2014 - 14:51h:

Olá,

Desculpe a insistência, mas agora está ocorrendo um outro erro.
Consegui implantar o servidor, estava enviando e recebendo corretamente em uma conta de teste que criei, porém parou de enviar e receber repentinamente, procurando o que poderia ser achei algo meio estranho, percebi que a fila de e-mail esta crescendo descontroladamente no servidor.
Segue abaixo link da imagem de um print que tirei.

http://www.imagebam.com/image/948c81323625479

Será que tem algo configurado errado no servidor?



Cara pode o teu DNS Reverso ou está em alguma blacklist dá uma verficada no DNS Reverso, coloca o mouse em cima da msg e se mostra algum erro, verifica também os logs do zimbra deve mostrar alguma coisa lá.



[25] Comentário enviado por rafael001_2 em 30/04/2014 - 11:51h

E este aumento de mensagens?
Só tenho 2 contas configuradas e não estava enviando emails por ela no momento, será que meu servidor esta distribuindo SPAM?
Posso te adicionar no skype para podermos conversar?
Obrigado.

[26] Comentário enviado por renatomartins_3 em 11/08/2014 - 20:40h

Essa versão é gratuita ?
até quantas contas de emails ?


Contribuir com comentário




Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts