VTUN e VELOX

A questão é: como montar um túnel com IP dinâmico? Usando Velox e NO-IP não é tão difícil, vou tentar explicar passo-a-passo e de maneira mais clara possível como montar um túnel entre dois servidores Linux remoto. Devo lembrar que montei sem ter problema algum usando o Conectiva 10.

[ Hits: 26.885 ]

Por: Luciano Gomes em 03/04/2008


Finalizando



Antes de subir o serviço, acerte seu firewall nos dois servidores com as seguintes regras:

iptables -A FORWARD -i tun+ -j ACCEPT

iptables -A INPUT -p tcp --dport 5000 -j ACCEPT
iptables -A INPUT -p udp --dport 5000 -j ACCEPT

iptables -I INPUT -i tun+ -j ACCEPT
iptables -I OUTPUT -o tun+ -j ACCEPT
iptables -I FORWARD -i tun+ -j ACCEPT
iptables -I FORWARD -o tun+ -j ACCEPT

iptables -A INPUT -i tun+ -j ACCEPT
iptables -A FORWARD -i tun+ -j ACCEPT

Certifique-se que não tenha nenhum processo do vtund rodando com o comando: ps -aux

Caso tenha, execute: killall vtund

Pronto, agora sim no servidor do Rio de Janeiro basta subir o serviço com o comando: vtund -s

E no servidor de São Paulo: vtund SP riodejaneiro.sytes.net

Não esqueça de acertar os rc.local de cada servidor.

Página anterior    

Páginas do artigo
   1. Introdução
   2. Instalação e configuração do VTUN
   3. Instalação e configuração do NO-IP
   4. Finalizando
Outros artigos deste autor
Nenhum artigo encontrado.
Leitura recomendada

Como transformar seu DVD/RW em um disco de backup como se fosse um HD convencional

Instalando Slackware 11.0 em um pendrive

Minix 3.2.0 no ESXi 5.0 - Instalação usando o vSphere Client 5.0

Novo método de instalação do Arch Linux (systemd)

NoBreak SMS e Gnu/Linux (FC5) - Parte 3 - Comunicação entre os servidores Linux sem senha

  
Comentários
[1] Comentário enviado por diekn em 03/04/2008 - 07:33h

Fala ai amigo,desde ja,parabens,vou testar no debian,caso tenha sucesso,coloco aqui.Grande abraço.

[2] Comentário enviado por lucianopqd em 03/04/2008 - 08:04h

Blz, qualquer dúvida é só postar...

[3] Comentário enviado por wakeup em 03/04/2008 - 19:58h

Boa noite, da matriz de dentro do firewall pingo a filial, mas da rede interna debaixo do nat nada feito, sei que o problema é a rota mas já tendei de todo jeito nada... da filial nao pingo nada... Alguma luz..??

matriz:
192.168.1.1
255.255.255.0

filial:

10.0.0.138
255.255.255.0

[4] Comentário enviado por lucianopqd em 04/04/2008 - 08:01h

A sua filial está com a rede errada, se vc está usando IP de classe A sua submascara tem que ser 255.0.0.0, e antes de pingar execute "ifconfig" para ver se as interfaces TUN subiram... e outra coisa o ideal é que os computadores da sua filial estajam em uma rede classe C, só o tunel na Classe A.


Contribuir com comentário